gnu: metabat: Update to 0.32.4-1.cbdca756.
* gnu/packages/bioinformatics.scm (metabat): Update to 0.32.4-1.cbdca756. * gnu/packages/patches/metabat-remove-compilation-date.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.master
parent
47c14714a4
commit
2c3eb4b85b
|
@ -691,6 +691,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/mcrypt-CVE-2012-4409.patch \
|
||||
%D%/packages/patches/mcrypt-CVE-2012-4426.patch \
|
||||
%D%/packages/patches/mcrypt-CVE-2012-4527.patch \
|
||||
%D%/packages/patches/metabat-remove-compilation-date.patch \
|
||||
%D%/packages/patches/mhash-keygen-test-segfault.patch \
|
||||
%D%/packages/patches/mpc123-initialize-ao.patch \
|
||||
%D%/packages/patches/mplayer2-theora-fix.patch \
|
||||
|
|
|
@ -3221,18 +3221,23 @@ form of assemblies or reads.")
|
|||
license:cpl1.0)))) ; Open Bloom Filter
|
||||
|
||||
(define-public metabat
|
||||
(package
|
||||
(name "metabat")
|
||||
(version "0.26.3")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
"https://bitbucket.org/berkeleylab/metabat/get/"
|
||||
version ".tar.bz2"))
|
||||
(file-name (string-append name "-" version ".tar.bz2"))
|
||||
(sha256
|
||||
(base32
|
||||
"1vpfvgsn8wdsv1g7z73zxcncskx7dy7bw5msg1hhibk25ay11pyg"))))
|
||||
;; We package from a git commit because compilation of the released version
|
||||
;; fails.
|
||||
(let ((commit "cbdca756993e66ae57e50a27970595dda9cbde1b"))
|
||||
(package
|
||||
(name "metabat")
|
||||
(version (string-append "0.32.4-1." (string-take commit 8)))
|
||||
(source
|
||||
(origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
(url "https://bitbucket.org/berkeleylab/metabat.git")
|
||||
(commit commit)))
|
||||
(file-name (string-append name "-" version))
|
||||
(sha256
|
||||
(base32
|
||||
"0byia8nsip6zvc4ha0qkxkxxyjf4x7jcvy48q2dvb0pzr989syzr"))
|
||||
(patches (search-patches "metabat-remove-compilation-date.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:phases
|
||||
|
@ -3299,7 +3304,7 @@ enables the study of individual organisms and their interactions. MetaBAT is
|
|||
an automated metagenome binning software, which integrates empirical
|
||||
probabilistic distances of genome abundance and tetranucleotide frequency.")
|
||||
(license (license:non-copyleft "file://license.txt"
|
||||
"See license.txt in the distribution."))))
|
||||
"See license.txt in the distribution.")))))
|
||||
|
||||
(define-public minced
|
||||
(package
|
||||
|
|
|
@ -0,0 +1,16 @@
|
|||
Remove the reference to the compilation date so that the build is
|
||||
reproducible.
|
||||
|
||||
diff --git a/src/metabat.cpp b/src/metabat.cpp
|
||||
index 88e06de..c95cb1a 100644
|
||||
--- a/src/metabat.cpp
|
||||
+++ b/src/metabat.cpp
|
||||
@@ -49,7 +49,7 @@ int main(int ac, char* av[]) {
|
||||
po::notify(vm);
|
||||
|
||||
if (vm.count("help") || inFile.length() == 0 || outFile.length() == 0) {
|
||||
- cerr << "\nMetaBAT: Metagenome Binning based on Abundance and Tetranucleotide frequency (version " << version << "; " << __DATE__ << " " << __TIME__ << ")" << endl;
|
||||
+ cerr << "\nMetaBAT: Metagenome Binning based on Abundance and Tetranucleotide frequency (version " << version << "; unknown compilation date)" << endl;
|
||||
cerr << "by Don Kang (ddkang@lbl.gov), Jeff Froula, Rob Egan, and Zhong Wang (zhongwang@lbl.gov) \n" << endl;
|
||||
cerr << desc << endl << endl;
|
||||
|
Reference in New Issue