gnu: perl-www-curl: Fix build with curl@7.69.1.
* gnu/packages/web.scm (perl-www-curl)[source]: Add perl-www-curl-fix-struct-void.patch. * gnu/packages/patches/perl-www-curl-remove-symbol.patch: Update. * gnu/packages/patches/perl-www-curl-fix-struct-void.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.master
parent
16144199c3
commit
2c560aa217
|
@ -1450,6 +1450,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/perl-text-markdown-discount-unbundle.patch \
|
||||
%D%/packages/patches/perl-module-pluggable-search.patch \
|
||||
%D%/packages/patches/perl-reproducible-build-date.patch \
|
||||
%D%/packages/patches/perl-www-curl-fix-struct-void.patch \
|
||||
%D%/packages/patches/perl-www-curl-remove-symbol.patch \
|
||||
%D%/packages/patches/picard-fix-id3-rename-test.patch \
|
||||
%D%/packages/patches/picprog-non-intel-support.patch \
|
||||
|
|
|
@ -0,0 +1,24 @@
|
|||
From: Tobias Geerinckx-Rice <me@tobias.gr>
|
||||
Date: Sat, 14 Nov 2020 15:40:56 +0100
|
||||
Subject: [PATCH] gnu: perl-www-curl: Fix struct void* usage.
|
||||
|
||||
Copied verbatim from Gentoo[0]. Fixes:
|
||||
|
||||
Curl.xs:76:12: error: expected ‘{’ before ‘void’
|
||||
struct void *curlm;
|
||||
^~~~
|
||||
Curl.xs:76:12: error: two or more data types in declaration specifiers
|
||||
|
||||
[0]: https://694466.bugs.gentoo.org/attachment.cgi?id=595098
|
||||
|
||||
--- WWW-Curl-4.17/Curl.xs 2014-02-21 18:08:30.000000000 +0200
|
||||
+++ WWW-Curl-4.17.new/Curl.xs 2019-11-05 21:44:55.434395739 +0200
|
||||
@@ -73,7 +73,7 @@ typedef struct {
|
||||
#ifdef __CURL_MULTI_H
|
||||
struct CURLM *curlm;
|
||||
#else
|
||||
- struct void *curlm;
|
||||
+ void *curlm;
|
||||
#endif
|
||||
} perl_curl_multi;
|
||||
|
Binary file not shown.
|
@ -4423,14 +4423,14 @@ RFC 6570.")
|
|||
(uri (string-append
|
||||
"mirror://cpan/authors/id/S/SZ/SZBALINT/WWW-Curl-"
|
||||
version".tar.gz"))
|
||||
(patches (search-patches "perl-www-curl-remove-symbol.patch"))
|
||||
(patches (search-patches "perl-www-curl-fix-struct-void.patch"
|
||||
"perl-www-curl-remove-symbol.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"1fmp9aib1kaps9vhs4dwxn7b15kgnlz9f714bxvqsd1j1q8spzsj"))))
|
||||
(build-system perl-build-system)
|
||||
(arguments
|
||||
'(#:tests? #f ;XXX: tests require network access
|
||||
|
||||
#:phases (modify-phases %standard-phases
|
||||
(add-before 'configure 'set-search-path
|
||||
(lambda _
|
||||
|
|
Reference in New Issue