gnu: findutils: Fix build with glibc 2.28.
* gnu/packages/patches/findutils-gnulib-libio.patch, gnu/packages/patches/findutils-makedev.patch: New files. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/base.scm (findutils)[source](patches): Use them.master
parent
8c8ded2cc9
commit
2fa4066c0a
|
@ -671,7 +671,9 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/fcgi-2.4.0-poll.patch \
|
%D%/packages/patches/fcgi-2.4.0-poll.patch \
|
||||||
%D%/packages/patches/fifo-map-fix-flags-for-gcc.patch \
|
%D%/packages/patches/fifo-map-fix-flags-for-gcc.patch \
|
||||||
%D%/packages/patches/fifo-map-remove-catch.hpp.patch \
|
%D%/packages/patches/fifo-map-remove-catch.hpp.patch \
|
||||||
|
%D%/packages/patches/findutils-gnulib-libio.patch \
|
||||||
%D%/packages/patches/findutils-localstatedir.patch \
|
%D%/packages/patches/findutils-localstatedir.patch \
|
||||||
|
%D%/packages/patches/findutils-makedev.patch \
|
||||||
%D%/packages/patches/findutils-test-xargs.patch \
|
%D%/packages/patches/findutils-test-xargs.patch \
|
||||||
%D%/packages/patches/flann-cmake-3.11.patch \
|
%D%/packages/patches/flann-cmake-3.11.patch \
|
||||||
%D%/packages/patches/flint-ldconfig.patch \
|
%D%/packages/patches/flint-ldconfig.patch \
|
||||||
|
|
|
@ -298,7 +298,9 @@ interactive means to merge two files.")
|
||||||
(base32
|
(base32
|
||||||
"178nn4dl7wbcw499czikirnkniwnx36argdnqgz4ik9i6zvwkm6y"))
|
"178nn4dl7wbcw499czikirnkniwnx36argdnqgz4ik9i6zvwkm6y"))
|
||||||
(patches (search-patches
|
(patches (search-patches
|
||||||
|
"findutils-gnulib-libio.patch"
|
||||||
"findutils-localstatedir.patch"
|
"findutils-localstatedir.patch"
|
||||||
|
"findutils-makedev.patch"
|
||||||
"findutils-test-xargs.patch"))
|
"findutils-test-xargs.patch"))
|
||||||
(modules '((guix build utils)))
|
(modules '((guix build utils)))
|
||||||
(snippet
|
(snippet
|
||||||
|
|
|
@ -0,0 +1,114 @@
|
||||||
|
Adjust to removal of libio interface in glibc 2.28.
|
||||||
|
|
||||||
|
Based on this gnulib commit:
|
||||||
|
https://git.savannah.gnu.org/cgit/gnulib.git/commit/?id=4af4a4a71827c0bc5e0ec67af23edef4f15cee8e
|
||||||
|
|
||||||
|
diff --git a/gl/lib/fflush.c b/gl/lib/fflush.c
|
||||||
|
index 5ae3e41..7a82470 100644
|
||||||
|
--- a/gl/lib/fflush.c
|
||||||
|
+++ b/gl/lib/fflush.c
|
||||||
|
@@ -33,7 +33,7 @@
|
||||||
|
#undef fflush
|
||||||
|
|
||||||
|
|
||||||
|
-#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
||||||
|
+#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
||||||
|
|
||||||
|
/* Clear the stream's ungetc buffer, preserving the value of ftello (fp). */
|
||||||
|
static void
|
||||||
|
@@ -72,7 +72,7 @@ clear_ungetc_buffer (FILE *fp)
|
||||||
|
|
||||||
|
#endif
|
||||||
|
|
||||||
|
-#if ! (defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */)
|
||||||
|
+#if ! (defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */)
|
||||||
|
|
||||||
|
# if (defined __sferror || defined __DragonFly__ || defined __ANDROID__) && defined __SNPT
|
||||||
|
/* FreeBSD, NetBSD, OpenBSD, DragonFly, Mac OS X, Cygwin, Android */
|
||||||
|
@@ -148,7 +148,7 @@ rpl_fflush (FILE *stream)
|
||||||
|
if (stream == NULL || ! freading (stream))
|
||||||
|
return fflush (stream);
|
||||||
|
|
||||||
|
-#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
||||||
|
+#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
||||||
|
|
||||||
|
clear_ungetc_buffer_preserving_position (stream);
|
||||||
|
|
||||||
|
diff --git a/gl/lib/fpurge.c b/gl/lib/fpurge.c
|
||||||
|
index f313b22..ecdf82d 100644
|
||||||
|
--- a/gl/lib/fpurge.c
|
||||||
|
+++ b/gl/lib/fpurge.c
|
||||||
|
@@ -62,7 +62,7 @@ fpurge (FILE *fp)
|
||||||
|
/* Most systems provide FILE as a struct and the necessary bitmask in
|
||||||
|
<stdio.h>, because they need it for implementing getc() and putc() as
|
||||||
|
fast macros. */
|
||||||
|
-# if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
||||||
|
+# if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
||||||
|
fp->_IO_read_end = fp->_IO_read_ptr;
|
||||||
|
fp->_IO_write_ptr = fp->_IO_write_base;
|
||||||
|
/* Avoid memory leak when there is an active ungetc buffer. */
|
||||||
|
diff --git a/gl/lib/freadahead.c b/gl/lib/freadahead.c
|
||||||
|
index 094daab..3f8101e 100644
|
||||||
|
--- a/gl/lib/freadahead.c
|
||||||
|
+++ b/gl/lib/freadahead.c
|
||||||
|
@@ -25,7 +25,7 @@
|
||||||
|
size_t
|
||||||
|
freadahead (FILE *fp)
|
||||||
|
{
|
||||||
|
-#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
||||||
|
+#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
||||||
|
if (fp->_IO_write_ptr > fp->_IO_write_base)
|
||||||
|
return 0;
|
||||||
|
return (fp->_IO_read_end - fp->_IO_read_ptr)
|
||||||
|
diff --git a/gl/lib/freading.c b/gl/lib/freading.c
|
||||||
|
index 0512b19..8c48fe4 100644
|
||||||
|
--- a/gl/lib/freading.c
|
||||||
|
+++ b/gl/lib/freading.c
|
||||||
|
@@ -31,7 +31,7 @@ freading (FILE *fp)
|
||||||
|
/* Most systems provide FILE as a struct and the necessary bitmask in
|
||||||
|
<stdio.h>, because they need it for implementing getc() and putc() as
|
||||||
|
fast macros. */
|
||||||
|
-# if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
||||||
|
+# if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
||||||
|
return ((fp->_flags & _IO_NO_WRITES) != 0
|
||||||
|
|| ((fp->_flags & (_IO_NO_READS | _IO_CURRENTLY_PUTTING)) == 0
|
||||||
|
&& fp->_IO_read_base != NULL));
|
||||||
|
diff --git a/gl/lib/fseeko.c b/gl/lib/fseeko.c
|
||||||
|
index 1c65d2a..9026408 100644
|
||||||
|
--- a/gl/lib/fseeko.c
|
||||||
|
+++ b/gl/lib/fseeko.c
|
||||||
|
@@ -47,7 +47,7 @@ fseeko (FILE *fp, off_t offset, int whence)
|
||||||
|
#endif
|
||||||
|
|
||||||
|
/* These tests are based on fpurge.c. */
|
||||||
|
-#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
||||||
|
+#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
||||||
|
if (fp->_IO_read_end == fp->_IO_read_ptr
|
||||||
|
&& fp->_IO_write_ptr == fp->_IO_write_base
|
||||||
|
&& fp->_IO_save_base == NULL)
|
||||||
|
@@ -123,7 +123,7 @@ fseeko (FILE *fp, off_t offset, int whence)
|
||||||
|
return -1;
|
||||||
|
}
|
||||||
|
|
||||||
|
-#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
||||||
|
+#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
||||||
|
fp->_flags &= ~_IO_EOF_SEEN;
|
||||||
|
fp->_offset = pos;
|
||||||
|
#elif defined __sferror || defined __DragonFly__ || defined __ANDROID__
|
||||||
|
diff --git a/gl/lib/stdio-impl.h b/gl/lib/stdio-impl.h
|
||||||
|
index 502d891..ea38ee2 100644
|
||||||
|
--- a/gl/lib/stdio-impl.h
|
||||||
|
+++ b/gl/lib/stdio-impl.h
|
||||||
|
@@ -18,6 +18,12 @@
|
||||||
|
the same implementation of stdio extension API, except that some fields
|
||||||
|
have different naming conventions, or their access requires some casts. */
|
||||||
|
|
||||||
|
+/* Glibc 2.28 made _IO_IN_BACKUP private. For now, work around this
|
||||||
|
+ problem by defining it ourselves. FIXME: Do not rely on glibc
|
||||||
|
+ internals. */
|
||||||
|
+#if !defined _IO_IN_BACKUP && defined _IO_EOF_SEEN
|
||||||
|
+# define _IO_IN_BACKUP 0x100
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
/* BSD stdio derived implementations. */
|
||||||
|
|
|
@ -0,0 +1,22 @@
|
||||||
|
Include <sys/sysmacros.h> for "makedev".
|
||||||
|
|
||||||
|
Taken from this gnulib commit:
|
||||||
|
https://git.savannah.gnu.org/cgit/gnulib.git/commit/?id=4da63c5881f60f71999a943612da9112232b9161
|
||||||
|
|
||||||
|
diff --git a/gl/lib/mountlist.c b/gl/lib/mountlist.c
|
||||||
|
index bb4e4ee21..cf4020e2a 100644
|
||||||
|
--- a/gl/lib/mountlist.c
|
||||||
|
+++ b/gl/lib/mountlist.c
|
||||||
|
@@ -37,6 +37,12 @@
|
||||||
|
# include <sys/param.h>
|
||||||
|
#endif
|
||||||
|
|
||||||
|
+#if MAJOR_IN_MKDEV
|
||||||
|
+# include <sys/mkdev.h>
|
||||||
|
+#elif MAJOR_IN_SYSMACROS
|
||||||
|
+# include <sys/sysmacros.h>
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
#if defined MOUNTED_GETFSSTAT /* OSF_1 and Darwin1.3.x */
|
||||||
|
# if HAVE_SYS_UCRED_H
|
||||||
|
# include <grp.h> /* needed on OSF V4.0 for definition of NGROUPS,
|
Reference in New Issue