From 337273e41f6bb9486424d0bb636e69f9ca55d88f Mon Sep 17 00:00:00 2001
From: David Craven <david@craven.ch>
Date: Wed, 4 Jan 2017 18:53:03 +0100
Subject: [PATCH] gnu: ocaml-ounit: Enable tests.

Followup to 7a76b4afd0ce296bb462be8cf66234e41672c285.

* gnu/packages/ocaml.scm (ocaml-ounit)[arguments]: Enable tests.

Problem reported by Julien Lepiller <julien@lepiller.eu>.
---
 gnu/packages/ocaml.scm | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 25c0815786..4313bde8a8 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -777,7 +777,10 @@ compilers that can directly deal with packages.")
     (native-inputs
      `(("libxml2" ,libxml2))) ; for xmllint
     (arguments
-     `(#:tests? #f)) ; tests are done during build
+     `(#:phases
+       (modify-phases %standard-phases
+         ;; Tests are done during build.
+         (delete 'check))))
     (home-page "http://ounit.forge.ocamlcore.org")
     (synopsis "Unit testing framework for OCaml")
     (description "Unit testing framework for OCaml.  It is similar to JUnit and