gnu: doxygen: Update to 1.8.16.
* gnu/packages/documentation.scm (doxygen): Update to 1.8.16. [arguments]: Add phase 'remove-git-requirement'. * gnu/packages/patches/doxygen-test.patch: Adjust for upstream changes.master
parent
8b2c4eb502
commit
33c1c4c95f
|
@ -125,7 +125,7 @@ markup) can be customized and extended by the user.")
|
|||
(define-public doxygen
|
||||
(package
|
||||
(name "doxygen")
|
||||
(version "1.8.15")
|
||||
(version "1.8.16")
|
||||
(home-page "http://www.doxygen.nl/")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
|
@ -136,7 +136,7 @@ markup) can be customized and extended by the user.")
|
|||
".src.tar.gz")))
|
||||
(sha256
|
||||
(base32
|
||||
"0p94b4yb6bk2dxzs5kyl82xxgq2qakgbx5yy3ssbbadncb20x75x"))
|
||||
"10iwv8bcz5b5cd85gg8pgn0bmyg04n9hs36xn7ggjjnvynv1z67z"))
|
||||
(patches (search-patches "doxygen-test.patch"))))
|
||||
(build-system cmake-build-system)
|
||||
(native-inputs
|
||||
|
@ -157,6 +157,13 @@ markup) can be customized and extended by the user.")
|
|||
'())
|
||||
#:test-target "tests"
|
||||
#:phases (modify-phases %standard-phases
|
||||
(add-after 'unpack 'remove-git-requirement
|
||||
(lambda _
|
||||
;; TODO: Remove this for > 1.8.16.
|
||||
(substitute* "cmake/git_watcher.cmake"
|
||||
(("Git QUIET REQUIRED")
|
||||
"Git QUIET"))
|
||||
#t))
|
||||
(add-before 'configure 'patch-sh
|
||||
(lambda* (#:key inputs #:allow-other-keys)
|
||||
(substitute* "src/portable.cpp"
|
||||
|
|
|
@ -5,19 +5,40 @@ test.
|
|||
diff -u -r doxygen-1.8.7.orig/testing/012/citelist.xml doxygen-1.8.7/testing/012/citelist.xml
|
||||
--- doxygen-1.8.7.orig/testing/012/citelist.xml 2014-04-24 23:43:34.000000000 +0200
|
||||
+++ doxygen-1.8.7/testing/012/citelist.xml 2014-04-24 23:49:43.000000000 +0200
|
||||
@@ -6,17 +6,6 @@
|
||||
@@ -6,38 +6,6 @@
|
||||
<briefdescription>
|
||||
</briefdescription>
|
||||
<detaileddescription>
|
||||
- <para>
|
||||
- <variablelist>
|
||||
- <varlistentry>
|
||||
- <term><anchor id="citelist_1CITEREF_knuth79"/>[1]</term>
|
||||
- <term><anchor id="citelist_1CITEREF_Be09"/>[1]</term>
|
||||
- </varlistentry>
|
||||
- <listitem>
|
||||
- <para>P.<nonbreakablespace/>Belotti. <ulink url="http://doi.org/10.1007/978-1-4614-1927-3_5">Disjunctive cuts for non-convex MINLP</ulink>. In <ulink url="#CITEREF_LeLe12">Lee and Leyffer</ulink> <ulink url="#CITEREF_LeLe12">[4]</ulink>, pages 117<ndash/>144.</para>
|
||||
- <para/>
|
||||
- </listitem>
|
||||
- <varlistentry>
|
||||
- <term><anchor id="citelist_1CITEREF_BertholdHeinzVigerske2009"/>[2]</term>
|
||||
- </varlistentry>
|
||||
- <listitem>
|
||||
- <para>T.<nonbreakablespace/>Berthold, S.<nonbreakablespace/>Heinz, and S.<nonbreakablespace/>Vigerske. <ulink url="http://doi.org/10.1007/978-1-4614-1927-3_15">Extending a CIP framework to solve MIQCPs</ulink>. In <ulink url="#CITEREF_LeLe12">Lee and Leyffer</ulink> <ulink url="#CITEREF_LeLe12">[4]</ulink>, pages 427<ndash/>444.</para>
|
||||
- <para/>
|
||||
- </listitem>
|
||||
- <varlistentry>
|
||||
- <term><anchor id="citelist_1CITEREF_knuth79"/>[3]</term>
|
||||
- </varlistentry>
|
||||
- <listitem>
|
||||
- <para>Donald<nonbreakablespace/>E. Knuth. <emphasis>Tex and Metafont, New Directions in Typesetting</emphasis>. American Mathematical Society and Digital Press, Stanford, 1979.</para>
|
||||
- <para/>
|
||||
- </listitem>
|
||||
- <varlistentry>
|
||||
- <term><anchor id="citelist_1CITEREF_LeLe12"/>[4]</term>
|
||||
- </varlistentry>
|
||||
- <listitem>
|
||||
- <para>Jon Lee and Sven Leyffer, editors. <ulink url="http://doi.org/10.1007/978-1-4614-1927-3"><emphasis>Mixed Integer Nonlinear Programming</emphasis></ulink>, volume 154 of <emphasis>The IMA Volumes in Mathematics and its Applications</emphasis>. Springer, 2012.</para>
|
||||
- <para/>
|
||||
- </listitem>
|
||||
- </variablelist>
|
||||
- </para>
|
||||
</detaileddescription>
|
||||
|
@ -26,13 +47,14 @@ diff -u -r doxygen-1.8.7.orig/testing/012/citelist.xml doxygen-1.8.7/testing/012
|
|||
diff -u -r doxygen-1.8.7.orig/testing/012/indexpage.xml doxygen-1.8.7/testing/012/indexpage.xml
|
||||
--- doxygen-1.8.7.orig/testing/012/indexpage.xml 2014-04-24 23:43:34.000000000 +0200
|
||||
+++ doxygen-1.8.7/testing/012/indexpage.xml 2014-04-24 23:44:05.000000000 +0200
|
||||
@@ -4,7 +4,7 @@
|
||||
<compoundname>index</compoundname>
|
||||
<title>My Project</title>
|
||||
@@ -6,8 +6,8 @@
|
||||
<briefdescription>
|
||||
</briefdescription>
|
||||
<detaileddescription>
|
||||
- <para>See <ref refid="citelist_1CITEREF_knuth79" kindref="member">[1]</ref> for more info. </para>
|
||||
+ <para>See knuth79 for more info. </para>
|
||||
- <para>See <ref refid="citelist_1CITEREF_knuth79" kindref="member">[3]</ref> for more info.</para>
|
||||
- <para>Oter references with crosreference see <ref refid="citelist_1CITEREF_Be09" kindref="member">[1]</ref> and <ref refid="citelist_1CITEREF_BertholdHeinzVigerske2009" kindref="member">[2]</ref> for more info. </para>
|
||||
+ <para>See knuth79 for more info.</para>
|
||||
+ <para>Oter references with crosreference see Be09 and BertholdHeinzVigerske2009 for more info. </para>
|
||||
</detaileddescription>
|
||||
</compounddef>
|
||||
</doxygen>
|
||||
|
||||
|
|
Reference in New Issue