me
/
guix
Archived
1
0
Fork 0

gnu: minimap2: Update to 2.18.

* gnu/packages/bioinformatics.scm (minimap2): Update to 2.18.
[source]: Remove patch.
* gnu/packages/patches/minimap2-aarch64-support.patch: Remove file.
* gnu/local.mk (dist_patch_DATA): Remove it.
master
Efraim Flashner 2021-05-26 13:40:59 +03:00
parent b085abbeb8
commit 36a90d0637
No known key found for this signature in database
GPG Key ID: 41AAE7DCCA3D8351
3 changed files with 2 additions and 56 deletions

View File

@ -1424,7 +1424,6 @@ dist_patch_DATA = \
%D%/packages/patches/mingw-w64-6.0.0-gcc.patch \
%D%/packages/patches/mingw-w64-dlltool-temp-prefix.patch \
%D%/packages/patches/mingw-w64-reproducible-gendef.patch \
%D%/packages/patches/minimap2-aarch64-support.patch \
%D%/packages/patches/minisat-friend-declaration.patch \
%D%/packages/patches/minisat-install.patch \
%D%/packages/patches/mit-krb5-hurd.patch \

View File

@ -12323,7 +12323,7 @@ version does count multisplits.")
(define-public minimap2
(package
(name "minimap2")
(version "2.17")
(version "2.18")
(source
(origin
(method url-fetch)
@ -12332,8 +12332,7 @@ version does count multisplits.")
"minimap2-" version ".tar.bz2"))
(sha256
(base32
"0hi7i9pzxhvjj44khzzzj1lrn5gb5837arr4wgln7k1k5n4ci2mn"))
(patches (search-patches "minimap2-aarch64-support.patch"))))
"1d7fvdqcqd6wns875rkyd7f34ii15gc9l1sivd2wbbpcb0fi0mbs"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; there are none

View File

@ -1,52 +0,0 @@
This patch should be removed with the next release. There is WIP upstream
support for proper support of more architectures, including aarch64 and powerpc64le.
diff --git a/Makefile b/Makefile
index ed341f6..94dbd85 100644
--- a/Makefile
+++ b/Makefile
@@ -6,20 +6,18 @@ PROG= minimap2
PROG_EXTRA= sdust minimap2-lite
LIBS= -lm -lz -lpthread
-ifeq ($(arm_neon),) # if arm_neon is not defined
-ifeq ($(sse2only),) # if sse2only is not defined
- OBJS+=ksw2_extz2_sse41.o ksw2_extd2_sse41.o ksw2_exts2_sse41.o ksw2_extz2_sse2.o ksw2_extd2_sse2.o ksw2_exts2_sse2.o ksw2_dispatch.o
-else # if sse2only is defined
- OBJS+=ksw2_extz2_sse.o ksw2_extd2_sse.o ksw2_exts2_sse.o
-endif
-else # if arm_neon is defined
+ifneq ($(arm_neon),) # if arm_neon is defined
OBJS+=ksw2_extz2_neon.o ksw2_extd2_neon.o ksw2_exts2_neon.o
- INCLUDES+=-Isse2neon
-ifeq ($(aarch64),) #if aarch64 is not defined
CFLAGS+=-D_FILE_OFFSET_BITS=64 -mfpu=neon -fsigned-char
-else #if aarch64 is defined
+ INCLUDES+=-Isse2neon
+else ifneq ($(aarch64),) #if aarch64 is defined
+ OBJS+=ksw2_extz2_neon.o ksw2_extd2_neon.o ksw2_exts2_neon.o
CFLAGS+=-D_FILE_OFFSET_BITS=64 -fsigned-char
-endif
+ INCLUDES+=-Isse2neon
+else ifneq ($(sse2only),) # if sse2only is defined
+ OBJS+=ksw2_extz2_sse.o ksw2_extd2_sse.o ksw2_exts2_sse.o
+else # none of the above
+ OBJS+=ksw2_extz2_sse41.o ksw2_extd2_sse41.o ksw2_exts2_sse41.o ksw2_extz2_sse2.o ksw2_extd2_sse2.o ksw2_exts2_sse2.o ksw2_dispatch.o
endif
.PHONY:all extra clean depend
@@ -46,9 +44,12 @@ sdust:sdust.c kalloc.o kalloc.h kdq.h kvec.h kseq.h ketopt.h sdust.h
# SSE-specific targets on x86/x86_64
-ifeq ($(arm_neon),) # if arm_neon is defined, compile this target with the default setting (i.e. no -msse2)
+ifneq ($(arm_neon),) # if arm_neon is defined, compile this target with the default setting (i.e. no -msse2)
+ksw2_ll_sse.o:ksw2_ll_sse.c ksw2.h kalloc.h
+else ifneq ($(aarch64),)
ksw2_ll_sse.o:ksw2_ll_sse.c ksw2.h kalloc.h
- $(CC) -c $(CFLAGS) -msse2 $(CPPFLAGS) $(INCLUDES) $< -o $@
+else
+ $(CC) -c $(CFLAGS) -msse2 $(CPPFLAGS) $(INCLUDES) $< -o $@
endif
ksw2_extz2_sse41.o:ksw2_extz2_sse.c ksw2.h kalloc.h