From 37ed844711c1e8c802ea9f7e0f378e6440e4c526 Mon Sep 17 00:00:00 2001
From: Sergey Trofimov <sarg@sarg.org.ru>
Date: Fri, 30 Sep 2022 09:34:39 +0200
Subject: [PATCH] gnu: squid: Enable TLS features.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Despite openssl being listed as an input, it was not actually enabled by
default.  Fixing that using a configure flag.

* gnu/packages/networking.scm (squid)[arguments]: Add "--with-openssl"
to #:configure-flags.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
---
 gnu/packages/networking.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 3d9ba4fc8d..3489c3b96a 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2010,7 +2010,7 @@ TCP connection, TLS handshake and so on) in the terminal.")
      '(#:configure-flags
        ;; disable -march=native in build for reproducibility; see
        ;; https://wiki.squid-cache.org/KnowledgeBase/IllegalInstructionError
-       (list "--disable-arch-native")
+       (list "--disable-arch-native" "--with-openssl")
        #:phases
        (modify-phases %standard-phases
          (add-before 'build 'fix-true-path