gnu: Add libofa.
* gnu/packages/audio.scm (libofa): New variable. * gnu/packages/patches/libofa-ftbfs-1.diff: New file. * gnu/packages/patches/libofa-curl.diff: New file. * gnu/packages/patches/libofa-ftbfs-2.diff: New file. * gnu/local.mk (dist_patch_DATA): Add them. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>master
parent
502114de11
commit
38375ce952
|
@ -1216,6 +1216,9 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/libgnomeui-utf8.patch \
|
%D%/packages/patches/libgnomeui-utf8.patch \
|
||||||
%D%/packages/patches/libjxr-fix-function-signature.patch \
|
%D%/packages/patches/libjxr-fix-function-signature.patch \
|
||||||
%D%/packages/patches/libjxr-fix-typos.patch \
|
%D%/packages/patches/libjxr-fix-typos.patch \
|
||||||
|
%D%/packages/patches/libofa-ftbfs-1.diff \
|
||||||
|
%D%/packages/patches/libofa-curl.diff \
|
||||||
|
%D%/packages/patches/libofa-ftbfs-2.diff \
|
||||||
%D%/packages/patches/libotr-test-auth-fix.patch \
|
%D%/packages/patches/libotr-test-auth-fix.patch \
|
||||||
%D%/packages/patches/libksieve-Fix-missing-link-libraries.patch \
|
%D%/packages/patches/libksieve-Fix-missing-link-libraries.patch \
|
||||||
%D%/packages/patches/libmad-armv7-thumb-pt1.patch \
|
%D%/packages/patches/libmad-armv7-thumb-pt1.patch \
|
||||||
|
|
|
@ -128,6 +128,38 @@
|
||||||
#:use-module (srfi srfi-1)
|
#:use-module (srfi srfi-1)
|
||||||
#:use-module (srfi srfi-26))
|
#:use-module (srfi srfi-26))
|
||||||
|
|
||||||
|
(define-public libofa
|
||||||
|
(package
|
||||||
|
(name "libofa")
|
||||||
|
(version "0.9.3")
|
||||||
|
(source
|
||||||
|
(origin
|
||||||
|
(method url-fetch)
|
||||||
|
(uri
|
||||||
|
(string-append "https://storage.googleapis.com/"
|
||||||
|
"google-code-archive-downloads/v2/code.google.com/"
|
||||||
|
"musicip-libofa/" name "-" version ".tar.gz"))
|
||||||
|
(sha256
|
||||||
|
(base32 "184ham039l7lwhfgg0xr2vch2xnw1lwh7sid432mh879adhlc5h2"))
|
||||||
|
(patches
|
||||||
|
(search-patches
|
||||||
|
"libofa-ftbfs-1.diff"
|
||||||
|
"libofa-curl.diff"
|
||||||
|
"libofa-ftbfs-2.diff"))))
|
||||||
|
(build-system gnu-build-system)
|
||||||
|
(native-inputs
|
||||||
|
`(("pkg-config" ,pkg-config)))
|
||||||
|
(inputs
|
||||||
|
`(("curl" ,curl)
|
||||||
|
("expat" ,expat)))
|
||||||
|
(propagated-inputs
|
||||||
|
`(("fftw" ,fftw)))
|
||||||
|
(synopsis "Open Fingerprint Architecture")
|
||||||
|
(description "LibOFA is an audio fingerprint library, created and provided
|
||||||
|
by MusicIP.")
|
||||||
|
(home-page "https://code.google.com/archive/p/musicip-libofa/")
|
||||||
|
(license license:gpl2+)))
|
||||||
|
|
||||||
(define-public faac
|
(define-public faac
|
||||||
(package
|
(package
|
||||||
(name "faac")
|
(name "faac")
|
||||||
|
|
|
@ -0,0 +1,15 @@
|
||||||
|
Description: Fix FTBFS due to unexisting and useless include. (Closes: #637896)
|
||||||
|
Author: Regis Boudin <regis@debian.org>
|
||||||
|
Last-Update: 2011-10-03
|
||||||
|
Index: libofa-0.9.3/examples/protocol.cpp
|
||||||
|
===================================================================
|
||||||
|
--- libofa-0.9.3.orig/examples/protocol.cpp
|
||||||
|
+++ libofa-0.9.3/examples/protocol.cpp
|
||||||
|
@@ -13,7 +13,6 @@
|
||||||
|
#include <map>
|
||||||
|
#include <expat.h>
|
||||||
|
#include <curl/curl.h>
|
||||||
|
-#include <curl/types.h>
|
||||||
|
#include <curl/easy.h>
|
||||||
|
|
||||||
|
using namespace std;
|
|
@ -0,0 +1,45 @@
|
||||||
|
Description: fix FTBFS with GCC 4.3. (Closes: #417355)
|
||||||
|
Author: Martin Michlmayr <tbm@cyrius.com>
|
||||||
|
Last-Update: 2007-04-02
|
||||||
|
|
||||||
|
Description: add a missing include. (Closes: #441557)
|
||||||
|
Author: Brian M. Carlson <sandals@crustytoothpaste.ath.cx>
|
||||||
|
Last-Update: 2007-12-29
|
||||||
|
|
||||||
|
Index: libofa-0.9.3/lib/signal_op.cpp
|
||||||
|
===================================================================
|
||||||
|
--- libofa-0.9.3.orig/lib/signal_op.cpp
|
||||||
|
+++ libofa-0.9.3/lib/signal_op.cpp
|
||||||
|
@@ -12,6 +12,7 @@
|
||||||
|
// DATE CREATED: 1/12/06
|
||||||
|
|
||||||
|
|
||||||
|
+#include <cstdlib>
|
||||||
|
#include <math.h>
|
||||||
|
#include "signal_op.h"
|
||||||
|
#include "AFLIB/aflibConverter.h"
|
||||||
|
Index: libofa-0.9.3/examples/example.cpp
|
||||||
|
===================================================================
|
||||||
|
--- libofa-0.9.3.orig/examples/example.cpp
|
||||||
|
+++ libofa-0.9.3/examples/example.cpp
|
||||||
|
@@ -8,6 +8,8 @@
|
||||||
|
-------------------------------------------------------------------*/
|
||||||
|
|
||||||
|
#include "protocol.h"
|
||||||
|
+#include <cctype>
|
||||||
|
+#include <string.h>
|
||||||
|
|
||||||
|
AudioData* loadWaveFile(char *file);
|
||||||
|
AudioData* loadDataUsingLAME(char *file);
|
||||||
|
Index: libofa-0.9.3/examples/protocol.cpp
|
||||||
|
===================================================================
|
||||||
|
--- libofa-0.9.3.orig/examples/protocol.cpp
|
||||||
|
+++ libofa-0.9.3/examples/protocol.cpp
|
||||||
|
@@ -8,6 +8,7 @@
|
||||||
|
-------------------------------------------------------------------*/
|
||||||
|
#include <stdio.h>
|
||||||
|
#include <stdlib.h>
|
||||||
|
+#include <cstring>
|
||||||
|
#include <string>
|
||||||
|
#include <map>
|
||||||
|
#include <expat.h>
|
|
@ -0,0 +1,27 @@
|
||||||
|
Description: ftbfs with GCC-4.7. (Closes: #667250)
|
||||||
|
Author: Matthias Klose <doko@debian.org>
|
||||||
|
Last-Update: 2012-04-17
|
||||||
|
Index: libofa-0.9.3/examples/uselame.cpp
|
||||||
|
===================================================================
|
||||||
|
--- libofa-0.9.3.orig/examples/uselame.cpp
|
||||||
|
+++ libofa-0.9.3/examples/uselame.cpp
|
||||||
|
@@ -11,6 +11,7 @@
|
||||||
|
#include "windows.h"
|
||||||
|
#else
|
||||||
|
#include <sys/wait.h>
|
||||||
|
+#include <unistd.h>
|
||||||
|
#endif
|
||||||
|
|
||||||
|
AudioData *loadWaveFile(char *file);
|
||||||
|
Index: libofa-0.9.3/examples/wavefile.cpp
|
||||||
|
===================================================================
|
||||||
|
--- libofa-0.9.3.orig/examples/wavefile.cpp
|
||||||
|
+++ libofa-0.9.3/examples/wavefile.cpp
|
||||||
|
@@ -11,6 +11,7 @@
|
||||||
|
#include "io.h"
|
||||||
|
#endif
|
||||||
|
#include <fcntl.h>
|
||||||
|
+#include <unistd.h>
|
||||||
|
|
||||||
|
static bool readBytes(int fd, unsigned char *buf, int size) {
|
||||||
|
int ct = 0;
|
Reference in New Issue