me
/
guix
Archived
1
0
Fork 0

gnu: mesa: Update to 21.2.4.

* gnu/packages/patches/mesa-skip-tests.patch: Adjust for current version.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
master
John Kehayias 2021-10-14 22:12:41 -04:00 committed by Maxim Cournoyer
parent 50db3459cb
commit 3b9b685d05
No known key found for this signature in database
GPG Key ID: 1260E46482E63562
2 changed files with 11 additions and 21 deletions

View File

@ -238,7 +238,7 @@ also known as DXTn or DXTC) for Mesa.")
(define-public mesa
(package
(name "mesa")
(version "21.1.6")
(version "21.2.4")
(source
(origin
(method url-fetch)
@ -250,7 +250,7 @@ also known as DXTn or DXTC) for Mesa.")
version "/mesa-" version ".tar.xz")))
(sha256
(base32
"0dwyk7cxlwna24ap23i8i92a2qcc6xhp16i03zzakpqiz4i03jxi"))
"0i2vz3ppcgqm076546imzl11jr3rlch1iv62lffk60mcs61dwvpy"))
(patches
(search-patches "mesa-skip-tests.patch"))))
(build-system meson-build-system)

View File

@ -5,25 +5,15 @@ completely with this patch:
https://gitlab.freedesktop.org/mesa/mesa/-/issues/4091
diff --git a/src/util/meson.build b/src/util/meson.build
index 0893f64..909b3e0 100644
index 319b22d9bf7..93790c72675 100644
--- a/src/util/meson.build
+++ b/src/util/meson.build
@@ -289,18 +289,6 @@ if with_tests
suite : ['util'],
)
@@ -344,7 +344,7 @@ if with_tests
)
endif
- test(
- 'u_debug_stack',
- executable(
- 'u_debug_stack_test',
- files('u_debug_stack_test.cpp'),
- include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
- dependencies : [idep_mesautil, idep_gtest],
- c_args : [c_msvc_compat_args],
- ),
- suite : ['util'],
- )
-
process_test_exe = executable(
'process_test',
files('process_test.c'),
- foreach t: ['bitset', 'register_allocate', 'u_debug_stack', 'u_qsort']
+ foreach t: ['bitset', 'register_allocate', 'u_qsort']
test(
t,
executable(