me
/
guix
Archived
1
0
Fork 0

gnu: rust-adblock: Update to 0.7.5.

* gnu/packages/crates-io.scm (rust-adblock-0.4): Replace with
rust-adblock-0.7.5.
[source]: Remove patch.
[arguments]: Add cargo-test-flags.
[cargo-inputs]: Replace rust-cssparser-0.25 with 0.28,
rust-selectors-0.21 with 0.23.
[cargo-development-inputs]: Replace rust-criterion-0.3 with 0.4,
rust-tokio-1.8 with rust-tokio.
[native-inputs]: Remove pkg-config, openssl.
* gnu/packages/patches/rust-adblock-ignore-live-tests.patch: Remove file.
* gnu/local.mk (dist_patch_DATA): Remove it.
master
Efraim Flashner 2023-03-09 17:50:59 +02:00
parent 26776d890d
commit 3cede546d4
No known key found for this signature in database
GPG Key ID: 41AAE7DCCA3D8351
3 changed files with 17 additions and 82 deletions

View File

@ -1863,7 +1863,6 @@ dist_patch_DATA = \
%D%/packages/patches/ruby-mustache-1.1.1-fix-race-condition-tests.patch \ %D%/packages/patches/ruby-mustache-1.1.1-fix-race-condition-tests.patch \
%D%/packages/patches/rustc-1.54.0-src.patch \ %D%/packages/patches/rustc-1.54.0-src.patch \
%D%/packages/patches/rust-1.64-fix-riscv64-bootstrap.patch \ %D%/packages/patches/rust-1.64-fix-riscv64-bootstrap.patch \
%D%/packages/patches/rust-adblock-ignore-live-tests.patch \
%D%/packages/patches/i3status-rust-enable-unstable-features.patch \ %D%/packages/patches/i3status-rust-enable-unstable-features.patch \
%D%/packages/patches/rust-ndarray-remove-blas-src-dep.patch \ %D%/packages/patches/rust-ndarray-remove-blas-src-dep.patch \
%D%/packages/patches/rust-ndarray-0.13-remove-blas-src.patch \ %D%/packages/patches/rust-ndarray-0.13-remove-blas-src.patch \

View File

@ -1576,10 +1576,10 @@ threads. This makes it robust in face of panics (it won't make your program
deadlock, like the standard Barrier).") deadlock, like the standard Barrier).")
(license (list license:asl2.0 license:expat)))) (license (list license:asl2.0 license:expat))))
(define-public rust-adblock-0.4 (define-public rust-adblock-0.7
(package (package
(name "rust-adblock") (name "rust-adblock")
(version "0.4.1") (version "0.7.5")
(source (source
(origin (origin
(method git-fetch) (method git-fetch)
@ -1587,42 +1587,47 @@ deadlock, like the standard Barrier).")
(url "https://github.com/brave/adblock-rust") (url "https://github.com/brave/adblock-rust")
(commit (string-append "v" version)))) (commit (string-append "v" version))))
(file-name (git-file-name name version)) (file-name (git-file-name name version))
(patches (search-patches "rust-adblock-ignore-live-tests.patch"))
(sha256 (sha256
(base32 (base32
"0l2iacwkm66z6wc71wy62x2k5xllx94adrqncicxqsx203c3ljpl")))) "0prlkq8am3sskg55x7b8vr4j54dmkjqldyl50isq5qyy9pff3xxs"))))
(build-system cargo-build-system) (build-system cargo-build-system)
(arguments (arguments
`(#:cargo-inputs `(#:cargo-test-flags
(list "--release" "--"
;; Skip tests which require the network.
"--skip=check_live_from_filterlists"
"--skip=check_live_specific_urls"
"--skip=stable_serialization"
"--skip=stable_serialization_through_load")
#:cargo-inputs
(("rust-addr" ,rust-addr-0.14) (("rust-addr" ,rust-addr-0.14)
("rust-base64" ,rust-base64-0.13) ("rust-base64" ,rust-base64-0.13)
("rust-bitflags" ,rust-bitflags-1) ("rust-bitflags" ,rust-bitflags-1)
("rust-cssparser" ,rust-cssparser-0.25) ("rust-cssparser" ,rust-cssparser-0.28)
("rust-flate2" ,rust-flate2-1) ("rust-flate2" ,rust-flate2-1)
("rust-idna" ,rust-idna-0.2) ("rust-idna" ,rust-idna-0.2)
("rust-itertools" ,rust-itertools-0.10) ("rust-itertools" ,rust-itertools-0.10)
("rust-lifeguard" ,rust-lifeguard-0.6) ("rust-lifeguard" ,rust-lifeguard-0.6)
("rust-once-cell" ,rust-once-cell-1) ("rust-once-cell" ,rust-once-cell-1)
("rust-percent-encoding" ("rust-percent-encoding" ,rust-percent-encoding-2)
,rust-percent-encoding-2)
("rust-regex" ,rust-regex-1) ("rust-regex" ,rust-regex-1)
("rust-rmp-serde" ,rust-rmp-serde-0.13) ("rust-rmp-serde" ,rust-rmp-serde-0.13)
("rust-rmp-serde" ,rust-rmp-serde-0.15) ("rust-rmp-serde" ,rust-rmp-serde-0.15)
("rust-seahash" ,rust-seahash-3) ("rust-seahash" ,rust-seahash-3)
("rust-selectors" ,rust-selectors-0.21) ("rust-selectors" ,rust-selectors-0.23)
("rust-serde" ,rust-serde-1) ("rust-serde" ,rust-serde-1)
("rust-serde-json" ,rust-serde-json-1) ("rust-serde-json" ,rust-serde-json-1)
("rust-twoway" ,rust-twoway-0.2) ("rust-twoway" ,rust-twoway-0.2)
("rust-url" ,rust-url-2)) ("rust-url" ,rust-url-2))
#:cargo-development-inputs #:cargo-development-inputs
(("rust-criterion" ,rust-criterion-0.3) (("rust-criterion" ,rust-criterion-0.4)
("rust-csv" ,rust-csv-1) ("rust-csv" ,rust-csv-1)
("rust-futures" ,rust-futures-0.3) ("rust-futures" ,rust-futures-0.3)
("rust-mock-instant" ,rust-mock-instant-0.2)
("rust-reqwest" ,rust-reqwest-0.11) ("rust-reqwest" ,rust-reqwest-0.11)
("rust-serde-json" ,rust-serde-json-1) ("rust-serde-json" ,rust-serde-json-1)
("rust-sha2" ,rust-sha2-0.9) ("rust-sha2" ,rust-sha2-0.9)
("rust-tokio" ,rust-tokio-1.8)))) ("rust-tokio" ,rust-tokio-1))))
(native-inputs (list pkg-config openssl))
(home-page "https://github.com/brave/adblock-rust/") (home-page "https://github.com/brave/adblock-rust/")
(synopsis "Adblock Plus syntax filter parsing and matching") (synopsis "Adblock Plus syntax filter parsing and matching")
(description "This package provides native Rust module for Adblock Plus (description "This package provides native Rust module for Adblock Plus

View File

@ -1,69 +0,0 @@
From b83b5b453d3f7883ef4c12f84a7045486957c709 Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Tue, 9 Nov 2021 17:02:54 +0100
Subject: [PATCH] Ignore live tests.
diff --git a/tests/live.rs b/tests/live.rs
index b1a19fc..6bd4685 100644
--- a/tests/live.rs
+++ b/tests/live.rs
@@ -140,6 +140,7 @@ fn get_blocker_engine_deserialized_ios() -> Engine {
}
#[test]
+#[ignore]
fn check_live_specific_urls() {
let mut engine = get_blocker_engine();
{
@@ -176,6 +177,7 @@ fn check_live_specific_urls() {
}
#[test]
+#[ignore]
fn check_live_deserialized_specific_urls() {
let mut engine = get_blocker_engine_deserialized();
{
@@ -201,6 +203,7 @@ fn check_live_deserialized_specific_urls() {
}
#[test]
+#[ignore]
fn check_live_from_filterlists() {
let engine = get_blocker_engine();
let requests = load_requests();
@@ -214,6 +217,7 @@ fn check_live_from_filterlists() {
}
#[test]
+#[ignore]
fn check_live_deserialized_file() {
let engine = get_blocker_engine_deserialized();
let requests = load_requests();
@@ -243,6 +247,7 @@ fn check_live_deserialized_ios() {
#[cfg(feature = "resource_assembler")]
#[test]
+#[ignore]
fn check_live_redirects() {
use adblock::resources::resource_assembler::assemble_web_accessible_resources;
@@ -278,6 +283,7 @@ fn check_live_redirects() {
}
#[test]
+#[ignore]
/// Ensure that two different engines loaded from the same textual filter set serialize to
/// identical buffers.
fn stable_serialization() {
@@ -291,6 +297,7 @@ fn stable_serialization() {
}
#[test]
+#[ignore]
/// Ensure that one engine's serialization result can be exactly reproduced by another engine after
/// deserializing from it.
fn stable_serialization_through_load() {
--
2.33.1