gnu: screen: Build fix for the Hurd.
* gnu/packages/patches/screen-hurd-path-max.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/screen.scm (screen): Use it.master
parent
3d3ca76f1c
commit
3da54cc318
|
@ -1424,6 +1424,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/scheme48-tests.patch \
|
%D%/packages/patches/scheme48-tests.patch \
|
||||||
%D%/packages/patches/scotch-build-parallelism.patch \
|
%D%/packages/patches/scotch-build-parallelism.patch \
|
||||||
%D%/packages/patches/scotch-integer-declarations.patch \
|
%D%/packages/patches/scotch-integer-declarations.patch \
|
||||||
|
%D%/packages/patches/screen-hurd-path-max.patch \
|
||||||
%D%/packages/patches/sdl-libx11-1.6.patch \
|
%D%/packages/patches/sdl-libx11-1.6.patch \
|
||||||
%D%/packages/patches/sdl2-mesa-compat.patch \
|
%D%/packages/patches/sdl2-mesa-compat.patch \
|
||||||
%D%/packages/patches/seahorse-gkr-use-0-on-empty-flags.patch \
|
%D%/packages/patches/seahorse-gkr-use-0-on-empty-flags.patch \
|
||||||
|
|
|
@ -0,0 +1,42 @@
|
||||||
|
Workaround for PATH_MAX usage on the Hurd.
|
||||||
|
|
||||||
|
Taken from https://salsa.debian.org/debian/screen/-/blob/master/debian/patches/61-default-PATH_MAX-if-undefined-for-hurd.patch
|
||||||
|
|
||||||
|
Description: Set PATH_MAX to 4096 if undefined
|
||||||
|
Fixes FTBFS since 4.4.0 on GNU/Hurd. Updated to add one more occurrence for 4.5.0.
|
||||||
|
Author: Axel Beckert <abe@debian.org>
|
||||||
|
Bug: https://savannah.gnu.org/bugs/?50089
|
||||||
|
Last-Updated: 2017-01-18
|
||||||
|
|
||||||
|
--- a/tty.sh
|
||||||
|
+++ b/tty.sh
|
||||||
|
@@ -1478,6 +1478,13 @@
|
||||||
|
return 0;
|
||||||
|
}
|
||||||
|
|
||||||
|
+/*
|
||||||
|
+ * Define PATH_MAX to 4096 if it's not defined, like on GNU/Hurd
|
||||||
|
+ */
|
||||||
|
+
|
||||||
|
+#ifndef PATH_MAX
|
||||||
|
+#define PATH_MAX 4096
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
int CheckTtyname (char *tty)
|
||||||
|
{
|
||||||
|
--- a/screen.h
|
||||||
|
+++ b/screen.h
|
||||||
|
@@ -109,6 +109,13 @@
|
||||||
|
# define DEFAULT_BUFFERFILE "/tmp/screen-exchange"
|
||||||
|
#endif
|
||||||
|
|
||||||
|
+/*
|
||||||
|
+ * Define PATH_MAX to 4096 if it's not defined, like on GNU/Hurd
|
||||||
|
+ */
|
||||||
|
+
|
||||||
|
+#ifndef PATH_MAX
|
||||||
|
+#define PATH_MAX 4096
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
#if defined(hpux) && !(defined(VSUSP) && defined(VDSUSP) && defined(VWERASE) && defined(VLNEXT))
|
||||||
|
# define HPUX_LTCHARS_HACK
|
|
@ -29,6 +29,7 @@
|
||||||
#:use-module (guix git-download)
|
#:use-module (guix git-download)
|
||||||
#:use-module (guix build-system gnu)
|
#:use-module (guix build-system gnu)
|
||||||
#:use-module (gnu packages)
|
#:use-module (gnu packages)
|
||||||
|
#:use-module (gnu packages hurd)
|
||||||
#:use-module (gnu packages ncurses)
|
#:use-module (gnu packages ncurses)
|
||||||
#:use-module (gnu packages perl)
|
#:use-module (gnu packages perl)
|
||||||
#:use-module (gnu packages python)
|
#:use-module (gnu packages python)
|
||||||
|
@ -43,6 +44,7 @@
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://gnu/screen/screen-"
|
(uri (string-append "mirror://gnu/screen/screen-"
|
||||||
version ".tar.gz"))
|
version ".tar.gz"))
|
||||||
|
(patches (search-patches "screen-hurd-path-max.patch"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "18ascpjzsy70h6hk7wpg8zmzjwgdyrdr7c6z4pg5z4l9hhyv24bf"))))
|
(base32 "18ascpjzsy70h6hk7wpg8zmzjwgdyrdr7c6z4pg5z4l9hhyv24bf"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
|
|
Reference in New Issue