me
/
guix
Archived
1
0
Fork 0

gnu: ddcci-driver-linux: Update to 0.4.5.

* gnu/packages/linux.scm (ddcci-driver-linux): Update to 0.4.5.
[source]: Remove already upstream patch.

* gnu/packages/patches/ddcci-driver-linux-6.8.patch: Remove it.
* gnu/local.mk: Unregister it.

Change-Id: I1d4920ec84ea2a67554560181e99e9e2d535af2a
Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn>
master
Ashish SHUKLA 2024-07-23 21:21:27 +02:00 committed by Zheng Junjie
parent be46349a4e
commit 3e4e1aa99b
No known key found for this signature in database
GPG Key ID: 3B5AA993E1A2DFF0
3 changed files with 4 additions and 40 deletions

View File

@ -65,6 +65,7 @@
# Copyright © 2023 Herman Rimm <herman@rimm.ee>
# Copyright © 2023 Troy Figiel <troy@troyfigiel.com>
# Copyright © 2024 David Elsing <david.elsing@posteo.net>
# Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
#
# This file is part of GNU Guix.
#
@ -1111,7 +1112,6 @@ dist_patch_DATA = \
%D%/packages/patches/dbus-c++-gcc-compat.patch \
%D%/packages/patches/dbus-c++-threading-mutex.patch \
%D%/packages/patches/dbxfs-remove-sentry-sdk.patch \
%D%/packages/patches/ddcci-driver-linux-linux-6.8.patch \
%D%/packages/patches/debops-constants-for-external-program-names.patch \
%D%/packages/patches/debops-debops-defaults-fall-back-to-less.patch \
%D%/packages/patches/dee-vapi.patch \

View File

@ -81,6 +81,7 @@
;;; Copyright © 2024 Gabriel Wicki <gabriel@erlikon.ch>
;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2024 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
;;;
;;; This file is part of GNU Guix.
;;;
@ -1810,7 +1811,7 @@ graphics card on Optimus laptops.")
(define-public ddcci-driver-linux
(package
(name "ddcci-driver-linux")
(version "0.4.4")
(version "0.4.5")
(source
(origin
(method git-fetch)
@ -1820,8 +1821,7 @@ graphics card on Optimus laptops.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32 "19vi7dk4jv5wm18cznz4lj2fb1c7m7j3ig62x4a6qy9djxf9z472"))
(patches (search-patches "ddcci-driver-linux-linux-6.8.patch"))))
(base32 "0j2bgzadrbcyf3k4zplv7p5yqb9pw2ca6wzkqjhhidaah2722vlf"))))
(build-system linux-module-build-system)
(arguments
(list #:tests? #f ; no tests

View File

@ -1,36 +0,0 @@
Retrieved from: https://gitlab.com/ddcci-driver-linux/ddcci-driver-linux/-/commit/3eb20df68a545d07b8501f13fa9d20e9c6f577ed.patch
From 7f851f5fb8fbcd7b3a93aaedff90b27124e17a7e Mon Sep 17 00:00:00 2001
From: Bruno Inec <contact@sweenu.xyz>
Date: Wed, 20 Mar 2024 10:36:56 +0100
Subject: [PATCH] Compatibility with Linux 6.8
---
ddcci/ddcci.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/ddcci/ddcci.c b/ddcci/ddcci.c
index 87b0818..6073c75 100644
--- a/ddcci/ddcci.c
+++ b/ddcci/ddcci.c
@@ -1666,7 +1666,7 @@ static int ddcci_detect(struct i2c_client *client, struct i2c_board_info *info)
pr_debug("detected %d:%02x\n", client->adapter->nr, outer_addr);
/* set device type */
- strlcpy(info->type, (outer_addr == DDCCI_DEFAULT_DEVICE_ADDR) ? "ddcci" : "ddcci-dependent", I2C_NAME_SIZE);
+ strscpy(info->type, (outer_addr == DDCCI_DEFAULT_DEVICE_ADDR) ? "ddcci" : "ddcci-dependent", I2C_NAME_SIZE);
return 0;
}
@@ -1824,7 +1824,7 @@ static struct i2c_driver ddcci_driver = {
#else
.remove = ddcci_remove,
#endif
- .class = I2C_CLASS_DDC,
+ .class = I2C_CLASS_SPD,
.detect = ddcci_detect,
.address_list = I2C_ADDRS(
DDCCI_DEFAULT_DEVICE_ADDR>>1
--
GitLab