From 3ff587f8b092bcef5a54203a651796f4ec473111 Mon Sep 17 00:00:00 2001
From: Ricardo Wurmus <rekado@elephly.net>
Date: Tue, 11 Apr 2023 18:24:09 +0200
Subject: [PATCH] gnu: abseil-cpp-20200923.3: Fix build failure.

* gnu/packages/cpp.scm (abseil-cpp-20200923.3)[arguments]: Add phase 'fix-max
to add a missing type cast.
---
 gnu/packages/cpp.scm | 5 +++++
 1 file changed, 5 insertions(+)

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 6b76b6f2b8..3e52b4ec78 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1048,6 +1048,11 @@ point and then, after each tween step, plugging back the result.")
                                "-DCMAKE_EXE_LINKER_FLAGS=-lgtest -lpthread -lgmock")
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'fix-max
+           (lambda _
+             (substitute* "absl/debugging/failure_signal_handler.cc"
+               (("std::max\\(SIGSTKSZ, 65536\\)")
+                "std::max<size_t>(SIGSTKSZ, 65536)"))))
          (add-before 'configure 'remove-gtest-check
            ;; The CMakeLists fails to find our googletest for some reason, but
            ;; it works nonetheless.