gnu: Remove unused patch.
* gnu/packages/patches/python-flake8-polyfill-flake8-4-compat.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
parent
96d47797dc
commit
413b85ad4f
|
@ -1593,7 +1593,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/ppsspp-disable-upgrade-and-gold.patch \
|
||||
%D%/packages/patches/pthreadpool-system-libraries.patch \
|
||||
%D%/packages/patches/python-chai-drop-python2.patch \
|
||||
%D%/packages/patches/python-flake8-polyfill-flake8-4-compat.patch \
|
||||
%D%/packages/patches/python-random2-getrandbits-test.patch \
|
||||
%D%/packages/patches/python-poppler-qt5-fix-build.patch \
|
||||
%D%/packages/patches/python-w3lib-fix-test-failure.patch \
|
||||
|
|
|
@ -1,32 +0,0 @@
|
|||
https://github.com/PyCQA/flake8-polyfill/commit/3cf414350e82ceb835ca2edbd5d5967d33e9ff35.patch
|
||||
|
||||
|
||||
From 3cf414350e82ceb835ca2edbd5d5967d33e9ff35 Mon Sep 17 00:00:00 2001
|
||||
From: Ian Stapleton Cordasco <graffatcolmingov@gmail.com>
|
||||
Date: Mon, 1 Nov 2021 19:18:04 -0500
|
||||
Subject: [PATCH] Skip unnecessary tests on Flake8 4.x+
|
||||
|
||||
---
|
||||
tests/test_stdin.py | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/tests/test_stdin.py b/tests/test_stdin.py
|
||||
index 4350967..212b309 100644
|
||||
--- a/tests/test_stdin.py
|
||||
+++ b/tests/test_stdin.py
|
||||
@@ -1,4 +1,5 @@
|
||||
"""Tests for polyfill's stdin monkey patching."""
|
||||
+import flake8
|
||||
import pep8
|
||||
import pycodestyle
|
||||
import pytest
|
||||
@@ -6,6 +7,9 @@
|
||||
from flake8_polyfill import stdin
|
||||
from flake8_polyfill import version
|
||||
|
||||
+if (4, 0, 0) <= flake8.__version_info__:
|
||||
+ pytestmark = pytest.mark.skip
|
||||
+
|
||||
|
||||
def test_modules_dict():
|
||||
"""Verify that it works the way we expect."""
|
Reference in New Issue