gnu: openssh: Update to 7.4p1.
* gnu/packages/ssh.scm (openssh): Update to 7.4p1. [source]: Remove 'openssh-memory-exhaustion.patch'. * gnu/packages/patches/openssh-memory-exhaustion.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.master
parent
307349f6f7
commit
43686dcb2f
|
@ -752,7 +752,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/openjpeg-CVE-2016-9850-CVE-2016-9851.patch \
|
%D%/packages/patches/openjpeg-CVE-2016-9850-CVE-2016-9851.patch \
|
||||||
%D%/packages/patches/openjpeg-use-after-free-fix.patch \
|
%D%/packages/patches/openjpeg-use-after-free-fix.patch \
|
||||||
%D%/packages/patches/openocd-nrf52.patch \
|
%D%/packages/patches/openocd-nrf52.patch \
|
||||||
%D%/packages/patches/openssh-memory-exhaustion.patch \
|
|
||||||
%D%/packages/patches/openssl-runpath.patch \
|
%D%/packages/patches/openssl-runpath.patch \
|
||||||
%D%/packages/patches/openssl-1.1.0-c-rehash-in.patch \
|
%D%/packages/patches/openssl-1.1.0-c-rehash-in.patch \
|
||||||
%D%/packages/patches/openssl-c-rehash-in.patch \
|
%D%/packages/patches/openssl-c-rehash-in.patch \
|
||||||
|
|
|
@ -1,39 +0,0 @@
|
||||||
Fix a memory exhaustion bug in the key exchange, whereby an unauthenticated user
|
|
||||||
could potentially consume 38400 MB of memory on the server:
|
|
||||||
|
|
||||||
http://seclists.org/oss-sec/2016/q4/185
|
|
||||||
|
|
||||||
Patch adapted from upstream source repository:
|
|
||||||
|
|
||||||
https://github.com/openssh/openssh-portable/commit/ec165c392ca54317dbe3064a8c200de6531e89ad
|
|
||||||
|
|
||||||
From ec165c392ca54317dbe3064a8c200de6531e89ad Mon Sep 17 00:00:00 2001
|
|
||||||
From: "markus@openbsd.org" <markus@openbsd.org>
|
|
||||||
Date: Mon, 10 Oct 2016 19:28:48 +0000
|
|
||||||
Subject: [PATCH] upstream commit
|
|
||||||
|
|
||||||
Unregister the KEXINIT handler after message has been
|
|
||||||
received. Otherwise an unauthenticated peer can repeat the KEXINIT and cause
|
|
||||||
allocation of up to 128MB -- until the connection is closed. Reported by
|
|
||||||
shilei-c at 360.cn
|
|
||||||
|
|
||||||
Upstream-ID: 43649ae12a27ef94290db16d1a98294588b75c05
|
|
||||||
---
|
|
||||||
kex.c | 3 ++-
|
|
||||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/kex.c b/kex.c
|
|
||||||
index 3f97f8c..6a94bc5 100644
|
|
||||||
--- a/kex.c
|
|
||||||
+++ b/kex.c
|
|
||||||
@@ -481,6 +481,7 @@ kex_input_kexinit(int type, u_int32_t seq, void *ctxt)
|
|
||||||
if (kex == NULL)
|
|
||||||
return SSH_ERR_INVALID_ARGUMENT;
|
|
||||||
|
|
||||||
+ ssh_dispatch_set(ssh, SSH2_MSG_KEXINIT, NULL);
|
|
||||||
ptr = sshpkt_ptr(ssh, &dlen);
|
|
||||||
if ((r = sshbuf_put(kex->peer, ptr, dlen)) != 0)
|
|
||||||
return r;
|
|
||||||
--
|
|
||||||
2.10.1
|
|
||||||
|
|
|
@ -112,7 +112,7 @@ a server that supports the SSH-2 protocol.")
|
||||||
(define-public openssh
|
(define-public openssh
|
||||||
(package
|
(package
|
||||||
(name "openssh")
|
(name "openssh")
|
||||||
(version "7.3p1")
|
(version "7.4p1")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (let ((tail (string-append name "-" version ".tar.gz")))
|
(uri (let ((tail (string-append name "-" version ".tar.gz")))
|
||||||
|
@ -122,9 +122,8 @@ a server that supports the SSH-2 protocol.")
|
||||||
tail)
|
tail)
|
||||||
(string-append "http://ftp2.fr.openbsd.org/pub/OpenBSD/OpenSSH/portable/"
|
(string-append "http://ftp2.fr.openbsd.org/pub/OpenBSD/OpenSSH/portable/"
|
||||||
tail))))
|
tail))))
|
||||||
(patches (search-patches "openssh-memory-exhaustion.patch"))
|
|
||||||
(sha256 (base32
|
(sha256 (base32
|
||||||
"1k5y1wi29d47cgizbryxrhc1fbjsba2x8l5mqfa9b9nadnd9iyrz"))))
|
"1l8r3x4fr2kb6xm95s7kjdif1wp6f94d4kljh4qjj9109shw87qv"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(inputs `(("groff" ,groff)
|
(inputs `(("groff" ,groff)
|
||||||
("openssl" ,openssl)
|
("openssl" ,openssl)
|
||||||
|
|
Reference in New Issue