gnu: sdl2: Update to 2.0.12.
* gnu/packages/patches/sdl2-mesa-compat.patch: Delete file. * gnu/packages/sdl.scm (sdl2): Update to 2.0.12. [source]: Drop patch that was included in this release. Signed-off-by: Marius Bakke <mbakke@fastmail.com>master
parent
9d4ed35703
commit
43b176f36c
|
@ -1415,7 +1415,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/scotch-build-parallelism.patch \
|
||||
%D%/packages/patches/scotch-integer-declarations.patch \
|
||||
%D%/packages/patches/sdl-libx11-1.6.patch \
|
||||
%D%/packages/patches/sdl2-mesa-compat.patch \
|
||||
%D%/packages/patches/seahorse-gkr-use-0-on-empty-flags.patch \
|
||||
%D%/packages/patches/seq24-rename-mutex.patch \
|
||||
%D%/packages/patches/sharutils-CVE-2018-1000097.patch \
|
||||
|
|
|
@ -1,21 +0,0 @@
|
|||
Do not include GLES header when OpenGL headers are already included.
|
||||
|
||||
Taken from upstream:
|
||||
https://hg.libsdl.org/SDL/rev/369b01006eb2
|
||||
|
||||
diff -r 4cbaffd0083b -r 369b01006eb2 src/video/SDL_video.c
|
||||
--- a/src/video/SDL_video.c Fri Oct 11 06:18:24 2019 +0200
|
||||
+++ b/src/video/SDL_video.c Sat Oct 12 18:47:56 2019 +0200
|
||||
@@ -37,9 +37,9 @@
|
||||
#include "SDL_opengl.h"
|
||||
#endif /* SDL_VIDEO_OPENGL */
|
||||
|
||||
-#if SDL_VIDEO_OPENGL_ES
|
||||
+#if SDL_VIDEO_OPENGL_ES && !SDL_VIDEO_OPENGL
|
||||
#include "SDL_opengles.h"
|
||||
-#endif /* SDL_VIDEO_OPENGL_ES */
|
||||
+#endif /* SDL_VIDEO_OPENGL_ES && !SDL_VIDEO_OPENGL */
|
||||
|
||||
/* GL and GLES2 headers conflict on Linux 32 bits */
|
||||
#if SDL_VIDEO_OPENGL_ES2 && !SDL_VIDEO_OPENGL
|
||||
|
|
@ -115,16 +115,15 @@ joystick, and graphics hardware.")
|
|||
(define-public sdl2
|
||||
(package (inherit sdl)
|
||||
(name "sdl2")
|
||||
(version "2.0.10")
|
||||
(version "2.0.12")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri
|
||||
(string-append "https://libsdl.org/release/SDL2-"
|
||||
version ".tar.gz"))
|
||||
(patches (search-patches "sdl2-mesa-compat.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"0mqxp6w5jhbq6y1j690g9r3gpzwjxh4czaglw8x05l7hl49nqrdl"))))
|
||||
"0qy8wbqvfkb5ps8kxgaaf2zzpkjqbsw712hlp74znbn0jpv6i4il"))))
|
||||
(arguments
|
||||
(substitute-keyword-arguments (package-arguments sdl)
|
||||
((#:configure-flags flags)
|
||||
|
|
Reference in New Issue