gnu: texlive-bin: Fix build with Poppler 0.86.
* gnu/packages/patches/texlive-bin-poppler-0.86.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/tex.scm (texlive-bin)[source](patches): Add it.master
parent
a7924ba9f7
commit
44a33ee90d
|
@ -1438,6 +1438,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/teensy-loader-cli-help.patch \
|
||||
%D%/packages/patches/texinfo-5-perl-compat.patch \
|
||||
%D%/packages/patches/texlive-bin-poppler-0.83.patch \
|
||||
%D%/packages/patches/texlive-bin-poppler-0.86.patch \
|
||||
%D%/packages/patches/telegram-purple-adjust-test.patch \
|
||||
%D%/packages/patches/telepathy-glib-channel-memory-leak.patch \
|
||||
%D%/packages/patches/texi2html-document-encoding.patch \
|
||||
|
|
|
@ -0,0 +1,17 @@
|
|||
Fix build with Poppler 0.86 and later.
|
||||
|
||||
Taken from Arch Linux, but adjusted to patch the versioned Poppler
|
||||
files, as upstream applies it after copying them in place.
|
||||
https://git.archlinux.org/svntogit/packages.git/tree/trunk/texlive-poppler-0.86.patch?h=packages/texlive-bin
|
||||
|
||||
--- a/texk/web2c/pdftexdir/pdftoepdf-poppler0.76.0.cc 2020-03-03 21:11:35.102711802 +0000
|
||||
+++ b/texk/web2c/pdftexdir/pdftoepdf-poppler0.76.0.cc 2020-03-03 21:13:13.057420111 +0000
|
||||
@@ -757,7 +757,7 @@
|
||||
if (page_name) {
|
||||
// get page by name
|
||||
GString name(page_name);
|
||||
- LinkDest *link = pdf_doc->doc->findDest(&name);
|
||||
+ LinkDest *link = pdf_doc->doc->findDest(&name).get();
|
||||
if (link == 0 || !link->isOk())
|
||||
pdftex_fail("PDF inclusion: invalid destination <%s>", page_name);
|
||||
Ref ref = link->getPageRef();
|
|
@ -255,7 +255,8 @@ files from LOCATIONS with expected checksum HASH. CODE is not currently in use.
|
|||
"03vc88dz37mjjyaspzv0fik2fp5gp8qv82114869akd1dhszbaax")
|
||||
(search-patch "texlive-bin-poppler-0.83.patch")
|
||||
(arch-patch "texlive-poppler-0.84.patch" arch-revision
|
||||
"1ia6cr99krk4ipx4hdi2qdb98bh2h26mckjlpxdzrjnfhlnghksa"))))
|
||||
"1ia6cr99krk4ipx4hdi2qdb98bh2h26mckjlpxdzrjnfhlnghksa")
|
||||
(search-patch "texlive-bin-poppler-0.86.patch"))))
|
||||
(modules '((guix build utils)
|
||||
(ice-9 ftw)))
|
||||
(snippet
|
||||
|
|
Reference in New Issue