gnu: tomb: Update to 2.7.
* gnu/packages/patches/tomb-fix-errors-on-open.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/crypto.scm (tomb): Update to 2.7. [source]: Use the patch.master
parent
528b52390d
commit
4535eb91c3
|
@ -1386,6 +1386,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/tk-find-library.patch \
|
%D%/packages/patches/tk-find-library.patch \
|
||||||
%D%/packages/patches/ttf2eot-cstddef.patch \
|
%D%/packages/patches/ttf2eot-cstddef.patch \
|
||||||
%D%/packages/patches/ttfautohint-source-date-epoch.patch \
|
%D%/packages/patches/ttfautohint-source-date-epoch.patch \
|
||||||
|
%D%/packages/patches/tomb-fix-errors-on-open.patch \
|
||||||
%D%/packages/patches/totem-meson-compat.patch \
|
%D%/packages/patches/totem-meson-compat.patch \
|
||||||
%D%/packages/patches/totem-meson-easy-codec.patch \
|
%D%/packages/patches/totem-meson-easy-codec.patch \
|
||||||
%D%/packages/patches/tuxpaint-stamps-path.patch \
|
%D%/packages/patches/tuxpaint-stamps-path.patch \
|
||||||
|
|
|
@ -339,14 +339,15 @@ no man page, refer to the home page for usage details.")
|
||||||
(define-public tomb
|
(define-public tomb
|
||||||
(package
|
(package
|
||||||
(name "tomb")
|
(name "tomb")
|
||||||
(version "2.6")
|
(version "2.7")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "https://files.dyne.org/tomb/"
|
(uri (string-append "https://files.dyne.org/tomb/"
|
||||||
"Tomb-" version ".tar.gz"))
|
"Tomb-" version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1sr3jcn96mciyn8xd0amd1jzamxxzpybakf8an7laf26gjim1dh2"))))
|
"0x3al02796vx1cvy6y6h685c367qx70dwv471g0hmks2gr10f0cn"))
|
||||||
|
(patches (search-patches "tomb-fix-errors-on-open.patch"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(native-inputs `(("sudo" ,sudo))) ;presence needed for 'check' phase
|
(native-inputs `(("sudo" ,sudo))) ;presence needed for 'check' phase
|
||||||
(inputs
|
(inputs
|
||||||
|
|
|
@ -0,0 +1,25 @@
|
||||||
|
Description: Avoid error messages when opening a new tomb
|
||||||
|
Make sure control file exists and has user ownership before user writes to it.
|
||||||
|
Author: Sven Geuer <debmaint@g-e-u-e-r.de>
|
||||||
|
Bug: https://github.com/dyne/Tomb/issues/369
|
||||||
|
Last-Update: 2019-11-04
|
||||||
|
--- a/tomb
|
||||||
|
+++ b/tomb
|
||||||
|
@@ -2197,14 +2197,15 @@
|
||||||
|
# {{{ Open
|
||||||
|
|
||||||
|
_update_control_file() {
|
||||||
|
- # replaces a control file with new contents and gives it user ownership
|
||||||
|
+ # make sure a control file exists, gives it user ownership
|
||||||
|
+ # and replaces it with new contents
|
||||||
|
# stdin = contents
|
||||||
|
# $1 = path to control file
|
||||||
|
# $2 = contents
|
||||||
|
[[ "$2" = "" ]] && return 1
|
||||||
|
_sudo touch "$1"
|
||||||
|
- print "$2" > "$1"
|
||||||
|
_sudo chown ${_UID}:${_GID} "$1"
|
||||||
|
+ print "$2" > "$1"
|
||||||
|
_verbose "updated control file $1 = $2"
|
||||||
|
}
|
||||||
|
|
Reference in New Issue