me
/
guix
Archived
1
0
Fork 0

gnu: libaio: Fix tests on 32 bit systems.

* gnu/packages/patches/libaio-32bit-test.patch: New file.
* gnu/packages/linux.scm (libaio): Add patch.
* gnu/local.mk (dist_patch_DATA): Register patch.
master
Andreas Enge 2023-03-18 10:36:22 +01:00
parent f9bff8614b
commit 483124bc48
No known key found for this signature in database
GPG Key ID: F7D5C9BF765C61E3
3 changed files with 29 additions and 1 deletions

View File

@ -1406,6 +1406,7 @@ dist_patch_DATA = \
%D%/packages/patches/liba52-link-with-libm.patch \
%D%/packages/patches/liba52-set-soname.patch \
%D%/packages/patches/liba52-use-mtune-not-mcpu.patch \
%D%/packages/patches/libaio-32bit-test.patch \
%D%/packages/patches/libbase-fix-includes.patch \
%D%/packages/patches/libbase-use-own-logging.patch \
%D%/packages/patches/libbonobo-activation-test-race.patch \

View File

@ -5535,7 +5535,8 @@ Linux Device Mapper multipathing driver:
name "-" version ".tar.gz")))
(sha256
(base32
"02r0g2vfv6kfljplm3ga93w4xw13q2wixbn9hwi7ahqdzp2x2i1c"))))
"02r0g2vfv6kfljplm3ga93w4xw13q2wixbn9hwi7ahqdzp2x2i1c"))
(patches (search-patches "libaio-32bit-test.patch"))))
(build-system gnu-build-system)
(arguments
(list #:make-flags

View File

@ -0,0 +1,26 @@
This fix comes from an upstream pull request, see
https://pagure.io/libaio/pull-request/22#commit_list
diff --git a/harness/cases/23.t b/harness/cases/23.t
index cc5a8a1..9bbb05c 100644
--- a/harness/cases/23.t
+++ b/harness/cases/23.t
@@ -72,7 +72,7 @@ static void fail_errno(const char *format, ...)
static void *thrproc2(void *arg)
{
for (;;) {
- off_t offset = 0;
+ off64_t offset = 0;
pthread_barrier_wait(&barrier);
if (exiting)
@@ -92,7 +92,7 @@ static void *thrproc3(void *arg)
{
for (;;) {
char c;
- off_t offset = 0;
+ off64_t offset = 0;
pthread_barrier_wait(&barrier);
if (exiting)