gnu: xf86-video-intel: Update to 2.21.15.
* gnu/packages/patches/xf86-video-intel-compat-api.patch, gnu/packages/patches/xf86-video-intel-glibc-2.20.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/xorg.scm (xf86-video-intel): Update to 2.21.15. Add patches. Add eudev to inputs.master
parent
7504007211
commit
49a9099ebc
|
@ -463,6 +463,8 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/xf86-video-geode-glibc-2.20.patch \
|
||||
gnu/packages/patches/xf86-video-glint-remove-mibstore.patch \
|
||||
gnu/packages/patches/xf86-video-i128-remove-mibstore.patch \
|
||||
gnu/packages/patches/xf86-video-intel-compat-api.patch \
|
||||
gnu/packages/patches/xf86-video-intel-glibc-2.20.patch \
|
||||
gnu/packages/patches/xf86-video-openchrome-includes.patch \
|
||||
gnu/packages/patches/xfce4-panel-plugins.patch \
|
||||
gnu/packages/patches/xmodmap-asprintf.patch
|
||||
|
|
|
@ -0,0 +1,13 @@
|
|||
This patch was copied from Debian.
|
||||
|
||||
--- xserver-xorg-video-intel-2.21.15.orig/src/compat-api.h
|
||||
+++ xserver-xorg-video-intel-2.21.15/src/compat-api.h
|
||||
@@ -158,4 +158,8 @@
|
||||
if ((d)->pScreen->SourceValidate) (d)->pScreen->SourceValidate(d, x, y, w, h)
|
||||
#endif
|
||||
|
||||
+#if XORG_VERSION_CURRENT >= XORG_VERSION_NUMERIC(1,14,99,2,0)
|
||||
+#define DamageUnregister(d, dd) DamageUnregister(dd)
|
||||
+#endif
|
||||
+
|
||||
#endif
|
|
@ -0,0 +1,15 @@
|
|||
Allow builds with glibc 2.20.
|
||||
Based on a patch by Peter Hutterer <peter.hutterer@who-t.net>.
|
||||
See <https://raw.githubusercontent.com/openembedded/oe-core/master/meta/recipes-graphics/xorg-driver/xf86-input-synaptics/always_include_xorg_server.h.patch>.
|
||||
|
||||
--- xf86-video-intel-2.21.15/src/intel_device.c.~1~ 2013-08-09 16:58:48.000000000 -0400
|
||||
+++ xf86-video-intel-2.21.15/src/intel_device.c 2014-12-18 00:03:54.700759577 -0500
|
||||
@@ -33,6 +33,8 @@
|
||||
|
||||
#include <sys/ioctl.h>
|
||||
|
||||
+#include <xorg-server.h>
|
||||
+
|
||||
#include <pciaccess.h>
|
||||
#include <xf86.h>
|
||||
#include <xf86drm.h>
|
|
@ -2585,19 +2585,22 @@ devices, thus making direct access unnecessary.")
|
|||
(define-public xf86-video-intel
|
||||
(package
|
||||
(name "xf86-video-intel")
|
||||
(version "2.19.0")
|
||||
(version "2.21.15")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
"mirror://xorg/X11R7.7/src/everything/xf86-video-intel-"
|
||||
"mirror://xorg/individual/driver/xf86-video-intel-"
|
||||
version
|
||||
".tar.bz2"))
|
||||
(sha256
|
||||
(base32
|
||||
"1g742szymajh88a5dw08sxcr45bmxgc4w3m6hddv9qscn5hks4rj"))))
|
||||
"1z6ncmpszmwqi9xr590c4kp4gjjf7mndcr56r35x2bx7h87i8nkx"))
|
||||
(patches (list (search-patch "xf86-video-intel-compat-api.patch")
|
||||
(search-patch "xf86-video-intel-glibc-2.20.patch")))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs `(("mesa" ,mesa)
|
||||
("udev" ,eudev)
|
||||
("libx11" ,libx11)
|
||||
("xorg-server" ,xorg-server)))
|
||||
(native-inputs
|
||||
|
|
Reference in New Issue