gnu: handbrake: Upgrade to 1.2.0.
* gnu/packages/patches/handbrake-opt-in-nvenc.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/video.scm (handbrake)[source]: Upgrade to 1.2.0. Use patch. [native-inputs]: Add cmake. [inputs]: Add speex. [arguments]: Disable runtime update checks via #:configure-flags.master
parent
3292219097
commit
4bdd41bb83
|
@ -812,6 +812,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/gtk3-respect-GUIX_GTK3_IM_MODULE_FILE.patch \
|
||||
%D%/packages/patches/gtkglext-disable-disable-deprecated.patch \
|
||||
%D%/packages/patches/gzdoom-search-in-installed-share.patch \
|
||||
%D%/packages/patches/handbrake-opt-in-nvenc.patch \
|
||||
%D%/packages/patches/haskell-mode-unused-variables.patch \
|
||||
%D%/packages/patches/haskell-mode-make-check.patch \
|
||||
%D%/packages/patches/hdf4-architectures.patch \
|
||||
|
|
|
@ -0,0 +1,14 @@
|
|||
Require opt-in for NVEnc support. Otherwise the default is true with no way
|
||||
to disable it.
|
||||
|
||||
--- HandBrake-1.2.0/make/configure.py.orig 1969-12-31 18:00:00.000000000 -0600
|
||||
+++ HandBrake-1.2.0/make/configure.py 2019-01-22 23:22:46.186959060 -0600
|
||||
@@ -1320,7 +1320,7 @@
|
||||
grp.add_option( '--disable-ffmpeg-aac', dest="enable_ffmpeg_aac", action='store_false' )
|
||||
|
||||
h = IfHost( 'enable Nvidia NVEnc video encoder', '*-*-*', none=optparse.SUPPRESS_HELP ).value
|
||||
- grp.add_option( '--enable-nvenc', dest="enable_nvenc", default=not (host.match( '*-*-darwin*' ) or host.match( '*-*-freebsd*' )), action='store_true', help=h )
|
||||
+ grp.add_option( '--enable-nvenc', dest="enable_nvenc", default=False, action='store_true', help=h )
|
||||
|
||||
|
||||
cli.add_option_group( grp )
|
|
@ -12,7 +12,7 @@
|
|||
;;; Copyright © 2016 Dmitry Nikolaev <cameltheman@gmail.com>
|
||||
;;; Copyright © 2016 Andy Patterson <ajpatter@uwaterloo.ca>
|
||||
;;; Copyright © 2016, 2017 Nils Gillmann <ng0@n0.is>
|
||||
;;; Copyright © 2016, 2018 Eric Bavier <bavier@member.fsf.org>
|
||||
;;; Copyright © 2016, 2018, 2019 Eric Bavier <bavier@member.fsf.org>
|
||||
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
|
||||
;;; Copyright © 2017 Feng Shu <tumashu@163.com>
|
||||
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
|
||||
|
@ -2430,14 +2430,14 @@ supported players in addition to this package.")
|
|||
(define-public handbrake
|
||||
(package
|
||||
(name "handbrake")
|
||||
(version "1.1.2")
|
||||
(version "1.2.0")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://download.handbrake.fr/releases/"
|
||||
version "/HandBrake-" version "-source.tar.bz2"))
|
||||
(sha256
|
||||
(base32
|
||||
"0bny0hwlr55g2c69rsamv0xvwmfh1s4a582b9vq20xv5ly84m6ms"))
|
||||
"03clkknaq3mz84p85cvr21gsy9b8vv2g4vvyfz44hz8la253jfqi"))
|
||||
(modules '((guix build utils)))
|
||||
(snippet
|
||||
;; Remove "contrib" and source not necessary for
|
||||
|
@ -2451,11 +2451,13 @@ supported players in addition to this package.")
|
|||
;; which would lead to fetching and building of these
|
||||
;; libraries. Use our own instead.
|
||||
(("MODULES \\+= contrib") "# MODULES += contrib"))
|
||||
#t))))
|
||||
#t))
|
||||
(patches (search-patches "handbrake-opt-in-nvenc.patch"))))
|
||||
(build-system glib-or-gtk-build-system)
|
||||
(native-inputs
|
||||
`(("automake" ,automake) ;gui subpackage must be bootstrapped
|
||||
("autoconf" ,autoconf)
|
||||
("cmake" ,cmake) ;TODO: could probably strip check from make/configure.py
|
||||
("curl" ,curl) ;not actually used, but tested for
|
||||
("intltool" ,intltool)
|
||||
("libtool" ,libtool)
|
||||
|
@ -2488,12 +2490,14 @@ supported players in addition to this package.")
|
|||
("libvpx" ,libvpx)
|
||||
("libxml2" ,libxml2)
|
||||
("libx264" ,libx264)
|
||||
("speex" ,speex)
|
||||
("x265" ,x265)
|
||||
("zlib" ,zlib)))
|
||||
(arguments
|
||||
`(#:tests? #f ;tests require Ruby and claim to be unsupported
|
||||
#:configure-flags
|
||||
(list (string-append "CPPFLAGS=-I"
|
||||
(list "--disable-gtk-update-checks"
|
||||
(string-append "CPPFLAGS=-I"
|
||||
(assoc-ref %build-inputs "libxml2")
|
||||
"/include/libxml2")
|
||||
"LDFLAGS=-lx265")
|
||||
|
|
Reference in New Issue