me
/
guix
Archived
1
0
Fork 0

gnu: Add fuzzylite.

* gnu/packages/games.scm (fuzzylite): New variable.
* gnu/packages/patches/fuzzylite-relative-path-in-tests.patch: New file.
* gnu/packages/patches/fuzzylite-use-catch2.patch: New file.
* gnu/packages/patches/fuzzylite-soften-float-equality.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register them here.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Vagrant Cascadian 2023-05-12 16:18:18 -07:00 committed by Liliana Marie Prikler
parent 1f42ba3533
commit 4c610d2b2e
No known key found for this signature in database
GPG Key ID: 442A84B8C70E2F87
5 changed files with 263 additions and 0 deletions

View File

@ -1157,6 +1157,9 @@ dist_patch_DATA = \
%D%/packages/patches/freeimage-unbundle.patch \
%D%/packages/patches/fuse-glibc-2.34.patch \
%D%/packages/patches/fuse-overlapping-headers.patch \
%D%/packages/patches/fuzzylite-relative-path-in-tests.patch \
%D%/packages/patches/fuzzylite-use-catch2.patch \
%D%/packages/patches/fuzzylite-soften-float-equality.patch \
%D%/packages/patches/fxdiv-system-libraries.patch \
%D%/packages/patches/gajim-honour-GAJIM_PLUGIN_PATH.patch \
%D%/packages/patches/ganeti-disable-version-symlinks.patch \

View File

@ -3645,6 +3645,37 @@ exec ~a/bin/freedink -refdir ~a/share/dink\n"
("bash" ,bash)))
(native-inputs '())))
(define-public fuzzylite
(package
(name "fuzzylite")
(version "6.0")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/fuzzylite/fuzzylite")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
"0yay0qc81x0irlvxqpy7jywjxpkmpjabdhq2hdh28r9z85wp2nwb"))
(patches (search-patches "fuzzylite-use-catch2.patch"
"fuzzylite-soften-float-equality.patch"
"fuzzylite-relative-path-in-tests.patch"))))
(build-system cmake-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
(add-before 'configure 'switch-to-fuzzylite-dir
(lambda _
(chdir "fuzzylite"))))))
(native-inputs (list catch2))
(home-page "https://www.fuzzylite.com/")
(synopsis "Fuzzy logic control binary")
(description
"This package provides fuzzylite, a fuzzy logic control library which
allows one to easily create fuzzy logic controllers in a few steps utilizing
object-oriented programming.")
(license license:gpl3)))
(define-public xboard
(package
(name "xboard")

View File

@ -0,0 +1,15 @@
Workaround https://github.com/fuzzylite/fuzzylite/issues/85
diff --git a/fuzzylite/test/BenchmarkTest.cpp b/fuzzylite/test/BenchmarkTest.cpp
index f868ec29..464d394d 100644
--- a/fuzzylite/test/BenchmarkTest.cpp
+++ b/fuzzylite/test/BenchmarkTest.cpp
@@ -30,7 +30,7 @@ namespace fl {
}
TEST_CASE("Benchmarks from FLD files", "[benchmark][fld]") {
- std::string path = "../../examples/";
+ std::string path = "../examples/";
typedef std::pair<std::string, int > Example;
std::vector<Example> examples;
examples.push_back(Example("mamdani/AllTerms", int(1e4)));

View File

@ -0,0 +1,30 @@
Origin: https://salsa.debian.org/debian/fuzzylite/-/blob/debian/6.0+dfsg-6/debian/patches/when-testing-large-float-numbers-for-equ.patch
From: Johannes 'josch' Schauer <josch@debian.org>
Date: Sun, 3 Feb 2019 10:33:22 +0100
X-Dgit-Generated: 6.0+dfsg-2 80960ae38da9db032dfbfec6405398653e8205ff
Subject: when testing large float numbers for equality, use a larger epsilon
---
--- fuzzylite-6.0+dfsg.orig/fuzzylite/test/BenchmarkTest.cpp
+++ fuzzylite-6.0+dfsg/fuzzylite/test/BenchmarkTest.cpp
@@ -96,7 +96,17 @@ namespace fl {
CHECK(Op::isEq(1.0, Benchmark::convert(1000.0, Benchmark::MilliSeconds, Benchmark::Seconds)));
FL_LOG(Benchmark::convert(1000.0, Benchmark::MilliSeconds, Benchmark::Seconds));
- CHECK(Op::isEq(35e9, Benchmark::convert(35, Benchmark::Seconds, Benchmark::NanoSeconds)));
+ scalar eps =
+#ifndef __i386__
+ fuzzylite::macheps();
+#else
+ // on i386, due to the 80bit x87 register, double floating point
+ // numbers are handled differently and thus the difference between
+ // 35e9 and the result of Benchmark::convert() will be 2.179e-6,
+ // which is greater than the default epsilon of 1e-6.
+ 1e-5;
+#endif
+ CHECK(Op::isEq(35e9, Benchmark::convert(35, Benchmark::Seconds, Benchmark::NanoSeconds), eps));
CHECK(Op::isEq(35, Benchmark::convert(35e9, Benchmark::NanoSeconds, Benchmark::Seconds)));
}

View File

@ -0,0 +1,184 @@
Origin: https://salsa.debian.org/debian/fuzzylite/-/blob/debian/6.0+dfsg-6/debian/patches/fix-tests2.patch
From: Ferdinand Thiessen <rpm@fthiessen.de>
Date: Mon, 31 Jan 2022 16:06:19 GMT
Subject: Replace Catch with Catch2 and require C++11 for tests
Origin: vendor, https://github.com/fuzzylite/fuzzylite/issues/94
Bug-Debian: http://bugs.debian.org/1017155
--- a/fuzzylite/CMakeLists.txt
+++ b/fuzzylite/CMakeLists.txt
@@ -194,7 +194,9 @@ if(FL_BUILD_BINARY)
endif(FL_BUILD_BINARY)
if(FL_BUILD_TESTS)
+ find_package(Catch2)
add_executable(fl-test ${fl-headers} ${fl-tests})
+ target_link_libraries(fl-test Catch2::Catch2)
set_target_properties(fl-test PROPERTIES OUTPUT_NAME fuzzylite-tests)
set_target_properties(fl-test PROPERTIES OUTPUT_NAME fuzzylite-tests IMPORT_PREFIX tmp-) #To prevent LNK1149 in Windows
set_target_properties(fl-test PROPERTIES DEBUG_POSTFIX -debug)
--- a/fuzzylite/test/activation/ThresholdTest.cpp
+++ b/fuzzylite/test/activation/ThresholdTest.cpp
@@ -14,7 +14,7 @@
fuzzylite is a registered trademark of FuzzyLite Limited.
*/
-#include "test/catch.hpp"
+#include "catch2/catch.hpp"
#include "fl/Headers.h"
namespace fl {
--- a/fuzzylite/test/BenchmarkTest.cpp
+++ b/fuzzylite/test/BenchmarkTest.cpp
@@ -16,7 +16,7 @@
#include "fl/Benchmark.h"
-#include "test/catch.hpp"
+#include "catch2/catch.hpp"
#include "fl/Headers.h"
#include <vector>
--- a/fuzzylite/test/hedge/HedgeFunctionTest.cpp
+++ b/fuzzylite/test/hedge/HedgeFunctionTest.cpp
@@ -14,7 +14,7 @@
fuzzylite is a registered trademark of FuzzyLite Limited.
*/
-#include "test/catch.hpp"
+#include "catch2/catch.hpp"
#include "fl/Headers.h"
namespace fl {
--- a/fuzzylite/test/imex/FldExporterTest.cpp
+++ b/fuzzylite/test/imex/FldExporterTest.cpp
@@ -14,7 +14,7 @@
fuzzylite is a registered trademark of FuzzyLite Limited.
*/
-#include "test/catch.hpp"
+#include "catch2/catch.hpp"
#include "fl/Headers.h"
namespace fl {
--- a/fuzzylite/test/imex/FllImporterTest.cpp
+++ b/fuzzylite/test/imex/FllImporterTest.cpp
@@ -14,7 +14,7 @@
fuzzylite is a registered trademark of FuzzyLite Limited.
*/
-#include "test/catch.hpp"
+#include "catch2/catch.hpp"
#include "fl/Headers.h"
namespace fl {
--- a/fuzzylite/test/imex/RScriptExporterTest.cpp
+++ b/fuzzylite/test/imex/RScriptExporterTest.cpp
@@ -14,7 +14,7 @@
fuzzylite is a registered trademark of FuzzyLite Limited.
*/
-#include "test/catch.hpp"
+#include "catch2/catch.hpp"
#include "fl/Headers.h"
#include <fstream>
--- a/fuzzylite/test/MainTest.cpp
+++ b/fuzzylite/test/MainTest.cpp
@@ -16,7 +16,7 @@
#define CATCH_CONFIG_RUNNER
-#include "test/catch.hpp"
+#include "catch2/catch.hpp"
#include "fl/Headers.h"
--- a/fuzzylite/test/norm/NormFunctionTest.cpp
+++ b/fuzzylite/test/norm/NormFunctionTest.cpp
@@ -14,7 +14,7 @@
fuzzylite is a registered trademark of FuzzyLite Limited.
*/
-#include "test/catch.hpp"
+#include "catch2/catch.hpp"
#include "fl/Headers.h"
namespace fl {
--- a/fuzzylite/test/QuickTest.cpp
+++ b/fuzzylite/test/QuickTest.cpp
@@ -14,7 +14,7 @@
fuzzylite is a registered trademark of FuzzyLite Limited.
*/
-#include "test/catch.hpp"
+#include "catch2/catch.hpp"
#include "fl/Headers.h"
namespace fl {
--- a/fuzzylite/test/term/AggregatedTest.cpp
+++ b/fuzzylite/test/term/AggregatedTest.cpp
@@ -14,7 +14,7 @@
fuzzylite is a registered trademark of FuzzyLite Limited.
*/
-#include "test/catch.hpp"
+#include "catch2/catch.hpp"
#include "fl/Headers.h"
namespace fl {
--- a/fuzzylite/test/term/DiscreteTest.cpp
+++ b/fuzzylite/test/term/DiscreteTest.cpp
@@ -14,7 +14,7 @@
fuzzylite is a registered trademark of FuzzyLite Limited.
*/
-#include "test/catch.hpp"
+#include "catch2/catch.hpp"
#include "fl/Headers.h"
namespace fl {
--- a/fuzzylite/test/term/FunctionTest.cpp
+++ b/fuzzylite/test/term/FunctionTest.cpp
@@ -14,7 +14,7 @@
fuzzylite is a registered trademark of FuzzyLite Limited.
*/
-#include "test/catch.hpp"
+#include "catch2/catch.hpp"
#include "fl/Headers.h"
namespace fl {
--- a/fuzzylite/test/term/TrapezoidTest.cpp
+++ b/fuzzylite/test/term/TrapezoidTest.cpp
@@ -14,7 +14,7 @@
fuzzylite is a registered trademark of FuzzyLite Limited.
*/
-#include "test/catch.hpp"
+#include "catch2/catch.hpp"
#include "fl/Headers.h"
namespace fl {
--- a/fuzzylite/test/term/TriangleTest.cpp
+++ b/fuzzylite/test/term/TriangleTest.cpp
@@ -14,7 +14,7 @@
fuzzylite is a registered trademark of FuzzyLite Limited.
*/
-#include "test/catch.hpp"
+#include "catch2/catch.hpp"
#include "fl/Headers.h"
namespace fl {
--- a/fuzzylite/test/variable/VariableTest.cpp
+++ b/fuzzylite/test/variable/VariableTest.cpp
@@ -14,7 +14,7 @@
fuzzylite is a registered trademark of FuzzyLite Limited.
*/
-#include "test/catch.hpp"
+#include "catch2/catch.hpp"
#include "fl/Headers.h"
#include <algorithm> // std::random_shuffle