gnu: Add aws-checksums.
* gnu/packages/c.scm (aws-checksums): New variable. * gnu/packages/patches/aws-checksums-cmake-prefix.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>master
parent
5f998a5cdb
commit
4c66a8deb5
|
@ -823,6 +823,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/avogadro-python-eigen-lib.patch \
|
%D%/packages/patches/avogadro-python-eigen-lib.patch \
|
||||||
%D%/packages/patches/avidemux-install-to-lib.patch \
|
%D%/packages/patches/avidemux-install-to-lib.patch \
|
||||||
%D%/packages/patches/awesome-reproducible-png.patch \
|
%D%/packages/patches/awesome-reproducible-png.patch \
|
||||||
|
%D%/packages/patches/aws-checksums-cmake-prefix.patch \
|
||||||
%D%/packages/patches/azr3.patch \
|
%D%/packages/patches/azr3.patch \
|
||||||
%D%/packages/patches/bash-reproducible-linux-pgrp-pipe.patch \
|
%D%/packages/patches/bash-reproducible-linux-pgrp-pipe.patch \
|
||||||
%D%/packages/patches/bash-completion-directories.patch \
|
%D%/packages/patches/bash-completion-directories.patch \
|
||||||
|
|
|
@ -36,6 +36,7 @@
|
||||||
#:use-module (guix build-system cmake)
|
#:use-module (guix build-system cmake)
|
||||||
#:use-module (guix build-system gnu)
|
#:use-module (guix build-system gnu)
|
||||||
#:use-module (guix build-system trivial)
|
#:use-module (guix build-system trivial)
|
||||||
|
#:use-module (gnu packages)
|
||||||
#:use-module (gnu packages bootstrap)
|
#:use-module (gnu packages bootstrap)
|
||||||
#:use-module (gnu packages bison)
|
#:use-module (gnu packages bison)
|
||||||
#:use-module (gnu packages check)
|
#:use-module (gnu packages check)
|
||||||
|
@ -559,3 +560,27 @@ portability.")
|
||||||
structures, and error handling for the @acronym{AWS,Amazon Web Services} SDK.")
|
structures, and error handling for the @acronym{AWS,Amazon Web Services} SDK.")
|
||||||
(home-page "https://github.com/awslabs/aws-c-common")
|
(home-page "https://github.com/awslabs/aws-c-common")
|
||||||
(license license:asl2.0)))
|
(license license:asl2.0)))
|
||||||
|
|
||||||
|
(define-public aws-checksums
|
||||||
|
(package
|
||||||
|
(name "aws-checksums")
|
||||||
|
(version "0.1.10")
|
||||||
|
(source (origin
|
||||||
|
(method git-fetch)
|
||||||
|
(uri (git-reference
|
||||||
|
(url (string-append "https://github.com/awslabs/" name))
|
||||||
|
(commit (string-append "v" version))))
|
||||||
|
(file-name (git-file-name name version))
|
||||||
|
(sha256
|
||||||
|
(base32
|
||||||
|
"1f9scl5734pgjlsixspwljrrlndzhllwlfygdcr1gx5p0za08zjb"))
|
||||||
|
(patches (search-patches "aws-checksums-cmake-prefix.patch"))))
|
||||||
|
(build-system cmake-build-system)
|
||||||
|
(inputs
|
||||||
|
`(("aws-c-common" ,aws-c-common)))
|
||||||
|
(synopsis "Amazon Web Services checksum library")
|
||||||
|
(description
|
||||||
|
"This library provides cross-Platform hardware accelerated CRC32c and CRC32
|
||||||
|
with fallback to efficient C99 software implementations.")
|
||||||
|
(home-page "https://github.com/awslabs/aws-checksums")
|
||||||
|
(license license:asl2.0)))
|
||||||
|
|
|
@ -0,0 +1,13 @@
|
||||||
|
--- a/CMakeLists.txt
|
||||||
|
+++ b/CMakeLists.txt
|
||||||
|
@@ -8,6 +8,10 @@
|
||||||
|
cmake_policy(SET CMP0069 NEW) # Enable LTO/IPO if available in the compiler, see AwsCFlags
|
||||||
|
endif()
|
||||||
|
|
||||||
|
+if (DEFINED ENV{CMAKE_PREFIX_PATH})
|
||||||
|
+ set(CMAKE_PREFIX_PATH $ENV{CMAKE_PREFIX_PATH})
|
||||||
|
+endif()
|
||||||
|
+
|
||||||
|
if (DEFINED CMAKE_PREFIX_PATH)
|
||||||
|
file(TO_CMAKE_PATH "${CMAKE_PREFIX_PATH}" CMAKE_PREFIX_PATH)
|
||||||
|
endif()
|
Reference in New Issue