gnu: aspell: Update to 0.60.8.
* gnu/packages/aspell.scm (aspell): Update to 0.60.8. [source]: Remove patch. * gnu/packages/patches/aspell-gcc-compat.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.master
parent
1ee0ac3f0d
commit
4fcb6a3558
|
@ -695,7 +695,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/antlr3-3_3-fix-java8-compilation.patch \
|
%D%/packages/patches/antlr3-3_3-fix-java8-compilation.patch \
|
||||||
%D%/packages/patches/apr-skip-getservbyname-test.patch \
|
%D%/packages/patches/apr-skip-getservbyname-test.patch \
|
||||||
%D%/packages/patches/aspell-default-dict-dir.patch \
|
%D%/packages/patches/aspell-default-dict-dir.patch \
|
||||||
%D%/packages/patches/aspell-gcc-compat.patch \
|
|
||||||
%D%/packages/patches/ath9k-htc-firmware-binutils.patch \
|
%D%/packages/patches/ath9k-htc-firmware-binutils.patch \
|
||||||
%D%/packages/patches/ath9k-htc-firmware-gcc.patch \
|
%D%/packages/patches/ath9k-htc-firmware-gcc.patch \
|
||||||
%D%/packages/patches/ath9k-htc-firmware-objcopy.patch \
|
%D%/packages/patches/ath9k-htc-firmware-objcopy.patch \
|
||||||
|
|
|
@ -38,7 +38,7 @@
|
||||||
(define-public aspell
|
(define-public aspell
|
||||||
(package
|
(package
|
||||||
(name "aspell")
|
(name "aspell")
|
||||||
(version "0.60.6.1")
|
(version "0.60.8")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
|
@ -46,9 +46,8 @@
|
||||||
version ".tar.gz"))
|
version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1qgn5psfyhbrnap275xjfrzppf5a83fb67gpql0kfqv37al869gm"))
|
"1wi60ankalmh8ds7nplz434jd7j94gdvbahdwsr539rlad8pxdzr"))
|
||||||
(patches (search-patches "aspell-default-dict-dir.patch"
|
(patches (search-patches "aspell-default-dict-dir.patch"))))
|
||||||
"aspell-gcc-compat.patch"))))
|
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(#:phases
|
`(#:phases
|
||||||
|
@ -144,7 +143,7 @@ dictionaries, including personal ones.")
|
||||||
(define-public aspell-dict-ar
|
(define-public aspell-dict-ar
|
||||||
(aspell-dictionary "ar" "Arabic"
|
(aspell-dictionary "ar" "Arabic"
|
||||||
#:version "1.2-0"
|
#:version "1.2-0"
|
||||||
#:prefix "aspell6-"
|
#:prefix "aspell6-"
|
||||||
#:sha256
|
#:sha256
|
||||||
(base32
|
(base32
|
||||||
"1avw40bp8yi5bnkq64ihm2rldgw34lk89yz281q9bmndh95a47h4")))
|
"1avw40bp8yi5bnkq64ihm2rldgw34lk89yz281q9bmndh95a47h4")))
|
||||||
|
|
|
@ -1,31 +0,0 @@
|
||||||
Fix GCC7 warnings.
|
|
||||||
|
|
||||||
Taken from upstream:
|
|
||||||
https://git.savannah.gnu.org/cgit/aspell.git/commit/?id=8089fa02122fed0a6394eba14bbedcb1d18e2384
|
|
||||||
|
|
||||||
diff --git a/modules/filter/tex.cpp b/modules/filter/tex.cpp
|
|
||||||
index a979539..19ab63c 100644
|
|
||||||
--- a/modules/filter/tex.cpp
|
|
||||||
+++ b/modules/filter/tex.cpp
|
|
||||||
@@ -174,7 +174,7 @@ namespace {
|
|
||||||
|
|
||||||
if (c == '{') {
|
|
||||||
|
|
||||||
- if (top.in_what == Parm || top.in_what == Opt || top.do_check == '\0')
|
|
||||||
+ if (top.in_what == Parm || top.in_what == Opt || *top.do_check == '\0')
|
|
||||||
push_command(Parm);
|
|
||||||
|
|
||||||
top.in_what = Parm;
|
|
||||||
diff --git a/prog/check_funs.cpp b/prog/check_funs.cpp
|
|
||||||
index db54f3d..89ee09d 100644
|
|
||||||
--- a/prog/check_funs.cpp
|
|
||||||
+++ b/prog/check_funs.cpp
|
|
||||||
@@ -647,7 +647,7 @@ static void print_truncate(FILE * out, const char * word, int width) {
|
|
||||||
}
|
|
||||||
}
|
|
||||||
if (i == width-1) {
|
|
||||||
- if (word == '\0')
|
|
||||||
+ if (*word == '\0')
|
|
||||||
put(out,' ');
|
|
||||||
else if (word[len] == '\0')
|
|
||||||
put(out, word, len);
|
|
Reference in New Issue