gnu: slurm: Update to 17.11.2.
* gnu/packages/parallel.scm (slurm): Update to 17.11.2. [source]: Replace patch with less fragile SUBSTITUTE* in a snippet. [arguments]: Rename ‘autogen’ phase to ‘autoconf’. Use INVOKE. * gnu/packages/patches/slurm-configure-remove-nonfree-contribs.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.master
parent
5d5ad3da88
commit
4ff22ec3b1
|
@ -1082,7 +1082,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/slim-sigusr1.patch \
|
||||
%D%/packages/patches/slim-reset.patch \
|
||||
%D%/packages/patches/slim-login.patch \
|
||||
%D%/packages/patches/slurm-configure-remove-nonfree-contribs.patch \
|
||||
%D%/packages/patches/sooperlooper-build-with-wx-30.patch \
|
||||
%D%/packages/patches/steghide-fixes.patch \
|
||||
%D%/packages/patches/superlu-dist-scotchmetis.patch \
|
||||
|
|
|
@ -7,6 +7,7 @@
|
|||
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
|
||||
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
|
||||
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
|
||||
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
;;;
|
||||
|
@ -93,7 +94,7 @@ and they are executed on lists of files, hosts, users or other items.")
|
|||
(define-public slurm
|
||||
(package
|
||||
(name "slurm")
|
||||
(version "16.05.11")
|
||||
(version "17.11.2")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
|
@ -101,12 +102,12 @@ and they are executed on lists of files, hosts, users or other items.")
|
|||
version ".tar.bz2"))
|
||||
(sha256
|
||||
(base32
|
||||
"0c63mvh13wsp6jlydaz98v35iwg53mk94ynpx9dqn2z4gl53k5y7"))
|
||||
(patches (search-patches
|
||||
"slurm-configure-remove-nonfree-contribs.patch"))
|
||||
"18yakb8kmhb16n0cv3zhjv8ahvsk9p0max8mmr2flb2c65fawks6"))
|
||||
(modules '((guix build utils)))
|
||||
(snippet
|
||||
'(begin
|
||||
(substitute* "configure.ac"
|
||||
(("^[[:space:]]+contribs/.*$") ""))
|
||||
(delete-file-recursively "contribs")
|
||||
#t))))
|
||||
;; FIXME: More optional inputs could be added,
|
||||
|
@ -136,8 +137,8 @@ and they are executed on lists of files, hosts, users or other items.")
|
|||
(string-append "--with-ssl=" (assoc-ref %build-inputs "openssl")))
|
||||
#:phases
|
||||
(modify-phases %standard-phases
|
||||
(add-after 'unpack 'autogen
|
||||
(lambda _ (zero? (system* "autoconf"))))))) ; configure.ac was patched
|
||||
(add-after 'unpack 'autoconf
|
||||
(lambda _ (invoke "autoconf")))))) ; configure.ac was patched
|
||||
(home-page "http://slurm.schedmd.com/")
|
||||
(synopsis "Workload manager for cluster computing")
|
||||
(description
|
||||
|
|
|
@ -1,45 +0,0 @@
|
|||
From 49d83e24a8e66977056fc9920812265c16806500 Mon Sep 17 00:00:00 2001
|
||||
From: carolili <carolili@iki.fi>
|
||||
Date: Thu, 9 Feb 2017 19:24:49 +0000
|
||||
Subject: [PATCH] Removing contribs
|
||||
|
||||
---
|
||||
configure.ac | 22 ----------------------
|
||||
1 file changed, 22 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 1cf1051..5d76b44 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -435,28 +435,6 @@ dnl All slurm Makefiles:
|
||||
|
||||
AC_CONFIG_FILES([Makefile
|
||||
auxdir/Makefile
|
||||
- contribs/Makefile
|
||||
- contribs/cray/Makefile
|
||||
- contribs/cray/csm/Makefile
|
||||
- contribs/lua/Makefile
|
||||
- contribs/mic/Makefile
|
||||
- contribs/pam/Makefile
|
||||
- contribs/pam_slurm_adopt/Makefile
|
||||
- contribs/perlapi/Makefile
|
||||
- contribs/perlapi/libslurm/Makefile
|
||||
- contribs/perlapi/libslurm/perl/Makefile.PL
|
||||
- contribs/perlapi/libslurmdb/Makefile
|
||||
- contribs/perlapi/libslurmdb/perl/Makefile.PL
|
||||
- contribs/seff/Makefile
|
||||
- contribs/torque/Makefile
|
||||
- contribs/openlava/Makefile
|
||||
- contribs/phpext/Makefile
|
||||
- contribs/phpext/slurm_php/config.m4
|
||||
- contribs/sgather/Makefile
|
||||
- contribs/sgi/Makefile
|
||||
- contribs/sjobexit/Makefile
|
||||
- contribs/slurmdb-direct/Makefile
|
||||
- contribs/pmi2/Makefile
|
||||
doc/Makefile
|
||||
doc/man/Makefile
|
||||
doc/man/man1/Makefile
|
||||
--
|
||||
2.11.0
|
||||
|
Reference in New Issue