me
/
guix
Archived
1
0
Fork 0

gnu: java-commons-lang3: Update to 3.12.0

* gnu/packages/java.scm (java-commons-lang3): Update to 3.12.0.
* gnu/packages/patches/java-commons-lang-fix-dependency.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.

Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Artyom V. Poptsov 2022-06-12 22:34:28 +03:00 committed by Julien Lepiller
parent f2ed82eb53
commit 4ff9f1689d
No known key found for this signature in database
GPG Key ID: 53D457B2D636EE82
3 changed files with 44 additions and 2 deletions

View File

@ -1317,6 +1317,7 @@ dist_patch_DATA = \
%D%/packages/patches/java-tunnelvisionlabs-antlr-code-too-large.patch \
%D%/packages/patches/java-apache-ivy-port-to-latest-bouncycastle.patch \
%D%/packages/patches/java-commons-collections-fix-java8.patch \
%D%/packages/patches/java-commons-lang-fix-dependency.patch \
%D%/packages/patches/java-jeromq-fix-tests.patch \
%D%/packages/patches/java-openjfx-build-jdk_version.patch \
%D%/packages/patches/java-powermock-fix-java-files.patch \

View File

@ -18,6 +18,7 @@
;;; Copyright © 2021 Mike Gerwitz <mtg@gnu.org>
;;; Copyright © 2021 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@ -6206,14 +6207,16 @@ included:
(define-public java-commons-lang3
(package
(name "java-commons-lang3")
(version "3.9")
(version "3.12.0")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://apache/commons/lang/source/"
"commons-lang3-" version "-src.tar.gz"))
(sha256
(base32 "0s4ffbvsyl16c90l45ximsg4dwd8hmz7wsza3p308fw43h6mwhb6"))))
(base32 "09dcv1pkdx3hpf06py8p9511f1wkin6jpacdll0c8vxpbi3yfwzv"))
(patches
(search-patches "java-commons-lang-fix-dependency.patch"))))
(build-system ant-build-system)
(arguments
`(#:jar-name "commons-lang3.jar"

View File

@ -0,0 +1,38 @@
Prevent java-commons-lang3 from depending on junit-bom when used with
maven.
From 5c15b04ff9d05235460ea58f303fcf3502a943f2 Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Mon, 13 Jun 2022 09:25:42 +0300
Subject: [PATCH] pom.xml: Remove dependency on 'junit-bom'
---
pom.xml | 12 ------------
1 file changed, 12 deletions(-)
diff --git a/pom.xml b/pom.xml
index 167a85a47..6cd9be57b 100644
--- a/pom.xml
+++ b/pom.xml
@@ -513,18 +513,6 @@
</contributor>
</contributors>
- <dependencyManagement>
- <dependencies>
- <dependency>
- <groupId>org.junit</groupId>
- <artifactId>junit-bom</artifactId>
- <version>5.7.1</version>
- <type>pom</type>
- <scope>import</scope>
- </dependency>
- </dependencies>
- </dependencyManagement>
-
<!-- Lang should depend on very little -->
<dependencies>
<!-- testing -->
--
2.25.1