me
/
guix
Archived
1
0
Fork 0

gnu: pjproject: Update to 2.12.1.

* gnu/packages/telephony.scm (pjproject): Update to 2.12.1.
[source]: Delete patches field.
[arguments]: Use gexps.
* gnu/packages/patches/pjproject-install-libpjsua2.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): De-register it.
master
Maxim Cournoyer 2022-09-17 22:34:55 -04:00
parent dab3800691
commit 503cfd5421
No known key found for this signature in database
GPG Key ID: 1260E46482E63562
3 changed files with 93 additions and 112 deletions

View File

@ -1608,7 +1608,6 @@ dist_patch_DATA = \
%D%/packages/patches/password-store-tree-compat.patch \
%D%/packages/patches/pciutils-hurd-configure.patch \
%D%/packages/patches/pciutils-hurd-fix.patch \
%D%/packages/patches/pjproject-install-libpjsua2.patch \
%D%/packages/patches/plasma-framework-fix-KF5PlasmaMacros.cmake.patch \
%D%/packages/patches/pokerth-boost.patch \
%D%/packages/patches/ppsspp-disable-upgrade-and-gold.patch \

View File

@ -1,19 +0,0 @@
# Retrieved from upstream:
# https://github.com/pjsip/pjproject/commit/742f7dc252ded778a8b677937791c02e2fbc0dde
diff --git a/Makefile b/Makefile
index 31a6d39d4..74e246a44 100644
--- a/Makefile
+++ b/Makefile
@@ -121,9 +121,10 @@ cmp_wav:
install:
mkdir -p $(DESTDIR)$(libdir)/
- cp -af $(APP_LIB_FILES) $(DESTDIR)$(libdir)/
if [ "$(PJ_EXCLUDE_PJSUA2)x" = "x" ] ; then \
- cp -af $(PJ_DIR)/pjsip/lib/libpjsua2-$(LIB_SUFFIX) $(DESTDIR)$(libdir)/; \
+ cp -af $(APP_LIBXX_FILES) $(DESTDIR)$(libdir)/; \
+ else \
+ cp -af $(APP_LIB_FILES) $(DESTDIR)$(libdir)/; \
fi
mkdir -p $(DESTDIR)$(includedir)/
for d in pjlib pjlib-util pjnath pjmedia pjsip; do \

View File

@ -17,7 +17,7 @@
;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020, 2022 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
;;; Copyright © 2020, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2021 LibreMiami <packaging-guix@libremiami.org>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
@ -723,7 +723,7 @@ your calls and messages.")
(define-public pjproject
(package
(name "pjproject")
(version "2.11.1")
(version "2.12.1")
(source
(origin
(method git-fetch)
@ -733,7 +733,7 @@ your calls and messages.")
(file-name (git-file-name name version))
(sha256
(base32
"04s4bgr2d22ym2ajjk6q507hyqss1p59yp8avyyyf5f8032nbaws"))
"0xrj4sznbaip22y9hclff6y81l285bzkkj1smzifskpk3kiwp00w"))
(modules '((guix build utils)))
(snippet
'(begin
@ -742,23 +742,23 @@ your calls and messages.")
(substitute* "aconfigure.ac"
(("third_party/build/os-auto.mak") ""))
(substitute* "Makefile"
(("third_party/build") ""))))
(patches (search-patches "pjproject-install-libpjsua2.patch"))))
(("third_party/build") ""))))))
(build-system gnu-build-system)
(outputs '("out" "debug" "static"))
(arguments
`(#:test-target "selftest"
(list
#:test-target "selftest"
#:configure-flags
(list "--enable-shared"
#~(list "--enable-shared"
"--with-external-speex"
"--with-external-gsm"
"--with-external-srtp"
"--with-external-pa"
;; The following flag is Linux specific.
,@(if (string-contains (or (%current-system)
#$@(if (string-contains (or (%current-system)
(%current-target-system)) "linux")
'("--enable-epoll")
'())
#~("--enable-epoll")
#~())
"--with-gnutls" ;disable OpenSSL checks
"--disable-libyuv" ;TODO: add missing package
"--disable-silk" ;TODO: add missing package
@ -772,10 +772,9 @@ your calls and messages.")
"CFLAGS=-DNDEBUG"
;; Specify a runpath reference to itself, which is missing and
;; causes the validate-runpath phase to fail.
(string-append "LDFLAGS=-Wl,-rpath=" (assoc-ref %outputs "out")
"/lib"))
(string-append "LDFLAGS=-Wl,-rpath=" #$output "/lib"))
#:phases
(modify-phases %standard-phases
#~(modify-phases %standard-phases
(add-before 'build 'build-dep
(lambda _ (invoke "make" "dep")))
;; The check phases is moved after the install phase so to
@ -783,10 +782,9 @@ your calls and messages.")
(delete 'check)
(add-after 'install 'move-static-libraries
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
(s (string-append (assoc-ref outputs "static") "/lib")))
(let ((s (string-append #$output:static "/lib")))
(mkdir-p s)
(with-directory-excursion out
(with-directory-excursion #$output
(for-each (lambda (f)
(rename-file f (string-append s "/" (basename f))))
(find-files "." "\\.a$"))))))
@ -834,7 +832,10 @@ your calls and messages.")
(("pjnath-test pjmedia-test pjsip-test pjsua-test")
"pjmedia-test pjsip-test")))))))
(native-inputs
(list autoconf automake libtool pkg-config))
(list autoconf
automake
libtool
pkg-config))
(inputs
(list bcg729
gnutls