gnu: python-argcomplete: Update to 1.11.1.
* gnu/packages/python-xyz.scm (python-argcomplete)[version]: Update to 1.11.1. [arguments]: Remove, obsolete. [inputs]: Remove as well. * gnu/packages/patches/python-argcomplete-1.11.1-fish31.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Marius Bakke <mbakke@fastmail.com>master
parent
c265d78640
commit
51443772b8
|
@ -1412,6 +1412,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/python-CVE-2018-14647.patch \
|
||||
%D%/packages/patches/python-aiohttp-3.6.2-no-warning-fail.patch \
|
||||
%D%/packages/patches/python-alembic-exceptions-cause.patch \
|
||||
%D%/packages/patches/python-argcomplete-1.11.1-fish31.patch \
|
||||
%D%/packages/patches/python-axolotl-AES-fix.patch \
|
||||
%D%/packages/patches/python-cairocffi-dlopen-path.patch \
|
||||
%D%/packages/patches/python-cross-compile.patch \
|
||||
|
|
|
@ -0,0 +1,29 @@
|
|||
Upstream commit fixing testcases for fish>=3.1, see
|
||||
https://github.com/kislyuk/argcomplete/commit/08bfc8a788e8081515d733e67be026d051c726f7
|
||||
|
||||
diff --git a/test/test.py b/test/test.py
|
||||
index e91352b..2c34806 100755
|
||||
--- a/test/test.py
|
||||
+++ b/test/test.py
|
||||
@@ -28,6 +28,8 @@
|
||||
|
||||
BASH_VERSION = subprocess.check_output(['bash', '-c', 'echo $BASH_VERSION']).decode()
|
||||
BASH_MAJOR_VERSION = int(BASH_VERSION.split('.')[0])
|
||||
+FISH_VERSION_STR = subprocess.check_output(['fish', '-c', 'echo -n $FISH_VERSION']).decode()
|
||||
+FISH_VERSION_TUPLE = tuple(int(x) for x in FISH_VERSION_STR.split('.'))
|
||||
|
||||
|
||||
class TempDir(object):
|
||||
@@ -1258,8 +1260,11 @@ class TestFish(_TestSh, unittest.TestCase):
|
||||
expected_failures = [
|
||||
'test_parse_special_characters',
|
||||
'test_comp_point',
|
||||
- 'test_special_characters_double_quoted'
|
||||
]
|
||||
+ if FISH_VERSION_TUPLE < (3, 1):
|
||||
+ expected_failures.extend([
|
||||
+ 'test_special_characters_double_quoted'
|
||||
+ ])
|
||||
|
||||
skipped = [
|
||||
'test_single_quotes_in_single_quotes',
|
|
@ -13070,33 +13070,16 @@ PNG, JPEG, JPEG2000 and GIF files in pure Python.")
|
|||
(define-public python-argcomplete
|
||||
(package
|
||||
(name "python-argcomplete")
|
||||
(version "1.10.3")
|
||||
(version "1.11.1")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (pypi-uri "argcomplete" version))
|
||||
(sha256
|
||||
(base32
|
||||
"02jkc44drb0yjz6x28lvg6rj607n8r2irdpdvyylm8xnycn54zx3"))))
|
||||
"0h1przxffrhqvi46k40pzjsvdrq4zc3sl1pc96kkigqppq0vdrss"))
|
||||
(patches (search-patches "python-argcomplete-1.11.1-fish31.patch"))))
|
||||
(build-system python-build-system)
|
||||
(arguments
|
||||
`(#:phases
|
||||
(modify-phases %standard-phases
|
||||
(add-after 'unpack 'embed-tool-references
|
||||
(lambda _
|
||||
(substitute* "argcomplete/bash_completion.d/python-argcomplete.sh"
|
||||
((" grep")
|
||||
(string-append " " (which "grep")))
|
||||
((" egrep")
|
||||
(string-append " " (which "egrep")))
|
||||
(("elif which")
|
||||
(string-append "elif " (which "which")))
|
||||
(("\\$\\(which")
|
||||
(string-append "$(" (which "which"))))
|
||||
#t)))))
|
||||
(inputs
|
||||
`(("grep" ,grep)
|
||||
("which" ,which)))
|
||||
(native-inputs
|
||||
`(("python-coverage" ,python-coverage)
|
||||
("python-flake8" ,python-flake8)
|
||||
|
|
Reference in New Issue