me
/
guix
Archived
1
0
Fork 0

gnu: python-apsw: Update to 3.39.2.1.

* gnu/packages/databases.scm (python-apsw): Update to 3.39.2.1.
[source]: Change back to compressed release.
* gnu/packages/patches/python-apsw-3.39.2.1-test-fix.patch: New file.
* gnu/local.mk: Add patch.

Signed-off-by: Marius Bakke <marius@gnu.org>
master
Hilton Chain 2022-09-06 20:30:45 +08:00 committed by Marius Bakke
parent b7629ff995
commit 53c127c16d
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
3 changed files with 39 additions and 7 deletions

View File

@ -1694,6 +1694,7 @@ dist_patch_DATA = \
%D%/packages/patches/python-3-fix-tests.patch \
%D%/packages/patches/python-3-hurd-configure.patch \
%D%/packages/patches/python-3-no-static-lib.patch \
%D%/packages/patches/python-apsw-3.39.2.1-test-fix.patch \
%D%/packages/patches/python-aionotify-0.2.0-py3.8.patch \
%D%/packages/patches/python-argcomplete-1.11.1-fish31.patch \
%D%/packages/patches/python-cross-compile.patch \

View File

@ -3568,18 +3568,22 @@ PickleShare.")
(define-public python-apsw
(package
(name "python-apsw")
(version "3.39.2.0")
(version "3.39.2.1")
;; The compressed release has fetching functionality disabled.
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/rogerbinns/apsw")
(commit version)))
(file-name (git-file-name name version))
(method url-fetch)
(uri (string-append
"https://github.com/rogerbinns/apsw/releases/download/"
version "/apsw-" version ".zip"))
(sha256
(base32
"0q7fnk8n3m5mpjzh6xyhj409k8sacdbjsfis98my9c50fdn5sr7y"))))
"06x3qgg71xz8l3kz8gz04wkfp5f6zfrg476a4mm1c5hikqyw6ykj"))
;; Cherry-picked from upstream, remove when bumping to 3.39.3.
(patches
(search-patches "python-apsw-3.39.2.1-test-fix.patch"))))
(build-system python-build-system)
(native-inputs (list unzip))
(inputs (list sqlite-next)) ;SQLite 3.39 required.
(arguments
(list #:phases

View File

@ -0,0 +1,27 @@
From 1111f902075169bd0d96cdd10607ef8499f0fed5 Mon Sep 17 00:00:00 2001
From: Roger Binns <rogerb@rogerbinns.com>
Date: Mon, 5 Sep 2022 07:12:25 -0700
Subject: [PATCH] Deal with mismatched SQLITE_ENABLE_COLUMN_METADATA
Address #363
---
apsw/tests.py | 2 +-
1 files changed, 1 insertions(+), 1 deletion(-)
diff --git a/apsw/tests.py b/apsw/tests.py
index b4a94d3..256ead0 100644
--- a/apsw/tests.py
+++ b/apsw/tests.py
@@ -772,8 +772,8 @@ class APSW(unittest.TestCase):
c.execute("drop table foo; create table foo (%s)" % (", ".join(["[%s] %s" % (n, t) for n, t in cols]), ))
c.execute("insert into foo([x a space]) values(1)")
c.execute("create temp table two(fred banana); insert into two values(7); create temp view three as select fred as [a space] from two")
- has_full=any(o=="ENABLE_COLUMN_METADATA" or o.startswith("ENABLE_COLUMN_METADATA=") for o in apsw.compile_options)
+ has_full=any(o=="ENABLE_COLUMN_METADATA" or o.startswith("ENABLE_COLUMN_METADATA=") for o in apsw.compile_options) if apsw.using_amalgamation else hasattr(c, "description_full")
for row in c.execute("select * from foo"):
self.assertEqual(cols, c.getdescription())
self.assertEqual(has_full, hasattr(c, "description_full"))
base-commit: f628374c5857d940067ef26c9ea4e85a08a94f76
--
2.37.2