From 55a604db4ee55ae25166df6f83e222c3caf33273 Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Thu, 4 Apr 2019 19:49:38 +0200
Subject: [PATCH] gnu: asymptote: Fix info file location.

* gnu/packages/plotutils.scm (asymptote): Fix info file location so it appears
  in the top-level directory.
---
 gnu/packages/plotutils.scm | 8 ++++++++
 1 file changed, 8 insertions(+)

diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index 63b36830c8..c2311958f3 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -230,6 +230,14 @@ colors, styles, options and details.")
              (substitute* (find-files "." "\\.in$")
                (("#include <primitives.h>") "#include \"primitives.h\""))
              (invoke "touch" "prc/config.h")))
+         (add-after 'unpack 'move-info-location
+           ;; Build process install info file in the unusual
+           ;; "%out/share/info/asymptote/" location.  Move it to
+           ;; "%out/share/info/" so it appears in the top-level directory.
+           (lambda _
+             (substitute* "doc/png/Makefile.in"
+               (("(\\$\\(infodir\\))/asymptote" _ infodir) infodir))
+             #t))
          (add-before 'build 'patch-pdf-viewer
            (lambda _
              ;; Default to a free pdf viewer.