me
/
guix
Archived
1
0
Fork 0

gnu: grantlee: Fix build on i686-linux.

This fixes a test (formatfiltertest07) failure on i686-linux.
See also <https://github.com/steveire/grantlee/issues/85>.

* gnu/packages/patches/grantlee-fix-i586-precision.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/qt.scm (grantlee)[source]: Add patch.
master
宋文武 2023-08-08 21:54:54 +08:00
parent 1a02365c4a
commit 55f3b17915
No known key found for this signature in database
GPG Key ID: D415BF253B515976
3 changed files with 43 additions and 1 deletions

View File

@ -1316,6 +1316,7 @@ dist_patch_DATA = \
%D%/packages/patches/gpm-glibc-2.26.patch \ %D%/packages/patches/gpm-glibc-2.26.patch \
%D%/packages/patches/gpodder-disable-updater.patch \ %D%/packages/patches/gpodder-disable-updater.patch \
%D%/packages/patches/gpsbabel-fix-i686-test.patch \ %D%/packages/patches/gpsbabel-fix-i686-test.patch \
%D%/packages/patches/grantlee-fix-i586-precision.patch \
%D%/packages/patches/grep-timing-sensitive-test.patch \ %D%/packages/patches/grep-timing-sensitive-test.patch \
%D%/packages/patches/grfcodec-gcc-compat.patch \ %D%/packages/patches/grfcodec-gcc-compat.patch \
%D%/packages/patches/gromacs-tinyxml2.patch \ %D%/packages/patches/gromacs-tinyxml2.patch \

View File

@ -0,0 +1,40 @@
From 13094b78a790786030a468453c2b3ead4c7fd9cf Mon Sep 17 00:00:00 2001
From: Fabian Vogt <fabian@ritter-vogt.de>
Date: Sun, 13 Nov 2022 14:01:21 +0100
Subject: [PATCH] Fix formatting of some larger file sizes on 32bit x86
With the x87 FPU available, GCC uses long double precision for some variables.
Due to the function call passing a double, some comparisons break down.
That resulted in "1.00 YB" being printed as "1000.00 ZB" instead.
Fixes #85
---
templates/lib/util.cpp | 7 +++++++
1 file changed, 7 insertions(+)
diff --git a/templates/lib/util.cpp b/templates/lib/util.cpp
index 504674a7..a0381c59 100644
--- a/templates/lib/util.cpp
+++ b/templates/lib/util.cpp
@@ -23,6 +23,7 @@
#include "metaenumvariable_p.h"
#include "metatype.h"
+#include <cfloat>
#include <QtCore/QStringList>
QString Grantlee::unescapeStringLiteral(const QString &input)
@@ -212,7 +213,13 @@ std::pair<qreal, QString> Grantlee::calcFileSize(qreal size, int unitSystem,
bool found = false;
int count = 0;
const qreal baseVal = (_unitSystem == 10) ? 1000.0F : 1024.0F;
+#if FLT_EVAL_METHOD == 2
+ // Avoid that this is treated as long double, as the increased
+ // precision breaks the comparison below.
+ volatile qreal current = 1.0F;
+#else
qreal current = 1.0F;
+#endif
int units = decimalUnits.size();
while (!found && (count < units)) {
current *= baseVal;

View File

@ -320,7 +320,8 @@ applications on Wayland.")
(commit (string-append "v" version)))) (commit (string-append "v" version))))
(file-name (git-file-name name version)) (file-name (git-file-name name version))
(sha256 (sha256
(base32 "1ipnkdi8wgv519mvwa5zxlz20wipbypyfixjv2qdfd9vl1pznwvs")))) (base32 "1ipnkdi8wgv519mvwa5zxlz20wipbypyfixjv2qdfd9vl1pznwvs"))
(patches (search-patches "grantlee-fix-i586-precision.patch"))))
(native-inputs (native-inputs
;; Optional: lcov and cccc, both are for code coverage ;; Optional: lcov and cccc, both are for code coverage
(list doxygen)) (list doxygen))