me
/
guix
Archived
1
0
Fork 0

gnu: Remove unreferenced patch.

This is a follow-up to a08c21f206.

* gnu/packages/patches/libmicrohttpd-0.9.73-test-ssl3.patch: Remove file.
* gnu/local.mk (dist_patch_DATA): Remove it.
Efraim Flashner 2022-06-01 22:55:27 +03:00
parent 8d653c08b7
commit 572bc6d7bd
No known key found for this signature in database
GPG Key ID: 41AAE7DCCA3D8351
2 changed files with 0 additions and 36 deletions

View File

@ -1403,7 +1403,6 @@ dist_patch_DATA = \
%D%/packages/patches/libmad-length-check.patch \
%D%/packages/patches/libmad-md_size.patch \
%D%/packages/patches/libmad-mips-newgcc.patch \
%D%/packages/patches/libmicrohttpd-0.9.73-test-ssl3.patch \
%D%/packages/patches/libmp4v2-c++11.patch \
%D%/packages/patches/libmpeg2-arm-private-symbols.patch \
%D%/packages/patches/libmpeg2-global-symbol-test.patch \

View File

@ -1,35 +0,0 @@
Disable usage of SSLv3 in testing
Integrated uptream version 0.9.74
diff --git a/src/testcurl/https/test_tls_options.c b/src/testcurl/https/test_tls_options.c
--- a/src/testcurl/https/test_tls_options.c
+++ b/src/testcurl/https/test_tls_options.c
@@ -119,11 +119,6 @@ main (int argc, char *const *argv)
fprintf (stderr, "Curl does not support SSL. Cannot run the test.\n");
return 77;
}
- if (0 != strncmp (ssl_version, "GnuTLS", 6))
- {
- fprintf (stderr, "This test can be run only with libcurl-gnutls.\n");
- return 77;
- }
if (! testsuite_curl_global_init ())
return 99;
@@ -152,10 +147,10 @@ main (int argc, char *const *argv)
fprintf (stderr,
"The following handshake should fail (and print an error message)...\n");
if (0 !=
- test_wrap ("TLS1.0 vs SSL3",
+ test_wrap ("TLS1.1 vs TLS1.0",
&test_unmatching_ssl_version, NULL, port, daemon_flags,
aes256_sha,
- CURL_SSLVERSION_SSLv3,
+ CURL_SSLVERSION_TLSv1_1,
MHD_OPTION_HTTPS_MEM_KEY, srv_key_pem,
MHD_OPTION_HTTPS_MEM_CERT, srv_self_signed_cert_pem,
MHD_OPTION_HTTPS_PRIORITIES,