gnu: mame: Fix build.
* gnu/packages/emulators.scm (mame): Apply upstream patch. * gnu/packages/patches/mame-rapidjson-fix.patch: New file. * gnu/local.mk: Register file.master
parent
c9093d2794
commit
57939283c0
|
@ -1078,6 +1078,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/lxsession-use-gapplication.patch \
|
%D%/packages/patches/lxsession-use-gapplication.patch \
|
||||||
%D%/packages/patches/make-glibc-compat.patch \
|
%D%/packages/patches/make-glibc-compat.patch \
|
||||||
%D%/packages/patches/make-impure-dirs.patch \
|
%D%/packages/patches/make-impure-dirs.patch \
|
||||||
|
%D%/packages/patches/mame-rapidjson-fix.patch \
|
||||||
%D%/packages/patches/mariadb-client-test-32bit.patch \
|
%D%/packages/patches/mariadb-client-test-32bit.patch \
|
||||||
%D%/packages/patches/mars-install.patch \
|
%D%/packages/patches/mars-install.patch \
|
||||||
%D%/packages/patches/mars-sfml-2.3.patch \
|
%D%/packages/patches/mars-sfml-2.3.patch \
|
||||||
|
|
|
@ -1196,6 +1196,10 @@ play them on systems for which they were never designed!")
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0p3zcb9l624dsy2gyv23ppp1k1iwd1vrg8cbn5v4fx1s44mx7f5c"))
|
"0p3zcb9l624dsy2gyv23ppp1k1iwd1vrg8cbn5v4fx1s44mx7f5c"))
|
||||||
|
(patches
|
||||||
|
;; FIXME: Remove once 0.213 is out. Applied upstream as
|
||||||
|
;; 0b5b13cf1e28550b49c387dec93f9801f029e313.
|
||||||
|
(search-patches "mame-rapidjson-fix.patch"))
|
||||||
(modules '((guix build utils)))
|
(modules '((guix build utils)))
|
||||||
(snippet
|
(snippet
|
||||||
;; Remove bundled libraries.
|
;; Remove bundled libraries.
|
||||||
|
|
|
@ -0,0 +1,37 @@
|
||||||
|
From 0b5b13cf1e28550b49c387dec93f9801f029e313 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Julian Sikorski <belegdol+github@gmail.com>
|
||||||
|
Date: Mon, 5 Aug 2019 21:16:54 +0200
|
||||||
|
Subject: [PATCH] Fix building using system rapidjson
|
||||||
|
|
||||||
|
---
|
||||||
|
scripts/target/mame/arcade.lua | 1 +
|
||||||
|
src/mame/video/midtunit.cpp | 4 ++--
|
||||||
|
2 files changed, 3 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/scripts/target/mame/arcade.lua b/scripts/target/mame/arcade.lua
|
||||||
|
index 964daa3572f..ef30ae3c2c2 100644
|
||||||
|
--- a/scripts/target/mame/arcade.lua
|
||||||
|
+++ b/scripts/target/mame/arcade.lua
|
||||||
|
@@ -930,6 +930,7 @@ function createMAMEProjects(_target, _subtarget, _name)
|
||||||
|
ext_includedir("flac"),
|
||||||
|
ext_includedir("glm"),
|
||||||
|
ext_includedir("jpeg"),
|
||||||
|
+ ext_includedir("rapidjson"),
|
||||||
|
}
|
||||||
|
|
||||||
|
end
|
||||||
|
diff --git a/src/mame/video/midtunit.cpp b/src/mame/video/midtunit.cpp
|
||||||
|
index b4cb98abacf..b307f3f722b 100644
|
||||||
|
--- a/src/mame/video/midtunit.cpp
|
||||||
|
+++ b/src/mame/video/midtunit.cpp
|
||||||
|
@@ -20,8 +20,8 @@
|
||||||
|
#include "emuopts.h" // Used by PNG logging
|
||||||
|
#include "png.h" // Used by PNG logging
|
||||||
|
|
||||||
|
-#include "rapidjson/include/rapidjson/prettywriter.h" // Used by JSON logging
|
||||||
|
-#include "rapidjson/include/rapidjson/stringbuffer.h" // Used by JSON logging
|
||||||
|
+#include <rapidjson/prettywriter.h> // Used by JSON logging
|
||||||
|
+#include <rapidjson/stringbuffer.h> // Used by JSON logging
|
||||||
|
|
||||||
|
DEFINE_DEVICE_TYPE(MIDTUNIT_VIDEO, midtunit_video_device, "tunitvid", "Midway T-Unit Video")
|
||||||
|
DEFINE_DEVICE_TYPE(MIDWUNIT_VIDEO, midwunit_video_device, "wunitvid", "Midway W-Unit Video")
|
Reference in New Issue