gnu: Add konversation.
* gnu/packages/kde-internet.scm (konversation): New variable. * gnu/packages/patches/konversation-Fix-build-with-Qt-5.11.patch: New file. * gnu/lokal.mk: Add it.master
parent
e21713270c
commit
579aa350ed
|
@ -1071,6 +1071,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/kodi-increase-test-timeout.patch \
|
%D%/packages/patches/kodi-increase-test-timeout.patch \
|
||||||
%D%/packages/patches/kodi-set-libcurl-ssl-parameters.patch \
|
%D%/packages/patches/kodi-set-libcurl-ssl-parameters.patch \
|
||||||
%D%/packages/patches/kodi-skip-test-449.patch \
|
%D%/packages/patches/kodi-skip-test-449.patch \
|
||||||
|
%D%/packages/patches/konversation-Fix-build-with-Qt-5.11.patch \
|
||||||
%D%/packages/patches/laby-make-install.patch \
|
%D%/packages/patches/laby-make-install.patch \
|
||||||
%D%/packages/patches/lcalc-default-parameters-1.patch \
|
%D%/packages/patches/lcalc-default-parameters-1.patch \
|
||||||
%D%/packages/patches/lcalc-default-parameters-2.patch \
|
%D%/packages/patches/lcalc-default-parameters-2.patch \
|
||||||
|
|
|
@ -155,3 +155,75 @@ HTTP(S) as well as pausing downloads.
|
||||||
This package is part of the KDE networking module.")
|
This package is part of the KDE networking module.")
|
||||||
(license ;; GPL for programs, LGPL for libraries, FDL for documentation
|
(license ;; GPL for programs, LGPL for libraries, FDL for documentation
|
||||||
(list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
|
(list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
|
||||||
|
|
||||||
|
(define-public konversation
|
||||||
|
(package
|
||||||
|
(name "konversation")
|
||||||
|
(version "1.7.5")
|
||||||
|
(source
|
||||||
|
(origin
|
||||||
|
(method url-fetch)
|
||||||
|
(uri (string-append "mirror://kde/stable/konversation/" version
|
||||||
|
"/src/konversation-" version ".tar.xz"))
|
||||||
|
(sha256
|
||||||
|
(base32 "0h098yhlp36ls6pdvs2r93ig8dv4fys62m0h6wxccprb0qrpbgv0"))
|
||||||
|
(patches (search-patches "konversation-Fix-build-with-Qt-5.11.patch"))))
|
||||||
|
(build-system qt-build-system)
|
||||||
|
(native-inputs
|
||||||
|
`(("extra-cmake-modules" ,extra-cmake-modules)
|
||||||
|
("kdoctools" ,kdoctools)))
|
||||||
|
(inputs
|
||||||
|
`(("karchive" ,karchive)
|
||||||
|
("kbookmarks" ,kbookmarks)
|
||||||
|
("kconfig" ,kconfig)
|
||||||
|
("kconfigwidgets" ,kconfigwidgets)
|
||||||
|
("kcoreaddons" ,kcoreaddons)
|
||||||
|
("kcrash" ,kcrash)
|
||||||
|
("kdbusaddons" ,kdbusaddons)
|
||||||
|
("kemoticons" ,kemoticons)
|
||||||
|
("kglobalaccel" ,kglobalaccel)
|
||||||
|
("ki18n" ,ki18n)
|
||||||
|
("kiconthemes" ,kiconthemes)
|
||||||
|
("kidletime" ,kidletime)
|
||||||
|
("kio" ,kio)
|
||||||
|
("kitemviews" ,kitemviews)
|
||||||
|
("knotifications" ,knotifications)
|
||||||
|
("knotifyconfig" ,knotifyconfig)
|
||||||
|
("kparts" ,kparts)
|
||||||
|
("kwallet" ,kwallet)
|
||||||
|
("kwidgetsaddons" ,kwidgetsaddons)
|
||||||
|
("kwindowsystem" ,kwindowsystem)
|
||||||
|
("oxygen-icons" ,oxygen-icons) ; default icon set
|
||||||
|
("phonon" ,phonon)
|
||||||
|
("qtbase" ,qtbase)
|
||||||
|
("qca" ,qca)
|
||||||
|
("solid" ,solid)
|
||||||
|
("sonnet" ,sonnet)))
|
||||||
|
(home-page "https://kde.org/applications/internet/org.kde.konversations")
|
||||||
|
(synopsis "Graphical Internet Relay Chat (IRC) client for KDE")
|
||||||
|
(description "Konversation is a graphical Internet Relay Chat client (IRC)
|
||||||
|
with KDE support.
|
||||||
|
|
||||||
|
Features are:
|
||||||
|
@itemize
|
||||||
|
@item Standard IRC features
|
||||||
|
@item SSL server support
|
||||||
|
@item Bookmarking support
|
||||||
|
@item Easy to use graphical user interface
|
||||||
|
@item Multiple servers and channels in one single window
|
||||||
|
@item DCC file transfer with resume support
|
||||||
|
@item Multiple identities for different servers
|
||||||
|
@item Text decorations and colors
|
||||||
|
@item Pattern-based message highlighting and OnScreen Display notifications
|
||||||
|
@item Automatic UTF-8 detection
|
||||||
|
@item Per channel encoding support
|
||||||
|
@item Theme support for nick icons
|
||||||
|
@item Highly configurable
|
||||||
|
@item Multi-language scripting support (with DCOP)
|
||||||
|
@item Customizable command aliases
|
||||||
|
@item NickServ-aware log-on (for registered nicknames)
|
||||||
|
@item Smart logging
|
||||||
|
@item Traditional or enhanced-shell-style nick completion
|
||||||
|
@end itemize")
|
||||||
|
(license ;; GPL for programs, FDL for documentation
|
||||||
|
(list license:gpl2+ license:fdl1.2+))))
|
||||||
|
|
|
@ -0,0 +1,24 @@
|
||||||
|
From 4d0036617becc26a76fd021138c98aceec4c7b53 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Luca Beltrame <lbeltrame@kde.org>
|
||||||
|
Date: Sun, 21 Jul 2019 09:14:32 +0200
|
||||||
|
Subject: Fix build with Qt 5.13
|
||||||
|
|
||||||
|
---
|
||||||
|
src/irc/outputfilter.cpp | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/src/irc/outputfilter.cpp b/src/irc/outputfilter.cpp
|
||||||
|
index f9e6253..45d11fb 100644
|
||||||
|
--- a/src/irc/outputfilter.cpp
|
||||||
|
+++ b/src/irc/outputfilter.cpp
|
||||||
|
@@ -32,6 +32,7 @@
|
||||||
|
|
||||||
|
#include <QStringList>
|
||||||
|
#include <QFile>
|
||||||
|
+#include <QMetaMethod>
|
||||||
|
#include <QRegExp>
|
||||||
|
#include <QTextCodec>
|
||||||
|
#include <QByteArray>
|
||||||
|
--
|
||||||
|
cgit v1.1
|
||||||
|
|
Reference in New Issue