me
/
guix
Archived
1
0
Fork 0

gnu: dune-common: Skip tests that fail on aarch64-linux.

* gnu/packages/patches/dune-common-skip-failing-tests.patch: New file.
* gnu/packages/maths.scm (dune-common)[source]: Add it
* gnu/local.mk (dist_patch_DATA): Register it.

Co-authored-by: Ludovic Courtès <ludo@gnu.org>
master
Felix Gruber 2023-05-02 21:59:30 +02:00 committed by Ludovic Courtès
parent fc6c96c88a
commit 59640af1c5
No known key found for this signature in database
GPG Key ID: 090B11993D9AEBB5
3 changed files with 31 additions and 1 deletions

View File

@ -1056,6 +1056,7 @@ dist_patch_DATA = \
%D%/packages/patches/dovecot-trees-support-dovecot-2.3.patch \
%D%/packages/patches/dstat-fix-crash-when-specifying-delay.patch \
%D%/packages/patches/dstat-skip-devices-without-io.patch \
%D%/packages/patches/dune-common-skip-failing-tests.patch \
%D%/packages/patches/dune-grid-add-missing-include-cassert.patch \
%D%/packages/patches/dune-istl-fix-solver-playground.patch \
%D%/packages/patches/dvd+rw-tools-add-include.patch \

View File

@ -6805,7 +6805,8 @@ linear algebra primitives specifically targeting graph analytics.")
version "/dune-common-" version ".tar.gz"))
(sha256
(base32
"04pzk8q0bibci8z5xlwndhh3y3vs63mw7kad62lbzfwrr5121hrd"))))
"04pzk8q0bibci8z5xlwndhh3y3vs63mw7kad62lbzfwrr5121hrd"))
(patches (search-patches "dune-common-skip-failing-tests.patch"))))
(build-system cmake-build-system)
(arguments
`(#:phases

View File

@ -0,0 +1,28 @@
Disable tests known to fail on AArch64:
https://gitlab.dune-project.org/core/dune-common/-/issues/262
https://issues.guix.gnu.org/62842
--- a/dune/common/test/eigenvaluestest.cc
+++ b/dune/common/test/eigenvaluestest.cc
@@ -340,20 +340,15 @@
testSymmetricFieldMatrix<double,200>();
testSymmetricFieldMatrix<float,4>();
testSymmetricFieldMatrix<float,200>();
- testSymmetricFieldMatrix<long double,4>();
- testSymmetricFieldMatrix<long double,200>();
#endif // HAVE_LAPACK
testSymmetricFieldMatrix<double,2>();
testSymmetricFieldMatrix<double,3>();
testSymmetricFieldMatrix<float,2>();
testSymmetricFieldMatrix<float,3>();
- testSymmetricFieldMatrix<long double,2>();
- testSymmetricFieldMatrix<long double,3>();
checkMultiplicity<double>();
checkMultiplicity<float>();
- checkMultiplicity<long double>();
return 0;
}