gnu: Remove unused patch.
This a followup to 9b714ec75e
.
* gnu/packages/patches/sbcl-fix-build-on-arm64-with-clisp-as-host.patch:
Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
master
parent
f0ee77a17e
commit
5a6d0b5193
|
@ -1839,7 +1839,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/sbcl-aserve-fix-rfe12668.patch \
|
%D%/packages/patches/sbcl-aserve-fix-rfe12668.patch \
|
||||||
%D%/packages/patches/sbcl-burgled-batteries3-fix-signals.patch \
|
%D%/packages/patches/sbcl-burgled-batteries3-fix-signals.patch \
|
||||||
%D%/packages/patches/sbcl-clml-fix-types.patch \
|
%D%/packages/patches/sbcl-clml-fix-types.patch \
|
||||||
%D%/packages/patches/sbcl-fix-build-on-arm64-with-clisp-as-host.patch \
|
|
||||||
%D%/packages/patches/sbcl-png-fix-sbcl-compatibility.patch \
|
%D%/packages/patches/sbcl-png-fix-sbcl-compatibility.patch \
|
||||||
%D%/packages/patches/scalapack-gcc-10-compilation.patch \
|
%D%/packages/patches/scalapack-gcc-10-compilation.patch \
|
||||||
%D%/packages/patches/scheme48-tests.patch \
|
%D%/packages/patches/scheme48-tests.patch \
|
||||||
|
|
|
@ -1,27 +0,0 @@
|
||||||
From 944f53fb00794f4bc96700dd14df1e88b6cd5623 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Christophe Rhodes <csr21@cantab.net>
|
|
||||||
Date: Thu, 17 Nov 2022 22:29:26 +0000
|
|
||||||
Subject: [PATCH] Fix build on arm64 with clisp as host
|
|
||||||
|
|
||||||
Make sure the offset constants are defined while compiling vm.lisp.
|
|
||||||
---
|
|
||||||
src/compiler/arm64/vm.lisp | 3 ++-
|
|
||||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/compiler/arm64/vm.lisp b/src/compiler/arm64/vm.lisp
|
|
||||||
index ae6d7c7fa..2a151be58 100644
|
|
||||||
--- a/src/compiler/arm64/vm.lisp
|
|
||||||
+++ b/src/compiler/arm64/vm.lisp
|
|
||||||
@@ -23,7 +23,8 @@
|
|
||||||
(macrolet ((defreg (name offset)
|
|
||||||
(let ((offset-sym (symbolicate name "-OFFSET")))
|
|
||||||
`(progn
|
|
||||||
- (defconstant ,offset-sym ,offset)
|
|
||||||
+ (eval-when (:compile-toplevel :load-toplevel :execute)
|
|
||||||
+ (defconstant ,offset-sym ,offset))
|
|
||||||
(setf (svref *register-names* ,offset-sym) ,(symbol-name name)))))
|
|
||||||
|
|
||||||
(defregset (name &rest regs)
|
|
||||||
--
|
|
||||||
2.30.2
|
|
||||||
|
|
Reference in New Issue