gnu: emacs-haskell-mode: Update to 17.4.
* gnu/packages/patches/emacs-haskell-mode-no-redefine-builtin.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it here. * gnu/packages/emacs-xyz.scm (emacs-haskell-mode): Update to 17.4. [source]<patches>: Use it here.master
parent
ef077b83f9
commit
5a989fc417
|
@ -1096,6 +1096,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/emacs-git-email-missing-parens.patch \
|
||||
%D%/packages/patches/emacs-fix-scheme-indent-function.patch \
|
||||
%D%/packages/patches/emacs-json-reformat-fix-tests.patch \
|
||||
%D%/packages/patches/emacs-haskell-mode-no-redefine-builtin.patch \
|
||||
%D%/packages/patches/emacs-highlight-stages-add-gexp.patch \
|
||||
%D%/packages/patches/emacs-lispy-fix-thread-last-test.patch \
|
||||
%D%/packages/patches/emacs-native-comp-driver-options.patch \
|
||||
|
|
|
@ -2249,20 +2249,20 @@ replacement.")
|
|||
(license license:gpl3+))))
|
||||
|
||||
(define-public emacs-haskell-mode
|
||||
(let ((revision "0")
|
||||
(commit "5a9f8072c7b9168f0a8409adf9d62a3e4ad4ea3d"))
|
||||
(package
|
||||
(name "emacs-haskell-mode")
|
||||
(version (git-version "17.2" revision commit))
|
||||
(version "17.4")
|
||||
(source
|
||||
(origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
(url "https://github.com/haskell/haskell-mode")
|
||||
(commit commit)))
|
||||
(commit (string-append "v" version))))
|
||||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32 "0np1wrwdq7b9hpqpl9liampacnkx6diphyk8h2sbz2mfn9qr7pxs"))))
|
||||
(base32 "03j94fgw1bljbjqmikbn9mnrfifxf7g9zrb727zmnnrjwyi0wd4n"))
|
||||
(patches
|
||||
(search-patches "emacs-haskell-mode-no-redefine-builtin.patch"))))
|
||||
(propagated-inputs
|
||||
(list emacs-dash))
|
||||
(native-inputs
|
||||
|
@ -2341,7 +2341,7 @@ replacement.")
|
|||
(description
|
||||
"This is an Emacs mode for editing, debugging and developing Haskell
|
||||
programs.")
|
||||
(license license:gpl3+))))
|
||||
(license license:gpl3+)))
|
||||
|
||||
(define-public emacs-dante
|
||||
(package
|
||||
|
|
|
@ -0,0 +1,75 @@
|
|||
From faa95a784d2c74c72e70367a5d531df6dd61aeab Mon Sep 17 00:00:00 2001
|
||||
From: Steve Purcell <steve@sanityinc.com>
|
||||
Date: Sun, 6 Aug 2023 16:41:48 +0200
|
||||
Subject: [PATCH] Don't redefine built-in function
|
||||
|
||||
Fixes #1817
|
||||
---
|
||||
tests/haskell-indent-tests.el | 14 ++++++++------
|
||||
tests/haskell-indentation-tests.el | 14 ++++++++------
|
||||
2 files changed, 16 insertions(+), 12 deletions(-)
|
||||
|
||||
diff --git a/tests/haskell-indent-tests.el b/tests/haskell-indent-tests.el
|
||||
index 7196405b8..9a3de4ad3 100644
|
||||
--- a/tests/haskell-indent-tests.el
|
||||
+++ b/tests/haskell-indent-tests.el
|
||||
@@ -40,11 +40,13 @@
|
||||
;; (haskell-indent-put-region-in-literate (point-min) (point-max) -1)
|
||||
;; (buffer-substring-no-properties (point-min) (point-max))))))
|
||||
|
||||
-(defsubst string-trim-left (string)
|
||||
- "Remove leading whitespace from STRING."
|
||||
- (if (string-match "\\`[ \t\n\r]+" string)
|
||||
- (replace-match "" t t string)
|
||||
- string))
|
||||
+(if (fboundp 'string-trim-left)
|
||||
+ (defalias 'haskell--string-trim-left 'string-trim-left)
|
||||
+ (defun haskell--string-trim-left (string &optional regexp)
|
||||
+ "Remove leading whitespace from STRING."
|
||||
+ (if (string-match (concat "\\`\\(?:" (or regexp "[ \t\n\r]+") "\\)") string)
|
||||
+ (substring string (match-end 0))
|
||||
+ string)))
|
||||
|
||||
(defun haskell-indent-format-info (info)
|
||||
(if (cdr info)
|
||||
@@ -128,7 +130,7 @@ macro quotes them for you."
|
||||
:expected-result
|
||||
,(if allow-failure :failed :passed)
|
||||
(haskell-indent-check
|
||||
- ,(string-trim-left source)
|
||||
+ ,(haskell--string-trim-left source)
|
||||
,@(mapcar (lambda (x)
|
||||
(list 'quote x))
|
||||
test-cases))))))
|
||||
diff --git a/tests/haskell-indentation-tests.el b/tests/haskell-indentation-tests.el
|
||||
index 4889b76a7..cd783a4f4 100644
|
||||
--- a/tests/haskell-indentation-tests.el
|
||||
+++ b/tests/haskell-indentation-tests.el
|
||||
@@ -33,11 +33,13 @@
|
||||
|
||||
;;; Code:
|
||||
|
||||
-(defsubst string-trim-left (string)
|
||||
- "Remove leading whitespace from STRING."
|
||||
- (if (string-match "\\`[ \t\n\r]+" string)
|
||||
- (replace-match "" t t string)
|
||||
- string))
|
||||
+(if (fboundp 'string-trim-left)
|
||||
+ (defalias 'haskell--string-trim-left 'string-trim-left)
|
||||
+ (defun haskell--string-trim-left (string &optional regexp)
|
||||
+ "Remove leading whitespace from STRING."
|
||||
+ (if (string-match (concat "\\`\\(?:" (or regexp "[ \t\n\r]+") "\\)") string)
|
||||
+ (substring string (match-end 0))
|
||||
+ string)))
|
||||
|
||||
(defun haskell-indentation-check (source &rest test-cases)
|
||||
"Check if `haskell-indentation-find-indentations' returns expected results.
|
||||
@@ -115,7 +117,7 @@ macro quotes them for you."
|
||||
:expected-result
|
||||
,(if allow-failure :failed :passed)
|
||||
(haskell-indentation-check
|
||||
- ,(string-trim-left source)
|
||||
+ ,(haskell--string-trim-left source)
|
||||
,@(mapcar (lambda (x)
|
||||
(list 'quote x))
|
||||
test-cases))))))
|
Reference in New Issue