gnu: zlib: Update to 1.2.12.
* gnu/packages/compression.scm (zlib): Update to 1.2.12. [source](patches): New field. [arguments]: Set CC variable. * gnu/packages/commencement.scm (zlib-final)[source]: New field. * gnu/packages/patches/zlib-cc.patch, gnu/packages/patches/zlib-correct-crc32-inputs.patch: New files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.master
parent
9959890264
commit
5aeb96103f
|
@ -1962,6 +1962,8 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/xterm-370-explicit-xcursor.patch \
|
||||
%D%/packages/patches/xygrib-fix-finding-data.patch \
|
||||
%D%/packages/patches/yggdrasil-extra-config.patch \
|
||||
%D%/packages/patches/zlib-cc.patch \
|
||||
%D%/packages/patches/zlib-correct-crc32-inputs.patch \
|
||||
%D%/packages/patches/zig-use-system-paths.patch
|
||||
|
||||
MISC_DISTRO_FILES = \
|
||||
|
|
|
@ -3013,6 +3013,7 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
|
|||
;; Zlib used by GCC-FINAL.
|
||||
(package
|
||||
(inherit zlib)
|
||||
(source (bootstrap-origin (package-source zlib)))
|
||||
(arguments
|
||||
`(#:guile ,%bootstrap-guile
|
||||
#:implicit-inputs? #f
|
||||
|
|
|
@ -100,7 +100,7 @@
|
|||
(define-public zlib
|
||||
(package
|
||||
(name "zlib")
|
||||
(version "1.2.11")
|
||||
(version "1.2.12")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
|
@ -108,9 +108,11 @@
|
|||
version ".tar.gz")
|
||||
(string-append "mirror://sourceforge/libpng/zlib/"
|
||||
version "/zlib-" version ".tar.gz")))
|
||||
(patches (search-patches "zlib-cc.patch"
|
||||
"zlib-correct-crc32-inputs.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"18dighcs333gsvajvvgqp8l4cx7h1x7yx9gd5xacnk80spyykrf3"))))
|
||||
"1n9na4fq4wagw1nzsfjr6wyly960jfa94460ncbf6p1fac44i14i"))))
|
||||
(build-system gnu-build-system)
|
||||
(outputs '("out" "static"))
|
||||
(arguments
|
||||
|
@ -122,6 +124,7 @@
|
|||
;; extra flags like `--enable-fast-install', so we need to
|
||||
;; invoke it with just what it understand.
|
||||
(let ((out (assoc-ref outputs "out")))
|
||||
(setenv "CC" ,(cc-for-target))
|
||||
;; 'configure' doesn't understand '--host'.
|
||||
,@(if (%current-target-system)
|
||||
`((setenv "CHOST" ,(%current-target-system)))
|
||||
|
|
|
@ -0,0 +1,21 @@
|
|||
Fix configure issue that discarded provided CC definition.
|
||||
|
||||
Taken from upstream:
|
||||
|
||||
https://github.com/madler/zlib/commit/05796d3d8d5546cf1b4dfe2cd72ab746afae505d
|
||||
|
||||
diff --git a/configure b/configure
|
||||
index 52ff4a04e..3fa3e8618 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -174,7 +174,10 @@ if test -z "$CC"; then
|
||||
else
|
||||
cc=${CROSS_PREFIX}cc
|
||||
fi
|
||||
+else
|
||||
+ cc=${CC}
|
||||
fi
|
||||
+
|
||||
cflags=${CFLAGS-"-O3"}
|
||||
# to force the asm version use: CFLAGS="-O3 -DASMV" ./configure
|
||||
case "$cc" in
|
|
@ -0,0 +1,44 @@
|
|||
Correct incorrect inputs provided to the CRC functions.
|
||||
|
||||
Taken from upstream:
|
||||
|
||||
https://github.com/madler/zlib/commit/ec3df00224d4b396e2ac6586ab5d25f673caa4c2
|
||||
|
||||
diff --git a/crc32.c b/crc32.c
|
||||
index a1bdce5c2..451887bc7 100644
|
||||
--- a/crc32.c
|
||||
+++ b/crc32.c
|
||||
@@ -630,7 +630,7 @@ unsigned long ZEXPORT crc32_z(crc, buf, len)
|
||||
#endif /* DYNAMIC_CRC_TABLE */
|
||||
|
||||
/* Pre-condition the CRC */
|
||||
- crc ^= 0xffffffff;
|
||||
+ crc = (~crc) & 0xffffffff;
|
||||
|
||||
/* Compute the CRC up to a word boundary. */
|
||||
while (len && ((z_size_t)buf & 7) != 0) {
|
||||
@@ -749,7 +749,7 @@ unsigned long ZEXPORT crc32_z(crc, buf, len)
|
||||
#endif /* DYNAMIC_CRC_TABLE */
|
||||
|
||||
/* Pre-condition the CRC */
|
||||
- crc ^= 0xffffffff;
|
||||
+ crc = (~crc) & 0xffffffff;
|
||||
|
||||
#ifdef W
|
||||
|
||||
@@ -1077,7 +1077,7 @@ uLong ZEXPORT crc32_combine64(crc1, crc2, len2)
|
||||
#ifdef DYNAMIC_CRC_TABLE
|
||||
once(&made, make_crc_table);
|
||||
#endif /* DYNAMIC_CRC_TABLE */
|
||||
- return multmodp(x2nmodp(len2, 3), crc1) ^ crc2;
|
||||
+ return multmodp(x2nmodp(len2, 3), crc1) ^ (crc2 & 0xffffffff);
|
||||
}
|
||||
|
||||
/* ========================================================================= */
|
||||
@@ -1112,5 +1112,5 @@ uLong crc32_combine_op(crc1, crc2, op)
|
||||
uLong crc2;
|
||||
uLong op;
|
||||
{
|
||||
- return multmodp(op, crc1) ^ crc2;
|
||||
+ return multmodp(op, crc1) ^ (crc2 & 0xffffffff);
|
||||
}
|
Reference in New Issue