gnu: VLC: Remove obsolete patch.
* gnu/packages/patches/vlc-qt-5.15.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/video.scm (vlc)[source]: Remove patch.master
parent
0e2abacae6
commit
5aeee07cc9
|
@ -1710,7 +1710,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/vboot-utils-fix-format-load-address.patch \
|
||||
%D%/packages/patches/vboot-utils-fix-tests-show-contents.patch \
|
||||
%D%/packages/patches/vboot-utils-skip-test-workbuf.patch \
|
||||
%D%/packages/patches/vlc-qt-5.15.patch \
|
||||
%D%/packages/patches/vigra-python-compat.patch \
|
||||
%D%/packages/patches/vinagre-newer-freerdp.patch \
|
||||
%D%/packages/patches/vinagre-newer-rdp-parameters.patch \
|
||||
|
|
|
@ -1,56 +0,0 @@
|
|||
Fix build of VLC with Qt 5.15. Otherwise it fails like this:
|
||||
|
||||
------
|
||||
In file included from gui/qt/util/timetooltip.moc.cpp:10:0:
|
||||
gui/qt/util/timetooltip.hpp:49:18: error: field ‘mPainterPath’ has incomplete type ‘QPainterPath’
|
||||
QPainterPath mPainterPath;
|
||||
^~~~~~~~~~~~
|
||||
In file included from /gnu/store/jsxxnsdvij5mrrv6c0kj0261k0f44xlz-qtbase-5.15.2/include/qt5/QtGui/qbrush.h:49:0,
|
||||
from /gnu/store/jsxxnsdvij5mrrv6c0kj0261k0f44xlz-qtbase-5.15.2/include/qt5/QtGui/qpalette.h:46,
|
||||
from /gnu/store/jsxxnsdvij5mrrv6c0kj0261k0f44xlz-qtbase-5.15.2/include/qt5/QtWidgets/qwidget.h:48,
|
||||
from /gnu/store/jsxxnsdvij5mrrv6c0kj0261k0f44xlz-qtbase-5.15.2/include/qt5/QtWidgets/QWidget:1,
|
||||
from gui/qt/util/timetooltip.hpp:27,
|
||||
from gui/qt/util/timetooltip.moc.cpp:10:
|
||||
/gnu/store/jsxxnsdvij5mrrv6c0kj0261k0f44xlz-qtbase-5.15.2/include/qt5/QtGui/qmatrix.h:54:7: note: forward declaration of ‘class QPainterPath’
|
||||
class QPainterPath;
|
||||
^~~~~~~~~~~~
|
||||
make[4]: *** [Makefile:25852: gui/qt/util/libqt_plugin_la-timetooltip.moc.lo] Error 1
|
||||
------
|
||||
|
||||
diff --git a/modules/gui/qt/components/playlist/views.cpp b/modules/gui/qt/components/playlist/views.cpp
|
||||
index 24db9d9..73c1779 100644
|
||||
--- a/modules/gui/qt/components/playlist/views.cpp
|
||||
+++ b/modules/gui/qt/components/playlist/views.cpp
|
||||
@@ -27,6 +27,7 @@
|
||||
#include "input_manager.hpp" /* THEMIM */
|
||||
|
||||
#include <QPainter>
|
||||
+#include <QPainterPath>
|
||||
#include <QRect>
|
||||
#include <QStyleOptionViewItem>
|
||||
#include <QFontMetrics>
|
||||
diff --git a/modules/gui/qt/dialogs/plugins.cpp b/modules/gui/qt/dialogs/plugins.cpp
|
||||
index d233382..69728eb 100644
|
||||
--- a/modules/gui/qt/dialogs/plugins.cpp
|
||||
+++ b/modules/gui/qt/dialogs/plugins.cpp
|
||||
@@ -53,6 +53,7 @@
|
||||
#include <QListView>
|
||||
#include <QListWidget>
|
||||
#include <QPainter>
|
||||
+#include <QPainterPath>
|
||||
#include <QStyleOptionViewItem>
|
||||
#include <QKeyEvent>
|
||||
#include <QPushButton>
|
||||
diff --git a/modules/gui/qt/util/timetooltip.hpp b/modules/gui/qt/util/timetooltip.hpp
|
||||
index 6a1329e..9f50b18 100644
|
||||
--- a/modules/gui/qt/util/timetooltip.hpp
|
||||
+++ b/modules/gui/qt/util/timetooltip.hpp
|
||||
@@ -25,6 +25,7 @@
|
||||
#include "qt.hpp"
|
||||
|
||||
#include <QWidget>
|
||||
+#include <QPainterPath>
|
||||
|
||||
class TimeTooltip : public QWidget
|
||||
{
|
||||
|
|
@ -1773,7 +1773,6 @@ videoformats depend on the configuration flags of ffmpeg.")
|
|||
"https://download.videolan.org/pub/videolan/vlc/"
|
||||
(car (string-split version #\-))
|
||||
"/vlc-" version ".tar.xz"))
|
||||
(patches (search-patches "vlc-qt-5.15.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"0ygqihw2c5vvzv8950dlf7rdwz1cpz1668jgyja604ljibrmix7g"))))
|
||||
|
|
Reference in New Issue