gnu: VLC: Update to 3.0.10.
* gnu/packages/patches/vlc-fix-test_libvlc_slaves.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/video.scm (vlc): Update to 3.0.10. [source]: Remove obsolete patch. [arguments]: Remove obsolete workarounds for libssh and fribidi compatibility issues in 'patch-source' phase.master
parent
65fd3f0ac3
commit
5af110868c
|
@ -1519,7 +1519,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/vinagre-newer-freerdp.patch \
|
%D%/packages/patches/vinagre-newer-freerdp.patch \
|
||||||
%D%/packages/patches/vinagre-newer-rdp-parameters.patch \
|
%D%/packages/patches/vinagre-newer-rdp-parameters.patch \
|
||||||
%D%/packages/patches/virglrenderer-CVE-2017-6386.patch \
|
%D%/packages/patches/virglrenderer-CVE-2017-6386.patch \
|
||||||
%D%/packages/patches/vlc-fix-test_libvlc_slaves.patch \
|
|
||||||
%D%/packages/patches/vorbis-tools-CVE-2014-9638+CVE-2014-9639.patch \
|
%D%/packages/patches/vorbis-tools-CVE-2014-9638+CVE-2014-9639.patch \
|
||||||
%D%/packages/patches/vorbis-tools-CVE-2014-9640.patch \
|
%D%/packages/patches/vorbis-tools-CVE-2014-9640.patch \
|
||||||
%D%/packages/patches/vorbis-tools-CVE-2015-6749.patch \
|
%D%/packages/patches/vorbis-tools-CVE-2015-6749.patch \
|
||||||
|
|
|
@ -1,35 +0,0 @@
|
||||||
From 4186c94104ee528abd6860611b49515f3e6ec644 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Thomas Guillem <thomas@gllm.fr>
|
|
||||||
Date: Fri, 18 Oct 2019 10:34:07 +0200
|
|
||||||
Subject: [PATCH] input/item: sort before attaching slaves
|
|
||||||
|
|
||||||
The order of readdir() is completely filesystem dependent.
|
|
||||||
|
|
||||||
Slaves should be attached using the same order across multiple OSses/access
|
|
||||||
modules.
|
|
||||||
|
|
||||||
This fixes the test_libvlc_slaves on some system when the entry order from
|
|
||||||
readdir() is different.
|
|
||||||
|
|
||||||
This patch need to be backported to VLC 3.0.
|
|
||||||
---
|
|
||||||
src/input/item.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/input/item.c b/src/input/item.c
|
|
||||||
index e8db39ca28..fbd74cc95f 100644
|
|
||||||
--- a/src/input/item.c
|
|
||||||
+++ b/src/input/item.c
|
|
||||||
@@ -1809,8 +1809,8 @@ void vlc_readdir_helper_finish(struct vlc_readdir_helper *p_rdh, bool b_success)
|
|
||||||
{
|
|
||||||
if (b_success)
|
|
||||||
{
|
|
||||||
- rdh_attach_slaves(p_rdh, p_rdh->p_node);
|
|
||||||
rdh_sort(p_rdh->p_node);
|
|
||||||
+ rdh_attach_slaves(p_rdh, p_rdh->p_node);
|
|
||||||
}
|
|
||||||
free(p_rdh->psz_ignored_exts);
|
|
||||||
|
|
||||||
--
|
|
||||||
2.20.1
|
|
||||||
|
|
|
@ -1191,7 +1191,7 @@ videoformats depend on the configuration flags of ffmpeg.")
|
||||||
(define-public vlc
|
(define-public vlc
|
||||||
(package
|
(package
|
||||||
(name "vlc")
|
(name "vlc")
|
||||||
(version "3.0.8")
|
(version "3.0.10")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append
|
(uri (string-append
|
||||||
|
@ -1200,13 +1200,7 @@ videoformats depend on the configuration flags of ffmpeg.")
|
||||||
"/vlc-" version ".tar.xz"))
|
"/vlc-" version ".tar.xz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1xmxjpyzdhabchwncz6lvx3kzvl7fz9c42bkv3nbj68albs9w570"))
|
"0cackl1084hcmg4myf3kvjvd6sjxmzn0c0qkmanz6brvgzyanrm9"))))
|
||||||
(patches
|
|
||||||
(search-patches
|
|
||||||
;; TODO: The test "libvlc_slaves" fails. Applied upstream as
|
|
||||||
;; <https://git.videolan.org/?p=vlc.git;a=commit;h=4186c94104ee528abd6860611b49515f3e6ec644>.
|
|
||||||
;; Try removing it in 3.0.9.
|
|
||||||
"vlc-fix-test_libvlc_slaves.patch"))))
|
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(native-inputs
|
(native-inputs
|
||||||
`(("flex" ,flex)
|
`(("flex" ,flex)
|
||||||
|
@ -1311,20 +1305,6 @@ videoformats depend on the configuration flags of ffmpeg.")
|
||||||
;; which fails in our sandboxed build system
|
;; which fails in our sandboxed build system
|
||||||
(substitute* "test/run_vlc.sh"
|
(substitute* "test/run_vlc.sh"
|
||||||
(("./vlc --ignore-config") "echo"))
|
(("./vlc --ignore-config") "echo"))
|
||||||
|
|
||||||
;; modules/text_renderer/freetype/text_layout.c uses a
|
|
||||||
;; now-deprecated interface 'fribidi_get_par_embedding_levels'
|
|
||||||
;; from fribidi.h, so for now we enable the use of deprecated
|
|
||||||
;; fribidi interfaces from this file.
|
|
||||||
;; FIXME: Try removing this for vlc >= 3.0.3.
|
|
||||||
(substitute* "modules/text_renderer/freetype/text_layout.c"
|
|
||||||
(("# define FRIBIDI_NO_DEPRECATED 1") ""))
|
|
||||||
|
|
||||||
;; Fix build with libssh2 > 1.8.0:
|
|
||||||
;; <https://trac.videolan.org/vlc/ticket/22060>
|
|
||||||
;; <https://git.videolan.org/?p=vlc.git;a=commit;h=11449b5cd8b415768e010d9b7c1d6ba3cea21f82>
|
|
||||||
(substitute* "modules/access/sftp.c"
|
|
||||||
(("010801") "010900"))
|
|
||||||
#t)))
|
#t)))
|
||||||
(add-after 'strip 'regenerate-plugin-cache
|
(add-after 'strip 'regenerate-plugin-cache
|
||||||
(lambda* (#:key outputs #:allow-other-keys)
|
(lambda* (#:key outputs #:allow-other-keys)
|
||||||
|
|
Reference in New Issue