diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ad5091ffed..74d617a0f9 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7818,39 +7818,26 @@ use this package to insert PostScript files, in addition to PDF files.")
 (define-deprecated-package texlive-latex-pdfpages texlive-pdfpages)
 
 (define-public texlive-stix2-otf
-  (let ((base (simple-texlive-package
-               "texlive-stix2-otf"
-               (list "/doc/fonts/stix2-otf/"
-                     "/fonts/opentype/public/stix2-otf/")
-               (base32 "0i7rd1wn5jgm3gbi779gy78apz63w034ck4pn73xw6s10zgjzmgl")
-               ;; Building these fonts requires FontLab, which is nonfree.
-               #:trivial? #t)))
-    (package
-      (inherit base)
-      (arguments
-       (substitute-keyword-arguments (package-arguments base)
-         ((#:phases phases)
-          #~(modify-phases #$phases
-              (add-after 'install 'symlink-fonts-to-system-fonts-prefix
-                ;; This is so that fontconfig can locate the fonts, such as
-                ;; when using xetex or xelatex.
-                (lambda _
-                  (let ((system-fonts-prefix (string-append #$output
-                                                            "/share/fonts")))
-                    (mkdir-p system-fonts-prefix)
-                    (symlink (string-append
-                              #$output "/share/texmf-dist/fonts/opentype"
-                              "/public/stix2-otf")
-                             (string-append system-fonts-prefix
-                                            "/stix2-otf")))))))))
-      (home-page "https://www.stixfonts.org/")
-      (synopsis "OpenType Unicode text and maths fonts")
-      (description "The Scientific and Technical Information eXchange (STIX)
-fonts are intended to satisfy the demanding needs of authors, publishers,
-printers, and others working in the scientific, medical, and technical fields.
-They combine a comprehensive Unicode-based collection of mathematical symbols
-and alphabets with a set of text faces suitable for professional publishing.")
-      (license license:silofl1.1))))
+  (package
+    (name "texlive-stix2-otf")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/stix2-otf/"
+                   "fonts/opentype/public/stix2-otf/")
+             (base32
+              "0i7rd1wn5jgm3gbi779gy78apz63w034ck4pn73xw6s10zgjzmgl")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/stix2-otf")
+    (synopsis "OpenType Unicode text and maths fonts")
+    (description
+     "The Scientific and Technical Information eXchange (STIX) fonts are
+intended to satisfy the demanding needs of authors, publishers, printers, and
+others working in the scientific, medical, and technical fields.  They combine
+a comprehensive Unicode-based collection of mathematical symbols and alphabets
+with a set of text faces suitable for professional publishing.")
+    (license license:silofl1.1)))
 
 (define-public texlive-sidecap
   (package