gnu: biber: Update to 2.19.
* gnu/packages/texlive.scm (biber): Update to 2.19. Remove patch. * gnu/packages/patches/biber-adapt-perl-5.36.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Unregister patch.
parent
8b71ddf91a
commit
6274dcbdbd
|
@ -946,7 +946,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/bazaar-CVE-2017-14176.patch \
|
||||
%D%/packages/patches/bc-fix-cross-compilation.patch \
|
||||
%D%/packages/patches/bdb-5.3-atomics-on-gcc-9.patch \
|
||||
%D%/packages/patches/biber-adapt-perl-5.36.patch \
|
||||
%D%/packages/patches/bind-re-add-attr-constructor-priority.patch \
|
||||
%D%/packages/patches/brightnessctl-elogind-support.patch \
|
||||
%D%/packages/patches/bsd-games-2.17-64bit.patch \
|
||||
|
|
|
@ -1,40 +0,0 @@
|
|||
From d9e961710074d266ad6bdf395c98868d91952088 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
|
||||
Date: Wed, 25 May 2022 12:41:59 +0200
|
||||
Subject: [PATCH] Adapt to Perl 5.36
|
||||
|
||||
A developmental release of Perl 5.36.0 fails to run tests with:
|
||||
|
||||
$ perl -Ilib t/basic-misc.t
|
||||
1..72
|
||||
Can't modify undef operator in scalar assignment at lib/Biber/Section.pm line 433, near "undef;"
|
||||
Compilation failed in require at lib/Biber.pm line 24.
|
||||
BEGIN failed--compilation aborted at lib/Biber.pm line 24.
|
||||
Compilation failed in require at t/basic-misc.t line 11.
|
||||
BEGIN failed--compilation aborted at t/basic-misc.t line 11.
|
||||
# Looks like your test exited with 255 before it could output anything.
|
||||
|
||||
This is because of a missing semicolon between commands in
|
||||
del_everykeys(). The new perl is more strict and raises a compile-time
|
||||
error:
|
||||
|
||||
$ perl -e '$a = undef $b = undef;'
|
||||
Can't modify undef operator in scalar assignment at -e line 1, near "undef;"
|
||||
Execution of -e aborted due to compilation errors.
|
||||
---
|
||||
lib/Biber/Section.pm | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/lib/Biber/Section.pm b/lib/Biber/Section.pm
|
||||
index 03ed69a51..a78942f57 100644
|
||||
--- a/lib/Biber/Section.pm
|
||||
+++ b/lib/Biber/Section.pm
|
||||
@@ -429,7 +429,7 @@ sub add_everykey {
|
||||
|
||||
sub del_everykeys {
|
||||
my $self = shift;
|
||||
- $self->{everykey} = undef
|
||||
+ $self->{everykey} = undef;
|
||||
$self->{everykey_lc} = undef;
|
||||
return;
|
||||
}
|
|
@ -455,7 +455,7 @@ This package contains the complete TeX Live distribution.")
|
|||
;; checking the Biber/BibLaTeX compatibility matrix in the BibLaTeX manual
|
||||
;; at <https://ctan.org/pkg/biblatex>.
|
||||
(name "biber")
|
||||
(version "2.17")
|
||||
(version "2.19")
|
||||
(source (origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
|
@ -464,8 +464,7 @@ This package contains the complete TeX Live distribution.")
|
|||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32
|
||||
"0b8a8lldz9xx3yr1h5bh2akbqq1ljydqyhr6bdf6qd7ncqvsrpaf"))
|
||||
(patches (search-patches "biber-adapt-perl-5.36.patch"))))
|
||||
"1cl7hrflbw61wc95rnjdwyx8cip3jmpn3ic2zjfm0pdp86f2i9rj"))))
|
||||
(build-system perl-build-system)
|
||||
(arguments
|
||||
`(#:phases
|
||||
|
|
Reference in New Issue