me
/
guix
Archived
1
0
Fork 0

gnu: QEMU: Fix compatibility with Meson 0.58.

* gnu/packages/patches/qemu-meson-compat.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/virtualization.scm (qemu)[source](patches): Add it.
master
Marius Bakke 2021-06-13 15:07:13 +02:00
parent 0368d4708c
commit 628a6c51d4
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
3 changed files with 29 additions and 0 deletions

View File

@ -1623,6 +1623,7 @@ dist_patch_DATA = \
%D%/packages/patches/pypy3-7.3.1-fix-tests.patch \
%D%/packages/patches/qemu-build-info-manual.patch \
%D%/packages/patches/qemu-CVE-2021-20203.patch \
%D%/packages/patches/qemu-meson-compat.patch \
%D%/packages/patches/qemu-glibc-2.27.patch \
%D%/packages/patches/qemu-glibc-2.30.patch \
%D%/packages/patches/qpdfview-qt515-compat.patch \

View File

@ -0,0 +1,27 @@
Fix a build failure that occurs with newer versions of Meson when
gdbus-codegen is unavailable.
Taken from upstream:
https://gitlab.com/qemu-project/qemu/-/commit/5ecfb76ccc056eb6127e44268e475827ae73b9e0
diff --git a/configure b/configure
--- a/configure
+++ b/configure
@@ -3341,7 +3341,7 @@ if ! test "$gio" = "no"; then
gio_cflags=$($pkg_config --cflags gio-2.0)
gio_libs=$($pkg_config --libs gio-2.0)
gdbus_codegen=$($pkg_config --variable=gdbus_codegen gio-2.0)
- if [ ! -x "$gdbus_codegen" ]; then
+ if ! has "$gdbus_codegen"; then
gdbus_codegen=
fi
# Check that the libraries actually work -- Ubuntu 18.04 ships
@@ -5704,6 +5704,8 @@ if test "$gio" = "yes" ; then
echo "CONFIG_GIO=y" >> $config_host_mak
echo "GIO_CFLAGS=$gio_cflags" >> $config_host_mak
echo "GIO_LIBS=$gio_libs" >> $config_host_mak
+fi
+if test "$gdbus_codegen" != "" ; then
echo "GDBUS_CODEGEN=$gdbus_codegen" >> $config_host_mak
fi
echo "CONFIG_TLS_PRIORITY=\"$tls_priority\"" >> $config_host_mak

View File

@ -152,6 +152,7 @@
(base32
"1f9hz8rf12jm8baa7kda34yl4hyl0xh0c4ap03krfjx23i3img47"))
(patches (search-patches "qemu-CVE-2021-20203.patch"
"qemu-meson-compat.patch"
"qemu-build-info-manual.patch"))
(modules '((guix build utils)))
(snippet