me
/
guix
Archived
1
0
Fork 0

gnu: picard: Update to 2.4.4.

* gnu/packages/music.scm (picard): Update to 2.4.4.
  [native-inputs]: Add python-dateutil.
  [source]: Add temporary patch to fix failing test due to missing "."
  	    in temporary filename.
* gnu/packages/patches/picard-fix-id3-rename-test.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
master
raingloom 2020-09-05 17:00:05 +02:00 committed by Ludovic Courtès
parent 4913e8ede0
commit 62cf60da7a
No known key found for this signature in database
GPG Key ID: 090B11993D9AEBB5
3 changed files with 17 additions and 3 deletions

View File

@ -1429,6 +1429,7 @@ dist_patch_DATA = \
%D%/packages/patches/perl-module-pluggable-search.patch \
%D%/packages/patches/perl-reproducible-build-date.patch \
%D%/packages/patches/perl-www-curl-remove-symbol.patch \
%D%/packages/patches/picard-fix-id3-rename-test.patch \
%D%/packages/patches/picprog-non-intel-support.patch \
%D%/packages/patches/pidgin-add-search-path.patch \
%D%/packages/patches/pidgin-libnm.patch \

View File

@ -2916,7 +2916,7 @@ event-based scripts for scrobbling, notifications, etc.")
(define-public picard
(package
(name "picard")
(version "2.1.3")
(version "2.4.4")
(source (origin
(method url-fetch)
(uri (string-append
@ -2924,7 +2924,8 @@ event-based scripts for scrobbling, notifications, etc.")
"picard/picard-" version ".tar.gz"))
(sha256
(base32
"19w5k3bf4886gdycxjds9nkjvir0gwy2r5cqkz0lbls4ikk4y14f"))))
"1c5l7i43jaj3s4wklc0cba6nn2x9cmpcggk4q4h9m1bci2xilsiy"))
(patches (search-patches "picard-fix-id3-rename-test.patch"))))
(build-system python-build-system)
(arguments
'(#:use-setuptools? #f
@ -2943,7 +2944,8 @@ event-based scripts for scrobbling, notifications, etc.")
(assoc-ref inputs "chromaprint") "/bin/fpcalc")))
#t)))))
(native-inputs
`(("gettext" ,gettext-minimal)))
`(("gettext" ,gettext-minimal)
("python-dateutil" ,python-dateutil)))
(inputs
`(("chromaprint" ,chromaprint)
("python-discid" ,python-discid)

View File

@ -0,0 +1,11 @@
Index: b/test/formats/test_id3.py
===================================================================
--- a/test/formats/test_id3.py
+++ b/test/formats/test_id3.py
@@ -266,5 +266,5 @@
def test_rename_txxx_tags(self):
file_path = os.path.join('test', 'data', 'test-id3-rename-tags.mp3')
- filename = self.copy_file_tmp(file_path, 'mp3')
+ filename = self.copy_file_tmp(file_path, '.mp3')
raw_metadata = load_raw(filename)
self.assertIn('TXXX:Artists', raw_metadata)