gnu: Remove python2-subprocess32.
* gnu/packages/python-xyz.scm (python2-subprocess32): Delete variable. * gnu/packages/patches/python2-subprocess32-disable-input-test.patch: Delete file. * gnu/local.mk (dist_patch_DATA): De-register it.
parent
787e582c47
commit
64c86457db
|
@ -1721,7 +1721,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/python-robotframework-sshlibrary-rf5-compat.patch \
|
||||
%D%/packages/patches/python-seaborn-kde-test.patch \
|
||||
%D%/packages/patches/python-seaborn-2690.patch \
|
||||
%D%/packages/patches/python2-subprocess32-disable-input-test.patch \
|
||||
%D%/packages/patches/python-unittest2-python3-compat.patch \
|
||||
%D%/packages/patches/python-unittest2-remove-argparse.patch \
|
||||
%D%/packages/patches/python-versioneer-guix-support.patch \
|
||||
|
|
|
@ -1,18 +0,0 @@
|
|||
This test tries to send a KeyboardInterrupt, which does
|
||||
not work in the build environment.
|
||||
|
||||
--- a/test_subprocess32.py 2017-03-06 22:21:49.334045485 +0100
|
||||
+++ b/test_subprocess32.py 2017-03-06 22:22:02.490439949 +0100
|
||||
@@ -1299,12 +1299,6 @@
|
||||
getattr(p, method)(*args)
|
||||
return p
|
||||
|
||||
- def test_send_signal(self):
|
||||
- p = self._kill_process('send_signal', signal.SIGINT)
|
||||
- _, stderr = p.communicate()
|
||||
- self.assertIn('KeyboardInterrupt', stderr)
|
||||
- self.assertNotEqual(p.wait(), 0)
|
||||
-
|
||||
def test_kill(self):
|
||||
p = self._kill_process('kill')
|
||||
_, stderr = p.communicate()
|
|
@ -14401,43 +14401,6 @@ to the Python ecosystem.")
|
|||
3.2.3 for use with older versions of Python and PyPy.")
|
||||
(license license:expat)))
|
||||
|
||||
(define-public python2-subprocess32
|
||||
(package
|
||||
(name "python2-subprocess32")
|
||||
(version "3.2.7")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (pypi-uri "subprocess32" version))
|
||||
(sha256
|
||||
(base32
|
||||
"14350dhhlhyz5gqzi3lihn9m6lvskx5mcb20srx1kgsk9i50li8y"))
|
||||
(patches
|
||||
(search-patches "python2-subprocess32-disable-input-test.patch"))))
|
||||
(build-system python-build-system)
|
||||
(arguments
|
||||
`(#:python ,python-2
|
||||
;; The test suite fails with Python > 2.7.13:
|
||||
;; import test.support
|
||||
;; ImportError: No module named support
|
||||
#:tests? #f
|
||||
#:phases
|
||||
(modify-phases %standard-phases
|
||||
(add-after 'unpack 'patch-/bin/sh
|
||||
(lambda _
|
||||
(substitute* '("subprocess32.py"
|
||||
"test_subprocess32.py")
|
||||
(("/bin/sh") (which "sh")))
|
||||
#t)))))
|
||||
(home-page "https://github.com/google/python-subprocess32")
|
||||
(synopsis "Backport of the subprocess module from Python 3.2")
|
||||
(description
|
||||
"This is a backport of the @code{subprocess} standard library module
|
||||
from Python 3.2 and 3.3 for use on Python 2. It includes bugfixes and some
|
||||
new features. On POSIX systems it is guaranteed to be reliable when used
|
||||
in threaded applications. It includes timeout support from Python 3.3 but
|
||||
otherwise matches 3.2’s API.")
|
||||
(license license:psfl)))
|
||||
|
||||
(define-public python-promise
|
||||
(package
|
||||
(name "python-promise")
|
||||
|
|
Reference in New Issue