me
/
guix
Archived
1
0
Fork 0

gnu: guile-static: Add missing hunk in guile-default-utf8.patch.

Before that, the ‘guile’ binary from ‘guile-static-stripped’ would abort
as it tries and fails to open an iconv descriptor for ISO-8859-1.

* gnu/packages/patches/guile-default-utf8.patch: Add missing hunk for
  Guile 2.0.9.
master
Ludovic Courtès 2013-08-21 11:33:27 +02:00
parent db90b40dfd
commit 682cb00461
1 changed files with 11 additions and 0 deletions

View File

@ -109,3 +109,14 @@ index 5d0db23..8266247 100644
(enum iconv_ilseq_handler) handler, NULL,
&buf, &len);
--- guile-2.0.9/libguile/ports.c 2013-08-21 11:08:50.000000000 +0200
+++ guile-2.0.9/libguile/ports.c 2013-08-21 11:09:47.000000000 +0200
@@ -2512,7 +2512,7 @@ scm_i_port_iconv_descriptors (SCM port,
const char *precise_encoding;
if (!pt->encoding)
- pt->encoding = "ISO-8859-1";
+ pt->encoding = "UTF-8";
/* If the specified encoding is UTF-16 or UTF-32, then make
that more precise by deciding what byte order to use. */