me
/
guix
Archived
1
0
Fork 0

gnu: openssh: Build fix for the Hurd.

* gnu/packages/patches/openssh-hurd.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/ssh.scm (openssh)[source]: Use it.
[inputs]: If hurd-target? is true, omit xauth.
master
Jan (janneke) Nieuwenhuizen 2020-04-07 17:48:45 +02:00 committed by Jan Nieuwenhuizen
parent a58f3708b2
commit 6a39cbe722
No known key found for this signature in database
GPG Key ID: F3C1A0D9C1D65273
3 changed files with 37 additions and 1 deletions

View File

@ -1288,6 +1288,7 @@ dist_patch_DATA = \
%D%/packages/patches/openjdk-10-idlj-reproducibility.patch \
%D%/packages/patches/openmpi-mtl-priorities.patch \
%D%/packages/patches/openocd-nrf52.patch \
%D%/packages/patches/openssh-hurd.patch \
%D%/packages/patches/openssl-runpath.patch \
%D%/packages/patches/openssl-1.1-c-rehash-in.patch \
%D%/packages/patches/openssl-c-rehash-in.patch \

View File

@ -0,0 +1,30 @@
Author: Jan (janneke) Nieuwenhuizen" <janneke@gnu.org>
Not upstreamed.
From 1ddae040d67e9a4ebcc3e1b95af1bff12c0f086b Mon Sep 17 00:00:00 2001
From: "Jan (janneke) Nieuwenhuizen" <janneke@gnu.org>
Date: Tue, 7 Apr 2020 17:41:05 +0200
Subject: [PATCH] Build fix for the Hurd.
* gss-serv.c (ssh_gssapi_acquire_cred): Use HOST_NAME_MAX instead of
MAXHOSTNAMELEN.
---
gss-serv.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/gss-serv.c b/gss-serv.c
index 1d47870e7..22081c6f1 100644
--- a/gss-serv.c
+++ b/gss-serv.c
@@ -107,7 +107,7 @@ ssh_gssapi_acquire_cred(Gssctxt *ctx)
gss_create_empty_oid_set(&status, &oidset);
gss_add_oid_set_member(&status, ctx->oid, &oidset);
- if (gethostname(lname, MAXHOSTNAMELEN)) {
+ if (gethostname(lname, HOST_NAME_MAX)) {
gss_release_oid_set(&status, &oidset);
return (-1);
}
--
2.26.0

View File

@ -13,6 +13,7 @@
;;; Copyright © 2018 Manuel Graf <graf@init.at>
;;; Copyright © 2019 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2019, 2020 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@ -42,6 +43,7 @@
#:use-module (gnu packages groff)
#:use-module (gnu packages guile)
#:use-module (gnu packages libedit)
#:use-module (gnu packages hurd)
#:use-module (gnu packages linux)
#:use-module (gnu packages logging)
#:use-module (gnu packages m4)
@ -136,6 +138,7 @@ a server that supports the SSH-2 protocol.")
(method url-fetch)
(uri (string-append "mirror://openbsd/OpenSSH/portable/"
"openssh-" version ".tar.gz"))
(patches (search-patches "openssh-hurd.patch"))
(sha256
(base32
"0wg6ckzvvklbzznijxkk28fb8dnwyjd0w30ra0afwv6gwr8m34j3"))))
@ -147,7 +150,9 @@ a server that supports the SSH-2 protocol.")
("pam" ,linux-pam)
("mit-krb5" ,mit-krb5)
("zlib" ,zlib)
("xauth" ,xauth))) ; for 'ssh -X' and 'ssh -Y'
,@(if (hurd-target?)
'()
`(("xauth" ,xauth))))) ; for 'ssh -X' and 'ssh -Y'
(arguments
`(#:test-target "tests"
;; Otherwise, the test scripts try to use a nonexistent directory and