me
/
guix
Archived
1
0
Fork 0

gnu: Remove texlive's dependence on ruby-rspec and ruby-byebug.

Motivation: Break the dependency chain from guix to mariadb.

Prior to this patch:

$ guix graph --path guix mariadb
guix@1.3.0-27.598f728
po4a@0.63
texlive-tiny@59745
texlive-latex-base@59745
texlive-hyphen-afrikaans@59745
ruby-hydra@0.0-0.5abfa37
ruby-byebug@11.1.3
ruby-rubocop@1.10.0
ruby-parallel@1.21.0
ruby-mysql2@0.5.2
mariadb@10.5.12

As of this patch:

$ ./pre-inst-env guix graph --path guix mariadb
guix graph: error: no path from 'guix@1.3.0-27.598f728' to 'mariadb@10.5.12'

* gnu/local.mk (dist_patch_DATA): Add texlive-hyph-utf8-no-byebug.patch.
* gnu/packages/patches/texlive-hyph-utf8-no-byebug.patch: New file.
* gnu/packages/tex.scm (hyph-utf8-scripts): Add patch.
(texlive-hyphen-package): Depend on ruby-hydra-minimal.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
master
Tom Fitzhenry 2022-06-24 21:08:35 +10:00 committed by Ludovic Courtès
parent bb907402a6
commit 6ba74ab29c
No known key found for this signature in database
GPG Key ID: 090B11993D9AEBB5
3 changed files with 16 additions and 1 deletions

View File

@ -1851,6 +1851,7 @@ dist_patch_DATA = \
%D%/packages/patches/telegram-purple-adjust-test.patch \
%D%/packages/patches/texi2html-document-encoding.patch \
%D%/packages/patches/texi2html-i18n.patch \
%D%/packages/patches/texlive-hyph-utf8-no-byebug.patch \
%D%/packages/patches/thefuck-test-environ.patch \
%D%/packages/patches/tidy-CVE-2015-5522+5523.patch \
%D%/packages/patches/timescaledb-flaky-test.patch \

View File

@ -0,0 +1,13 @@
Description: Avoid dependency on byebug to reduce package closure
significantly, see https://issues.guix.gnu.org/55997
diff --git a/lib/tex/hyphen/language.rb b/lib/tex/hyphen/language.rb
index 12831417..df6daa39 100644
--- a/lib/tex/hyphen/language.rb
+++ b/lib/tex/hyphen/language.rb
@@ -1,6 +1,5 @@
require 'yaml'
require 'hydra'
-require 'byebug'
require_relative 'path'

View File

@ -157,6 +157,7 @@ copied to their outputs; otherwise the TEXLIVE-BUILD-SYSTEM is used."
(file-name (string-append "hyph-utf8-scripts-"
(number->string %texlive-revision)
"-checkout"))
(patches (search-patches "texlive-hyph-utf8-no-byebug.patch"))
(sha256
(base32
"04xzf5gr3ylyh3ls09imrx4mwq3qp1k97r9njzlan6hlff875rx2"))))
@ -225,7 +226,7 @@ files from LOCATIONS with expected checksum HASH. CODE is not currently in use.
(invoke "ruby" "generate-ptex-patterns.rb")))))))))
(native-inputs
`(("ruby" ,ruby)
("ruby-hydra" ,ruby-hydra)
("ruby-hydra-minimal" ,ruby-hydra-minimal)
("hyph-utf8-scripts" ,hyph-utf8-scripts)))
(home-page "https://ctan.org/pkg/hyph-utf8"))))