me
/
guix
Archived
1
0
Fork 0

gnu: emacs-xelb: Update to 0.19.

* gnu/packages/emacs-xyz.scm (emacs-xelb): Update to 0.19.
[source]: Remove patch.
[arguments]<#:phase>: Remove "/usr/bin/env".
* gnu/packages/patches/emacs-xelb-ignore-length-element.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Apply removal.

Change-Id: Ib7143de596043158eabdab93338d5178780434d8
master
Nicolas Goaziou 2024-06-18 21:55:26 +02:00
parent ef726bf8b7
commit 6c2a65e566
No known key found for this signature in database
GPG Key ID: DA00B4F048E92F2D
3 changed files with 4 additions and 24 deletions

View File

@ -1166,7 +1166,6 @@ dist_patch_DATA = \
%D%/packages/patches/emacs-telega-path-placeholder.patch \
%D%/packages/patches/emacs-telega-test-env.patch \
%D%/packages/patches/emacs-wordnut-require-adaptive-wrap.patch \
%D%/packages/patches/emacs-xelb-ignore-length-element.patch \
%D%/packages/patches/emacs-yasnippet-fix-empty-snippet-next.patch \
%D%/packages/patches/enblend-enfuse-reproducible.patch \
%D%/packages/patches/enjarify-setup-py.patch \

View File

@ -19728,16 +19728,14 @@ conflicts.")
(define-public emacs-xelb
(package
(name "emacs-xelb")
(version "0.18")
(version "0.19")
(source (origin
(method url-fetch)
(uri (string-append "https://elpa.gnu.org/packages/xelb-"
version ".tar"))
(sha256
(base32
"1fp5mzl63sh0h3ws4l5p4qgvi7ny8a3fj6k4dhqa98xgw2bx03v7"))
(patches
(search-patches "emacs-xelb-ignore-length-element.patch"))))
"1jgpb1ym7p2dfkk45zrv6w1jqgw66sb76jvjfjsqbrkx5605x2hk"))))
(build-system emacs-build-system)
;; The following functions and variables needed by emacs-xelb are
;; not included in emacs-minimal:
@ -19750,6 +19748,8 @@ conflicts.")
(modify-phases %standard-phases
(add-after 'unpack 'regenerate-el-files
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "xelb-gen"
(("/usr/bin/env") (which "env")))
(invoke "make"
(string-append "PROTO_PATH="
(assoc-ref inputs "xcb-proto")

View File

@ -1,19 +0,0 @@
Work around build failure due to XCB "length" element.
Patch from <https://sources.debian.org/patches/xelb/0.18-4/>.
Author: Martin <debacle@debian.org>
Bug: https://github.com/ch11ng/xelb/issues/28
Bug-Debian: https://bugs.debian.org/1017294
---
--- a/el_client.el
+++ b/el_client.el
@@ -519,7 +519,7 @@
(`list (xelb-parse-list node))
(`exprfield (xelb-parse-exprfield node))
(`switch (xelb-parse-switch node))
- ((or `comment `doc)) ;simply ignored
+ ((or `comment `doc `length)) ;simply ignored
(x (error "Unsupported structure content: <%s>" x))))
;; The car of the result shall be renamed to prevent duplication of slot names