gnu: Update gPodder to 3.10.16 and disable updater.
* gnu/packages/gpodder.scm (gpodder): Update to 3.10.16 and add patch. * gnu/packages/patches/gpodder-disable-updater.patch: New file * gnu/local.mk (dist_patch_DATA): Add patch Signed-off-by: Andreas Enge <andreas@enge.fr>master
parent
4daa12182d
commit
6c36daaac7
|
@ -1074,6 +1074,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/gobject-introspection-girepository.patch \
|
||||
%D%/packages/patches/go-skip-gc-test.patch \
|
||||
%D%/packages/patches/gpm-glibc-2.26.patch \
|
||||
%D%/packages/patches/gpodder-disable-updater.patch \
|
||||
%D%/packages/patches/gpsbabel-minizip.patch \
|
||||
%D%/packages/patches/gpsbabel-qstring.patch \
|
||||
%D%/packages/patches/grantlee-merge-theme-dirs.patch \
|
||||
|
|
|
@ -38,7 +38,7 @@
|
|||
(define-public gpodder
|
||||
(package
|
||||
(name "gpodder")
|
||||
(version "3.10.15")
|
||||
(version "3.10.16")
|
||||
(source
|
||||
(origin
|
||||
(method git-fetch)
|
||||
|
@ -47,8 +47,9 @@
|
|||
(commit version)))
|
||||
(sha256
|
||||
(base32
|
||||
"0ghbanj142n0hgydzfjmnkdgri2kswsjal3mn10c723kih4ir4yr"))
|
||||
(file-name (git-file-name name version))))
|
||||
"0pbpaasd7kj6y25nm45y1qyb9sxd4570f7g6zkfcpf6pa3nx7qkq"))
|
||||
(file-name (git-file-name name version))
|
||||
(patches (search-patches "gpodder-disable-updater.patch"))))
|
||||
(build-system python-build-system)
|
||||
(native-inputs
|
||||
`(("intltool" ,intltool)
|
||||
|
|
|
@ -0,0 +1,18 @@
|
|||
Description: Modify the default value for check_on_startup to false.
|
||||
This prevents an privacy/information disclosure unless the user
|
||||
explicitly opts-in for the update check.
|
||||
Forwarded: not-needed
|
||||
Origin: vendor
|
||||
Author: tony mancill <tmancill@debian.org>
|
||||
|
||||
--- a/src/gpodder/config.py
|
||||
+++ b/src/gpodder/config.py
|
||||
@@ -93,7 +93,7 @@
|
||||
|
||||
# Software updates from gpodder.org
|
||||
'software_update': {
|
||||
- 'check_on_startup': True, # check for updates on start
|
||||
+ 'check_on_startup': False, # check for updates on start
|
||||
'last_check': 0, # unix timestamp of last update check
|
||||
'interval': 5, # interval (in days) to check for updates
|
||||
},
|
Reference in New Issue